aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2010-06-29 19:01:08 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2010-06-29 19:01:08 +0000
commit12b2fc22128779a445376488bb7b04b7555e202d (patch)
treed92df4eae0aa15d0f32317885a35be963dc68c41 /emulators/virtualbox-ose
parentc6da10cdfd1837c3ec2d4db6cbaa82f5c3a3455e (diff)
downloadports-12b2fc22128779a445376488bb7b04b7555e202d.tar.gz
ports-12b2fc22128779a445376488bb7b04b7555e202d.zip
Notes
Diffstat (limited to 'emulators/virtualbox-ose')
-rw-r--r--emulators/virtualbox-ose/Makefile6
-rw-r--r--emulators/virtualbox-ose/distinfo12
-rw-r--r--emulators/virtualbox-ose/files/extrapatch-include-iprt-string.h10
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp30
4 files changed, 51 insertions, 7 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 63bb4c28de19..e9f9b96ad046 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= virtualbox-ose
-DISTVERSION= 3.2.4
+DISTVERSION= 3.2.6
CATEGORIES= emulators
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
@@ -169,6 +169,10 @@ PLIST_SUB+= I386="@comment "
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900012
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-include-iprt-string.h
+.endif
+
pre-everything::
.if ${ARCH} == "amd64"
.if !exists(/usr/lib32)
diff --git a/emulators/virtualbox-ose/distinfo b/emulators/virtualbox-ose/distinfo
index 2a3c85a25606..9d39c76b8d66 100644
--- a/emulators/virtualbox-ose/distinfo
+++ b/emulators/virtualbox-ose/distinfo
@@ -1,6 +1,6 @@
-MD5 (VirtualBox-3.2.4-OSE.tar.bz2) = 80052833c8d9fd162c29fbf91cedd3d0
-SHA256 (VirtualBox-3.2.4-OSE.tar.bz2) = 49e69fd357a80d2537a8139f970a23af9aa5e2f6c3179eefca69d1a75e1fb25c
-SIZE (VirtualBox-3.2.4-OSE.tar.bz2) = 57492454
-MD5 (VBoxGuestAdditions_3.2.4.iso) = 4000e6dce2a646f9ae948724720fd99f
-SHA256 (VBoxGuestAdditions_3.2.4.iso) = 74c711e7b89ca910ba124349a17248e14c4e4d47a7222be4030beaf9a7aad023
-SIZE (VBoxGuestAdditions_3.2.4.iso) = 33470464
+MD5 (VirtualBox-3.2.6-OSE.tar.bz2) = 65b822ab3c08ff882d9621101996dc14
+SHA256 (VirtualBox-3.2.6-OSE.tar.bz2) = 0cacfc0f6360d4052c16fef5b0ca262b71f9aec8ceb3bb6fb140477b9076ce48
+SIZE (VirtualBox-3.2.6-OSE.tar.bz2) = 57899455
+MD5 (VBoxGuestAdditions_3.2.6.iso) = 9542cf2fb93e1921a860930ac2a1d0de
+SHA256 (VBoxGuestAdditions_3.2.6.iso) = f2de08722ef70f7a7c7e5117a2d99aa0cced1ff93668aa81446f7e4cca47ebb0
+SIZE (VBoxGuestAdditions_3.2.6.iso) = 33503232
diff --git a/emulators/virtualbox-ose/files/extrapatch-include-iprt-string.h b/emulators/virtualbox-ose/files/extrapatch-include-iprt-string.h
new file mode 100644
index 000000000000..c22eebe25952
--- /dev/null
+++ b/emulators/virtualbox-ose/files/extrapatch-include-iprt-string.h
@@ -0,0 +1,10 @@
+--- include/iprt/string.h.orig 2010-04-28 01:02:16.000000000 +0200
++++ include/iprt/string.h 2010-06-17 16:20:14.000000000 +0200
+@@ -60,7 +60,6 @@
+ #if (defined(RT_OS_DARWIN) && defined(KERNEL)) \
+ || (defined(RT_OS_FREEBSD) && defined(_KERNEL))
+ RT_C_DECLS_BEGIN
+-void *memchr(const void *pv, int ch, size_t cb);
+ char *strpbrk(const char *pszStr, const char *pszChars);
+ RT_C_DECLS_END
+ #endif
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp b/emulators/virtualbox-ose/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp
new file mode 100644
index 000000000000..8e706db41fd3
--- /dev/null
+++ b/emulators/virtualbox-ose/files/patch-src-VBox-Main-freebsd-NetIf-freebsd.cpp
@@ -0,0 +1,30 @@
+--- src/VBox/Main/freebsd/NetIf-freebsd.cpp.orig 2010-06-07 15:34:44.000000000 +0300
++++ src/VBox/Main/freebsd/NetIf-freebsd.cpp 2010-06-18 16:45:31.000000000 +0300
+@@ -180,11 +180,16 @@
+ char *pBuf, *pNext;
+ int aiMib[6];
+ unsigned short u16DefaultIface;
++ int haveDefaultIface;
+
+ /* Get the index of the interface associated with default route. */
+ rc = getDefaultIfaceIndex(&u16DefaultIface, PF_INET);
+- if (RT_FAILURE(rc))
+- return rc;
++ haveDefaultIface = 1;
++ if (RT_FAILURE(rc)) {
++ Log(("NetIfList: Failed to get default route interface\n"));
++ haveDefaultIface = 0;
++ rc = VINF_SUCCESS;
++ }
+
+ aiMib[0] = CTL_NET;
+ aiMib[1] = PF_ROUTE;
+@@ -286,7 +291,7 @@
+ IfObj.createObject();
+ if (SUCCEEDED(IfObj->init(Bstr(pNew->szName), enmType, pNew)))
+ /* Make sure the default interface gets to the beginning. */
+- if (pIfMsg->ifm_index == u16DefaultIface)
++ if (haveDefaultIface == 1 && pIfMsg->ifm_index == u16DefaultIface)
+ list.push_front(IfObj);
+ else
+ list.push_back(IfObj);