aboutsummaryrefslogtreecommitdiff
path: root/emulators/vmsbackup
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1995-04-19 02:30:22 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1995-04-19 02:30:22 +0000
commit29bd1142784528edf2e989eb9cbffdd9fb7200df (patch)
tree442de8dcd40aeba12ece74d0f877b53c69504ec5 /emulators/vmsbackup
parent1c6d79f1fa68040a47d8939108a7c0340b9fbbe4 (diff)
downloadports-29bd1142784528edf2e989eb9cbffdd9fb7200df.tar.gz
ports-29bd1142784528edf2e989eb9cbffdd9fb7200df.zip
vmsbackup: read VMS backup tapes
Reviewed by: jmz Submitted by: Jonathan M Bresler <jmb@kryten.atinc.com>
Notes
Notes: svn path=/head/; revision=1463
Diffstat (limited to 'emulators/vmsbackup')
-rw-r--r--emulators/vmsbackup/Makefile22
-rw-r--r--emulators/vmsbackup/distinfo1
-rw-r--r--emulators/vmsbackup/files/patch-aa43
-rw-r--r--emulators/vmsbackup/files/patch-ab162
-rw-r--r--emulators/vmsbackup/pkg-comment1
-rw-r--r--emulators/vmsbackup/pkg-descr10
-rw-r--r--emulators/vmsbackup/pkg-plist3
7 files changed, 242 insertions, 0 deletions
diff --git a/emulators/vmsbackup/Makefile b/emulators/vmsbackup/Makefile
new file mode 100644
index 000000000000..91890d2f2c84
--- /dev/null
+++ b/emulators/vmsbackup/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: vmsbackup
+# Version required: 3.0
+# Date created: 18 Apr 1994
+# Whom: Jonathan M. Bresler (jmb)
+#
+#
+
+DISTNAME= vmsbackup
+PKGNAME= vmsbackup-3.0
+MASTER_SITES= ftp://ftp.cs.uni-sb.de/pub/utils/
+MASTER_SITES+= ftp://ftp.uni-passau.de/pub/unix/system/backup/
+CATEGORIES+= utilities
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= jmb@FreeBSD.org
+
+MAKE_FLAGS= BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 -f
+
+pre-install:
+ @mkdir -p ${PREFIX}/bin ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/emulators/vmsbackup/distinfo b/emulators/vmsbackup/distinfo
new file mode 100644
index 000000000000..888e10289fbf
--- /dev/null
+++ b/emulators/vmsbackup/distinfo
@@ -0,0 +1 @@
+MD5 (vmsbackup.tar.Z) = 8469f4a156c6d531e491558543eee0b6
diff --git a/emulators/vmsbackup/files/patch-aa b/emulators/vmsbackup/files/patch-aa
new file mode 100644
index 000000000000..6f04db249edd
--- /dev/null
+++ b/emulators/vmsbackup/files/patch-aa
@@ -0,0 +1,43 @@
+*** Makefile Tue Jun 13 04:49:54 1989
+--- ../../src/Makefile Tue Apr 18 20:43:30 1995
+***************
+*** 6,22 ****
+ CFLAGS= $(SWAP) $(REMOTE) -O
+ LFLAGS=
+! LIBS= -lrmt # remote magtape library
+! OWNER=tar # user for remote tape access
+! MODE=4755
+ BINDIR=/usr/local/bin
+! MANSEC=l
+! MANDIR=/usr/man/man$(MANSEC)
+
+- #
+ vmsbackup: vmsbackup.o match.o
+! cc $(LFLAGS) -o vmsbackup vmsbackup.o match.o -lV
+ install:
+ install -m $(MODE) -o $(OWNER) -s vmsbackup $(BINDIR)
+! cp vmsbackup.1 $(MANDIR)/vmsbackup.$(MANSEC)
+ clean:
+ rm -f vmsbackup *.o core
+--- 6,26 ----
+ CFLAGS= $(SWAP) $(REMOTE) -O
+ LFLAGS=
+! # LIBS= -lrmt # remote magtape library
+! OWNER=bin # user for remote tape access
+! MODE=755
+ BINDIR=/usr/local/bin
+! MANSEC=1
+! MANDIR=/usr/local/man/man$(MANSEC)
+!
+! all: vmsbackup
+
+ vmsbackup: vmsbackup.o match.o
+! cc $(LFLAGS) -o vmsbackup vmsbackup.o match.o
+!
+ install:
+ install -m $(MODE) -o $(OWNER) -s vmsbackup $(BINDIR)
+! gzip vmsbackup.1
+! cp vmsbackup.1.gz $(MANDIR)
+!
+ clean:
+ rm -f vmsbackup *.o core
diff --git a/emulators/vmsbackup/files/patch-ab b/emulators/vmsbackup/files/patch-ab
new file mode 100644
index 000000000000..fc7aa54eb5a3
--- /dev/null
+++ b/emulators/vmsbackup/files/patch-ab
@@ -0,0 +1,162 @@
+*** vmsbackup.1 Sun Feb 19 10:35:29 1989
+--- ../../src/vmsbackup.1 Tue Apr 18 20:59:08 1995
+***************
+*** 4,18 ****
+ .SH SYNOPSIS
+ .B vmsbackup
+! .B \-{tx}[cdevw][s setnumber][f tapefile]
+ [ name ... ]
+ .SH DESCRIPTION
+ .I vmsbackup
+ reads a VMS generated backup tape, converting the files
+! to Unix format and writing the files to disc.
+ The default operation of the program is to go through an entire
+! tape, extracting every file and writing it to disc.
+ This may be modified by the following options.
+ .TP 8
+! .B c
+ Use complete filenames, including the version number.
+ A colon and the octal version number will be appended to all filenames.
+--- 4,18 ----
+ .SH SYNOPSIS
+ .B vmsbackup
+! .B \-[txcdevw][s setnumber][f tapefile]
+ [ name ... ]
+ .SH DESCRIPTION
+ .I vmsbackup
+ reads a VMS generated backup tape, converting the files
+! to Unix format and writing the files to disk.
+ The default operation of the program is to go through an entire
+! tape, extracting every file and writing it to disk.
+ This may be modified by the following options.
+ .TP 8
+! .B -c
+ Use complete filenames, including the version number.
+ A colon and the octal version number will be appended to all filenames.
+***************
+*** 26,33 ****
+ The default is to ignore version numbers.
+ .TP 8
+! .B d
+ use the directory structure from VMS, the default value is off.
+ .TP 8
+! .B e
+ Process all filename extensions.
+ Since this program is mainly intended to move source code and possibly
+--- 26,33 ----
+ The default is to ignore version numbers.
+ .TP 8
+! .B -d
+ use the directory structure from VMS, the default value is off.
+ .TP 8
+! .B -e
+ Process all filename extensions.
+ Since this program is mainly intended to move source code and possibly
+***************
+*** 35,39 ****
+ all files whose filename extension specifies system dependent data.
+ The file types which will be ignored, unless the
+! .B e
+ option is specified, are
+ .IP "" 10
+--- 35,39 ----
+ all files whose filename extension specifies system dependent data.
+ The file types which will be ignored, unless the
+! .B -e
+ option is specified, are
+ .IP "" 10
+***************
+*** 57,61 ****
+ .PP
+ .TP 8
+! .B f
+ Use the next argument in the command line as the tape device to
+ be used, rather than the default.
+--- 57,61 ----
+ .PP
+ .TP 8
+! .B -f
+ Use the next argument in the command line as the tape device to
+ be used, rather than the default.
+***************
+*** 83,94 ****
+ This must be a raw mode tape device.
+ .TP 8
+! .B s saveset
+ Process only the given saveset number.
+ .TP 8
+! .B t
+! Produce a table of contents (a directory listing) on the standard output
+! of the files on tape.
+ .TP 8
+! .B v
+ Verbose output.
+ Normally
+--- 83,94 ----
+ This must be a raw mode tape device.
+ .TP 8
+! .B -s saveset
+ Process only the given saveset number.
+ .TP 8
+! .B -t
+! Produce a table of contents (a recursive directory listing) on the
+! standard output of the files on tape.
+ .TP 8
+! .B -v
+ Verbose output.
+ Normally
+***************
+*** 98,102 ****
+ tape to disk to be output on the standard output.
+ .TP 8
+! .B w
+ .I vmsbackup
+ prints the action to be taken followed by file name, then
+--- 98,102 ----
+ tape to disk to be output on the standard output.
+ .TP 8
+! .B -w
+ .I vmsbackup
+ prints the action to be taken followed by file name, then
+***************
+*** 104,108 ****
+ is given, the action is done. Any other input means don't do it.
+ .TP 8
+! .B x
+ extract the named files from the tape.
+ .TP 8
+--- 104,108 ----
+ is given, the action is done. Any other input means don't do it.
+ .TP 8
+! .B -x
+ extract the named files from the tape.
+ .TP 8
+***************
+*** 111,122 ****
+ argument specifies one or more filenames to be
+ searched for specifically on the tape and only those files are to be processed.
+! The name may contain the usal sh(1) meta-characters *?![] \nnn.
+ .SH FILES
+! /dev/rmt\fIx\fP
+ .SH SEE ALSO
+! rmtops(3)
+ .SH BUGS
+ The filename match uses the complete VMS file names.
+!
+ .SH AUTHOR
+ John Douglas Carey
+--- 111,124 ----
+ argument specifies one or more filenames to be
+ searched for specifically on the tape and only those files are to be processed.
+! The name may contain the usal
+! .I sh(1)
+! meta-characters *?![].
+ .SH FILES
+! /dev/rmt\fIx\fP, /dev/rst\fIx\fP
+ .SH SEE ALSO
+! rsh(1), rmt(8)
+ .SH BUGS
+ The filename match uses the complete VMS file names.
+! Filename matching does not use libregex.a
+ .SH AUTHOR
+ John Douglas Carey
diff --git a/emulators/vmsbackup/pkg-comment b/emulators/vmsbackup/pkg-comment
new file mode 100644
index 000000000000..3becb538ce13
--- /dev/null
+++ b/emulators/vmsbackup/pkg-comment
@@ -0,0 +1 @@
+VMSBACKUP reads VMS BACKUP tapes.
diff --git a/emulators/vmsbackup/pkg-descr b/emulators/vmsbackup/pkg-descr
new file mode 100644
index 000000000000..9be9becac437
--- /dev/null
+++ b/emulators/vmsbackup/pkg-descr
@@ -0,0 +1,10 @@
+
+ VMSBACKUP reads VMS BACKUP tapes.
+
+ Main features:
+ swaps bytes from big-endian to little-endian, if required.
+ savesets can be selected individually.
+ can preserve directory structure.
+ excludes vms specific files (eg executables and objects).
+ converts vms version numbering semicolons to colons.
+
diff --git a/emulators/vmsbackup/pkg-plist b/emulators/vmsbackup/pkg-plist
new file mode 100644
index 000000000000..c6a74b7e3ff3
--- /dev/null
+++ b/emulators/vmsbackup/pkg-plist
@@ -0,0 +1,3 @@
+@cwd /usr/local
+bin/vmsbackup
+man/man1/vmsbackup.1.gz