aboutsummaryrefslogtreecommitdiff
path: root/emulators/vxtools
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 12:57:47 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-03-14 12:57:47 +0000
commit360b89ee54367c66f15cb677f048d662e580a92c (patch)
treeb595e1b6135b0b006a6c4384078ee7655061a408 /emulators/vxtools
parent30f208c29a6299a36962a5b97779d8b6226c81d0 (diff)
downloadports-360b89ee54367c66f15cb677f048d662e580a92c.tar.gz
ports-360b89ee54367c66f15cb677f048d662e580a92c.zip
- Support staging
- Respect CFLAGS - Don't build with debug symbols - USES -> gmake - Convert USE_BZIP2=yes to USES=tar:bzip2
Notes
Notes: svn path=/head/; revision=348220
Diffstat (limited to 'emulators/vxtools')
-rw-r--r--emulators/vxtools/Makefile24
-rw-r--r--emulators/vxtools/files/patch-Makefile.in12
-rw-r--r--emulators/vxtools/files/patch-dir.c4
-rw-r--r--emulators/vxtools/files/patch-olt.c4
-rw-r--r--emulators/vxtools/pkg-plist3
5 files changed, 26 insertions, 21 deletions
diff --git a/emulators/vxtools/Makefile b/emulators/vxtools/Makefile
index fdbe5fad7e82..553ee9b88a16 100644
--- a/emulators/vxtools/Makefile
+++ b/emulators/vxtools/Makefile
@@ -10,25 +10,15 @@ MASTER_SITES= ftp://ftp.penguin.cz/pub/users/mhi/vxfs/
MAINTAINER= mhi@penguin.cz
COMMENT= Command-line utilities for reading Veritas Filesystem (VxFS)
-USE_BZIP2= yes
+USES= tar:bzip2 gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-MAN1= vxmount.1 vxumount.1
-MAN8= prtvtoc.8
-
-NO_STAGE= yes
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/vxls ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/vxmount ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/vxumount ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/vxcat ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/vxidump ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/vxcd ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/vxpwd ${PREFIX}/bin
- @ ${INSTALL_PROGRAM} ${WRKSRC}/prtvtoc ${PREFIX}/bin
- @ ${INSTALL_MAN} ${WRKSRC}/prtvtoc.8 ${PREFIX}/man/man8
- @ ${INSTALL_MAN} ${WRKSRC}/vxmount.1 ${PREFIX}/man/man1
- @ ${INSTALL_MAN} ${WRKSRC}/vxumount.1 ${PREFIX}/man/man1
+.for f in vxls vxmount vxumount vxcat vxidump vxcd vxpwd prtvtoc
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
+.endfor
+ ${INSTALL_MAN} ${WRKSRC}/prtvtoc.8 ${STAGEDIR}${MANPREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/vxmount.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/vxumount.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/emulators/vxtools/files/patch-Makefile.in b/emulators/vxtools/files/patch-Makefile.in
new file mode 100644
index 000000000000..2da4e7293175
--- /dev/null
+++ b/emulators/vxtools/files/patch-Makefile.in
@@ -0,0 +1,12 @@
+--- ./Makefile.in.orig 1999-12-02 18:52:25.000000000 +0100
++++ ./Makefile.in 2014-03-14 13:55:04.943662466 +0100
+@@ -10,8 +10,7 @@
+ MAN8 = prtvtoc.8
+
+ CC = @CC@
+-CFLAGS = -Wall -g -I.
+-LDFLAGS = -g
++CFLAGS += -Wall -I.
+
+ all: $(BINS)
+
diff --git a/emulators/vxtools/files/patch-dir.c b/emulators/vxtools/files/patch-dir.c
index c287ec8a3494..7a9e8d3e4a04 100644
--- a/emulators/vxtools/files/patch-dir.c
+++ b/emulators/vxtools/files/patch-dir.c
@@ -1,5 +1,5 @@
---- dir.c.orig 2007-11-16 03:10:42.000000000 +0600
-+++ dir.c 2007-11-16 03:11:11.000000000 +0600
+--- ./dir.c.orig 1999-12-02 17:57:40.000000000 +0100
++++ ./dir.c 2014-03-14 13:54:55.820662227 +0100
@@ -105,7 +105,7 @@
if (direct->ino)
filldir (dir, direct->name, direct->namelen, direct->ino);
diff --git a/emulators/vxtools/files/patch-olt.c b/emulators/vxtools/files/patch-olt.c
index 26330c7ce4f5..97b7d18c8510 100644
--- a/emulators/vxtools/files/patch-olt.c
+++ b/emulators/vxtools/files/patch-olt.c
@@ -1,5 +1,5 @@
---- olt.c.orig 2007-11-16 03:09:17.000000000 +0600
-+++ olt.c 2007-11-16 03:12:11.000000000 +0600
+--- ./olt.c.orig 1999-12-02 15:19:27.000000000 +0100
++++ ./olt.c 2014-03-14 13:54:55.821662410 +0100
@@ -85,7 +85,7 @@
case VXFS_OLTSB:
break;
diff --git a/emulators/vxtools/pkg-plist b/emulators/vxtools/pkg-plist
index 670adbecb2bc..57d2de2eaa62 100644
--- a/emulators/vxtools/pkg-plist
+++ b/emulators/vxtools/pkg-plist
@@ -6,3 +6,6 @@ bin/vxcd
bin/vxpwd
bin/vxidump
bin/vxcat
+man/man1/vxmount.1.gz
+man/man1/vxumount.1.gz
+man/man8/prtvtoc.8.gz