aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine-devel
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-02-28 07:18:05 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-02-28 07:18:05 +0000
commit8f2cfe82d21f540753ee6bf0a120f3dac5c742e7 (patch)
tree22f118098984edd0702239ad88abb07c327de276 /emulators/wine-devel
parentd8cc10c4f3ecd032cfd92512717cd0b5ae3c1bf8 (diff)
downloadports-8f2cfe82d21f540753ee6bf0a120f3dac5c742e7.tar.gz
ports-8f2cfe82d21f540753ee6bf0a120f3dac5c742e7.zip
Update to Wine 6.3. This includes the following changes:
- Better debugger support in the NT syscall interface. - WineGStreamer library converted to PE. - Still more WinRT support in WIDL. - Optional support for build IDs. - Various bug fixes. Most of the files that "disppeared" from the Staging patchset (with the STAGING option active) with version 6.2 are back. It appears some patches were temporarily deactivated in that one snapshot.
Notes
Notes: svn path=/head/; revision=566748
Diffstat (limited to 'emulators/wine-devel')
-rw-r--r--emulators/wine-devel/Makefile2
-rw-r--r--emulators/wine-devel/distinfo10
-rw-r--r--emulators/wine-devel/pkg-plist20
3 files changed, 26 insertions, 6 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 8cffa314355f..318448a591d7 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= wine
-DISTVERSION= 6.2
+DISTVERSION= 6.3
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 9cedd4e75175..00464c8a459a 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1613257468
-SHA256 (wine-6.2.tar.xz) = b6609609a3abcc6ad927cdd65c740be01162b801523e0f7ba9fd6691800bbf19
-SIZE (wine-6.2.tar.xz) = 24270924
-SHA256 (v6.2.tar.gz) = 8ae73db67446d00ca7aef8c34c9a7336d6ca36893fa55f943e662cd1035844de
-SIZE (v6.2.tar.gz) = 9820682
+TIMESTAMP = 1614415004
+SHA256 (wine-6.3.tar.xz) = 682a77c1fd12f56347ca2080d85fe17def1b655d3241d94582f87591d9d0cc3b
+SIZE (wine-6.3.tar.xz) = 24301496
+SHA256 (v6.3.tar.gz) = c490127b2bbbe326923ad32a5b730dc4d7541a07085a9553929b64b52a556c58
+SIZE (v6.3.tar.gz) = 9796930
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index e27259d507b9..13aca821b00f 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -118,6 +118,8 @@ include/wine/windows/appmodel.h
include/wine/windows/asferr.h
include/wine/windows/asptlb.h
include/wine/windows/asptlb.idl
+%%STAGING%%include/wine/windows/asyncinfo.h
+%%STAGING%%include/wine/windows/asyncinfo.idl
include/wine/windows/asynot.idl
include/wine/windows/asysta.idl
include/wine/windows/atlbase.h
@@ -952,11 +954,23 @@ include/wine/windows/wincred.h
include/wine/windows/wincrypt.h
include/wine/windows/windef.h
include/wine/windows/windns.h
+include/wine/windows/windows.foundation.collections.h
+include/wine/windows/windows.foundation.collections.idl
include/wine/windows/windows.foundation.h
include/wine/windows/windows.foundation.idl
+%%STAGING%%include/wine/windows/windows.gaming.input.forcefeedback.h
+%%STAGING%%include/wine/windows/windows.gaming.input.forcefeedback.idl
+%%STAGING%%include/wine/windows/windows.gaming.input.h
+%%STAGING%%include/wine/windows/windows.gaming.input.idl
+%%STAGING%%include/wine/windows/windows.globalization.h
+%%STAGING%%include/wine/windows/windows.globalization.idl
include/wine/windows/windows.h
include/wine/windows/windows.media.speechsynthesis.h
include/wine/windows/windows.media.speechsynthesis.idl
+%%STAGING%%include/wine/windows/windows.system.h
+%%STAGING%%include/wine/windows/windows.system.idl
+%%STAGING%%include/wine/windows/windows.system.userprofile.h
+%%STAGING%%include/wine/windows/windows.system.userprofile.idl
include/wine/windows/windowscontracts.h
include/wine/windows/windowscontracts.idl
include/wine/windows/windowsx.h
@@ -2475,6 +2489,9 @@ lib/wine/fakedlls/wimgapi.dll
%%WINE32%%lib/wine/fakedlls/win87em.dll16
%%WINE32%%lib/wine/fakedlls/winaspi.dll16
%%WINE32%%lib/wine/fakedlls/windebug.dll16
+%%STAGING%%lib/wine/fakedlls/windows.gaming.input.dll
+%%STAGING%%lib/wine/fakedlls/windows.globalization.dll
+%%STAGING%%lib/wine/fakedlls/windows.media.speech.dll
lib/wine/fakedlls/windowscodecs.dll
lib/wine/fakedlls/windowscodecsext.dll
lib/wine/fakedlls/wineboot.exe
@@ -3238,6 +3255,9 @@ lib/wine/wimgapi.dll.so
%%WINE32%%lib/wine/win87em.dll16.so
%%WINE32%%lib/wine/winaspi.dll16.so
%%WINE32%%lib/wine/windebug.dll16.so
+%%STAGING%%lib/wine/windows.gaming.input.dll.so
+%%STAGING%%lib/wine/windows.globalization.dll.so
+%%STAGING%%lib/wine/windows.media.speech.dll.so
lib/wine/windowscodecs.dll.so
lib/wine/windowscodecs.so
lib/wine/windowscodecsext.dll.so