aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine-gecko-devel
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-10-21 21:46:11 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-10-21 21:46:11 +0000
commit29dea009f39ee2405144e1de3581f70bb9c6fbb8 (patch)
tree79dbef5084b984fce2d2cecb1889f517cf4760e2 /emulators/wine-gecko-devel
parent2c346b1214d41a119785f8a0fe65d94c12e8d381 (diff)
downloadports-29dea009f39ee2405144e1de3581f70bb9c6fbb8.tar.gz
ports-29dea009f39ee2405144e1de3581f70bb9c6fbb8.zip
STAGEify. Move PKGNAMESUFFIX to the proper location in Makefile.
Approved by: dbn (maintainer)
Notes
Notes: svn path=/head/; revision=331198
Diffstat (limited to 'emulators/wine-gecko-devel')
-rw-r--r--emulators/wine-gecko-devel/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/emulators/wine-gecko-devel/Makefile b/emulators/wine-gecko-devel/Makefile
index 5c7c6ada2aa4..22224697ced7 100644
--- a/emulators/wine-gecko-devel/Makefile
+++ b/emulators/wine-gecko-devel/Makefile
@@ -5,6 +5,7 @@ PORTNAME= wine-gecko
DISTVERSION= 2.24
CATEGORIES= emulators
MASTER_SITES= SF/wine/Wine%20Gecko/${DISTVERSION}
+PKGNAMESUFFIX= -devel
DISTNAME= wine_gecko-${DISTVERSION}-x86
EXTRACT_SUFX= .msi
EXTRACT_ONLY=
@@ -15,17 +16,15 @@ COMMENT= Gecko Layout Engine for Wine development branch (HTML support)
LICENSE= MPL GPLv2 GPLv3 LGPL21 LGPL3
LICENSE_COMB= multi
-PKGNAMESUFFIX= -devel
NO_BUILD= yes
PLIST_SUB+= GECKO_VERSION="${DISTVERSION}"
DATADIR= ${PREFIX}/share/wine
PLIST_FILES= %%DATADIR%%/gecko/wine_gecko-%%GECKO_VERSION%%-x86.msi
PLIST_DIRSTRY= %%DATADIR%%/gecko %%DATADIR%%
-NO_STAGE= yes
do-install:
- @${MKDIR} ${DATADIR}/gecko
+ @${MKDIR} ${STAGEDIR}${DATADIR}/gecko
${INSTALL_DATA} ${DISTDIR}/wine_gecko-${DISTVERSION}-x86.msi \
- ${DATADIR}/gecko
+ ${STAGEDIR}${DATADIR}/gecko
.include <bsd.port.mk>