aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-13 21:11:06 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-13 21:11:06 +0000
commit9bdd8e871b28eaceacf5999517c13960b0fb6af2 (patch)
tree45ed58cb9e79b1a55c895305cc790813406bc531 /emulators/wine
parent7e7fcbf1c51e61076c73204233cb49befbd64149 (diff)
downloadports-9bdd8e871b28eaceacf5999517c13960b0fb6af2.tar.gz
ports-9bdd8e871b28eaceacf5999517c13960b0fb6af2.zip
emulators/i386-wine: Use standard ports infrastructure for ARCH
This commit is the analogous for i386-wine of r528249 that concerns emulators/i386-wine-devel. Until now i386-wine defined its own ARCH variable and manually included Makefile.i386 for i386 systems and Makefile.inc for amd64 systems. This commit makes use of the standard ARCH variable and renames Makefile.inc to Makefile.amd64 so that the proper Makefile.${ARCH} is automatically included. This requires conditional inclusion bsd.ports.pre.mk and bsd.ports.post.mk by emulators/wine [1], master port for i386-wine: those files must be included only if they have not already been included by i386-wine. Approved by: gerald (mentor, maintainer [1])
Notes
Notes: svn path=/head/; revision=528378
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 9260dec1f876..89499a24839b 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -119,7 +119,11 @@ X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
liblcms2.so:graphics/lcms2 \
libpng.so:graphics/png
+# Include this only if it has not been already included by the
+# i386-wine slave port.
+.ifndef PKGNAMEPREFIX
.include <bsd.port.pre.mk>
+.endif
.if ${ARCH} == amd64
# Wine is composed of three parts:
@@ -160,4 +164,6 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/programs/winedbg/README ${STAGEDIR}${DOCSDIR}/README.winedbg
${INSTALL_DATA} ${WRKSRC}/tools/winedump/README ${STAGEDIR}${DOCSDIR}/README.winedump
+.ifndef PKGNAMEPREFIX
.include <bsd.port.post.mk>
+.endif