aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2021-11-24 12:38:04 +0000
committerStefan Eßer <se@FreeBSD.org>2021-11-24 12:44:05 +0000
commitb1ac48afa4fb490b5fc7d1dc8e3862ef2ef93c88 (patch)
tree1772b2610b8b2c7081cd26946dc764f9bf10e27d /emulators/wine
parent11e104a80c7bb9a689d0435bb4de18d012809f10 (diff)
downloadports-b1ac48afa4fb490b5fc7d1dc8e3862ef2ef93c88.tar.gz
ports-b1ac48afa4fb490b5fc7d1dc8e3862ef2ef93c88.zip
emulators/wine: revert accidentially committed local changes
In commit 5933ac0b099 CONFLICTS_INSTALL definitions in multiple ports have been fixed to omit the unneeded version patterns they had. The commit of the wine port did not include that fix, but instead local changes to deal with an issue introduced by recent changes to sched.h. This commit reverts the accidentially committed changes, but retains the intended removal of a version wildcard in CONFLICTS_INSTALL. Reported by: gerald
Diffstat (limited to 'emulators/wine')
-rw-r--r--emulators/wine/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 367205931cc6..ed3e5754d68f 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -18,8 +18,7 @@ ONLY_FOR_ARCHS= amd64 i386
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex
LIB_DEPENDS= libFAudio.so:audio/faudio \
- libxml2.so:textproc/libxml2 \
- libsysinfo.so:devel/libsysinfo
+ libxml2.so:textproc/libxml2
USES= bison cpe desktop-file-utils gmake localbase \
pkgconfig sdl shebangfix tar:xz
@@ -58,7 +57,7 @@ CONFIGURE_ARGS+=--verbose \
--without-udev \
--without-unwind \
--without-usb
-CONFIGURE_ENV= CPPBIN="${CPP}" FLEX="${LOCALBASE}/bin/flex" CFLAGS="-D_WITH_CPU_SET_T"
+CONFIGURE_ENV= CPPBIN="${CPP}" FLEX="${LOCALBASE}/bin/flex"
WINELIBDIR?= ${PREFIX}/lib
.if !defined(USE_LDCONFIG32)
USE_LDCONFIG= ${WINELIBDIR} ${WINELIBDIR}/wine