aboutsummaryrefslogtreecommitdiff
path: root/emulators/wxmupen64plus
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2014-04-07 20:27:24 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2014-04-07 20:27:24 +0000
commit0a550f1cc4b2e68892b4e09da311476b8135f065 (patch)
tree7e6d1074c545918dbdb40bb83af307e4abbfd453 /emulators/wxmupen64plus
parent5dd88545f837ee18a19eaf9c68d32747a82f8c28 (diff)
downloadports-0a550f1cc4b2e68892b4e09da311476b8135f065.tar.gz
ports-0a550f1cc4b2e68892b4e09da311476b8135f065.zip
Notes
Diffstat (limited to 'emulators/wxmupen64plus')
-rw-r--r--emulators/wxmupen64plus/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/emulators/wxmupen64plus/Makefile b/emulators/wxmupen64plus/Makefile
index e47c31709751..f6e80f05cbd5 100644
--- a/emulators/wxmupen64plus/Makefile
+++ b/emulators/wxmupen64plus/Makefile
@@ -13,8 +13,6 @@ DIST_SUBDIR= ${PORTNAME:S/wx//}
MAINTAINER= acm@FreeBSD.org
COMMENT= Mupen64Plus 2.0 GUI frontend written using wxWidgets
-BROKEN= does not build with any of the supported wx
-
LIB_DEPENDS= mupen64plus:${PORTSDIR}/emulators/mupen64plus-core
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl \
@@ -30,10 +28,9 @@ WX_UNICODE= yes
USE_PYTHON= yes
WAF_SCRIPT= waf
-NO_STAGE= yes
-
post-patch:
- @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' -e 's|%%CXX%%|${CXX}|g' ${WRKSRC}/wscript
+ @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' -e 's|%%CXX%%|${CXX}|g' -e
+ 's|version=2.9|version=${WX_VERSION}|g' ${WRKSRC}/wscript
do-configure:
@cd ${WRKSRC} && \
@@ -51,8 +48,8 @@ do-build:
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${WAF_SCRIPT}
do-install:
- @${MKDIR} ${DATADIR}
- @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}
- @${INSTALL_PROGRAM} ${WRKSRC}/build/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/build/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>