aboutsummaryrefslogtreecommitdiff
path: root/emulators/xcpc
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:20:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:20:28 +0000
commitf53196ebc931edf54afe56ab65deddc4f2d5b8fb (patch)
tree17f3405d36f74dd57d11bda9e7ecc80c2929914c /emulators/xcpc
parent02ad6b1271fd43ec6fd524c9a6957530cd83d262 (diff)
downloadports-f53196ebc931edf54afe56ab65deddc4f2d5b8fb.tar.gz
ports-f53196ebc931edf54afe56ab65deddc4f2d5b8fb.zip
Convert emulators to new options framework
Notes
Notes: svn path=/head/; revision=316753
Diffstat (limited to 'emulators/xcpc')
-rw-r--r--emulators/xcpc/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/emulators/xcpc/Makefile b/emulators/xcpc/Makefile
index 3f3fef5556c0..131fef2865ee 100644
--- a/emulators/xcpc/Makefile
+++ b/emulators/xcpc/Makefile
@@ -23,33 +23,34 @@ LIB_DEPENDS+= icui18n:${PORTSDIR}/devel/icu \
pcre.3:${PORTSDIR}/devel/pcre \
dsk.5:${PORTSDIR}/emulators/libdsk
-OPTIONS= MOTIF "With Motif widget set" on \
- ATHENA "With Athen widget set" off \
- XSHM "With XShm support" on \
- DEBUG "Turn debugging on" off
+OPTIONS_DEFINE= MOTIF ATHENA XSHM DEBUG
+OPTIONS_DEFAULT= MOTIF XSHM
+MOTIF_DESC= With Motif widget set
+ATHENA_DESC= With Athen widget set
+XSHM_DESC= With XShm support
.include <bsd.port.pre.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--enable-debug
.else
CONFIGURE_ARGS+=--disable-debug
.endif
-.if defined(WITH_XSHM)
+.if ${PORT_OPTIONS:MXSHM}
CONFIGURE_ARGS+=--enable-xshm
.else
CONFIGURE_ARGS+=--disable-xshm
.endif
-.if defined(WITH_MOTIF)
+.if ${PORT_OPTIONS:MMOTIF}
USE_MOTIF=yes
CONFIGURE_ARGS+=--with-motif1
.else
CONFIGURE_ARGS+=--without-motif1
.endif
-.if defined(WITH_ATHENA)
+.if ${PORT_OPTIONS:MATHENA}
LIB_DEPENDS+= Xaw.8:${PORTSDIR}/x11-toolkits/libXaw
CONFIGURE_ARGS+=--with-athena
.else