aboutsummaryrefslogtreecommitdiff
path: root/emulators/xen-kernel
diff options
context:
space:
mode:
authorRoger Pau Monné <royger@FreeBSD.org>2016-06-07 07:34:40 +0000
committerRoger Pau Monné <royger@FreeBSD.org>2016-06-07 07:34:40 +0000
commit500732089daa8daef97bf6fd574a95f5de50705a (patch)
treef883cf5e953c51e03a5ffd2575055f78c58e5274 /emulators/xen-kernel
parentb1ad15fe58f158bb033b97f1e39244edec2ce853 (diff)
downloadports-500732089daa8daef97bf6fd574a95f5de50705a.tar.gz
ports-500732089daa8daef97bf6fd574a95f5de50705a.zip
xen: add missing file from r416310
Sponsored by: Citrix Systems R&D
Notes
Notes: svn path=/head/; revision=416497
Diffstat (limited to 'emulators/xen-kernel')
-rw-r--r--emulators/xen-kernel/files/kconf_arch.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/emulators/xen-kernel/files/kconf_arch.patch b/emulators/xen-kernel/files/kconf_arch.patch
new file mode 100644
index 000000000000..d37038b44530
--- /dev/null
+++ b/emulators/xen-kernel/files/kconf_arch.patch
@@ -0,0 +1,33 @@
+diff --git a/xen/Makefile b/xen/Makefile
+index 0d5f240..f232d01 100644
+--- a/xen/Makefile
++++ b/xen/Makefile
+@@ -21,8 +21,8 @@ MAKEFLAGS += -rR
+
+ EFI_MOUNTPOINT ?= $(BOOT_DIR)/efi
+
+-ARCH=$(XEN_TARGET_ARCH)
+-SRCARCH=$(shell echo $(ARCH) | sed -e 's/x86.*/x86/' -e s'/arm\(32\|64\)/arm/g')
++KCONF_ARCH=$(XEN_TARGET_ARCH)
++KCONF_SRCARCH=$(shell echo $(KCONF_ARCH) | sed -e 's/x86.*/x86/' -e s'/arm\(32\|64\)/arm/g')
+
+ # Don't break if the build process wasn't called from the top level
+ # we need XEN_TARGET_ARCH to generate the proper config
+@@ -246,14 +246,14 @@ kconfig := silentoldconfig oldconfig config menuconfig defconfig \
+ randconfig
+ .PHONY: $(kconfig)
+ $(kconfig):
+- $(MAKE) -f $(BASEDIR)/tools/kconfig/Makefile.kconfig ARCH=$(ARCH) SRCARCH=$(SRCARCH) HOSTCC=$(HOSTCC) HOSTCXX=$(HOSTCXX) $@
++ $(MAKE) -f $(BASEDIR)/tools/kconfig/Makefile.kconfig ARCH=$(KCONF_ARCH) SRCARCH=$(KCONF_SRCARCH) HOSTCC=$(HOSTCC) HOSTCXX=$(HOSTCXX) $@
+
+ include/config/%.conf: include/config/auto.conf.cmd $(KCONFIG_CONFIG)
+- $(MAKE) -f $(BASEDIR)/tools/kconfig/Makefile.kconfig ARCH=$(ARCH) SRCARCH=$(SRCARCH) HOSTCC=$(HOSTCC) HOSTCXX=$(HOSTCXX) silentoldconfig
++ $(MAKE) -f $(BASEDIR)/tools/kconfig/Makefile.kconfig ARCH=$(KCONF_ARCH) SRCARCH=$(KCONF_SRCARCH) HOSTCC=$(HOSTCC) HOSTCXX=$(HOSTCXX) silentoldconfig
+
+ # Allow people to just run `make` as before and not force them to configure
+ $(KCONFIG_CONFIG):
+- $(MAKE) -f $(BASEDIR)/tools/kconfig/Makefile.kconfig ARCH=$(ARCH) SRCARCH=$(SRCARCH) HOSTCC=$(HOSTCC) HOSTCXX=$(HOSTCXX) defconfig
++ $(MAKE) -f $(BASEDIR)/tools/kconfig/Makefile.kconfig ARCH=$(KCONF_ARCH) SRCARCH=$(KCONF_SRCARCH) HOSTCC=$(HOSTCC) HOSTCXX=$(HOSTCXX) defconfig
+
+ # Break the dependency chain for the first run
+ include/config/auto.conf.cmd: ;