aboutsummaryrefslogtreecommitdiff
path: root/emulators/xgngeo
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-02 03:14:36 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-02 03:14:36 +0000
commitcacf0e81a540a13639627f2f6bf5e105d98232ca (patch)
treed79e1ba69f68ebc89b228e24a143fc0a1fb6ad63 /emulators/xgngeo
parent53629f86b029dd4f18a0a856203cba9bd27d0ec5 (diff)
downloadports-cacf0e81a540a13639627f2f6bf5e105d98232ca.tar.gz
ports-cacf0e81a540a13639627f2f6bf5e105d98232ca.zip
Notes
Diffstat (limited to 'emulators/xgngeo')
-rw-r--r--emulators/xgngeo/Makefile17
-rw-r--r--emulators/xgngeo/distinfo6
-rw-r--r--emulators/xgngeo/files/patch-data-py___init__.py14
-rw-r--r--emulators/xgngeo/files/patch-data-py_configfile.py20
-rw-r--r--emulators/xgngeo/files/patch-setup.py42
-rw-r--r--emulators/xgngeo/pkg-plist3
6 files changed, 61 insertions, 41 deletions
diff --git a/emulators/xgngeo/Makefile b/emulators/xgngeo/Makefile
index 97fc56d9fbbb..1e58c55775ad 100644
--- a/emulators/xgngeo/Makefile
+++ b/emulators/xgngeo/Makefile
@@ -6,11 +6,12 @@
#
PORTNAME= xgngeo
-PORTVERSION= 16b
+PORTVERSION= 16
+PORTEPOCH= 1
CATEGORIES= emulators games
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME:S/xg/XG/}-${PORTVERSION:S/b/_beta/}
+DISTNAME= ${PORTNAME:S/xg/XG/}-${PORTVERSION}
DIST_SUBDIR= gngeo
MAINTAINER= acm@FreeBSD.org
@@ -25,6 +26,16 @@ USE_GETTEXT= yes
USE_PYDISTUTILS= yes
NO_BUILD= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_PSYCO= yes
+.endif
+
+.if !defined(WITHOUT_PSYCO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/data/py/configfile.py
@@ -34,4 +45,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/xgngeo-doc.pdf ${WRKSRC}/doc/xgngeo-doc.txt ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/emulators/xgngeo/distinfo b/emulators/xgngeo/distinfo
index 384ba70d19db..398c69361bc1 100644
--- a/emulators/xgngeo/distinfo
+++ b/emulators/xgngeo/distinfo
@@ -1,3 +1,3 @@
-MD5 (gngeo/XGngeo-16_beta.tar.bz2) = cde3c42ec5c981614b5be02cb8381c4c
-SHA256 (gngeo/XGngeo-16_beta.tar.bz2) = 52d6a35d9ee492493785d6de0d314704bb280d6cf96587da80fa4f05c1e898ff
-SIZE (gngeo/XGngeo-16_beta.tar.bz2) = 338656
+MD5 (gngeo/XGngeo-16.tar.bz2) = 741d8099b6560b1f82518dbff90bd08b
+SHA256 (gngeo/XGngeo-16.tar.bz2) = a782049367c2865a867ee944381104c7e05474ecca8e81cf04e2ef48b61fccd0
+SIZE (gngeo/XGngeo-16.tar.bz2) = 346232
diff --git a/emulators/xgngeo/files/patch-data-py___init__.py b/emulators/xgngeo/files/patch-data-py___init__.py
index c1d113a0d0d4..0eff2d6733a3 100644
--- a/emulators/xgngeo/files/patch-data-py___init__.py
+++ b/emulators/xgngeo/files/patch-data-py___init__.py
@@ -1,11 +1,11 @@
---- data/py/__init__.py Tue Aug 1 00:19:19 2006
-+++ data/py/__init__.py Tue Aug 1 00:19:52 2006
-@@ -33,7 +33,7 @@
- datarootpath = os.path.join(sys.prefix,'share','xgngeo')
+--- data/py/__init__.py Sun Oct 1 20:49:37 2006
++++ data/py/__init__.py Sun Oct 1 20:50:23 2006
+@@ -63,7 +63,7 @@
+ datarootpath = os.path.join(sys.prefix, 'share', 'xgngeo')
- #Internationalization.
--gettext.install("xgngeo",os.path.join(datarootpath,"locale"))
-+gettext.install("xgngeo",os.path.join(sys.prefix,"share","locale"))
+ # Internationalization.
+-gettext.install("xgngeo", os.path.join(datarootpath, "locale"))
++gettext.install("xgngeo", os.path.join(sys.prefix,"share", "locale"))
class XGngeo:
def __init__(self):
diff --git a/emulators/xgngeo/files/patch-data-py_configfile.py b/emulators/xgngeo/files/patch-data-py_configfile.py
index affdee6722d1..a80c43581d0b 100644
--- a/emulators/xgngeo/files/patch-data-py_configfile.py
+++ b/emulators/xgngeo/files/patch-data-py_configfile.py
@@ -1,11 +1,11 @@
---- data/py/configfile.py Fri Jul 14 07:30:15 2006
-+++ data/py/configfile.py Tue Aug 1 00:01:53 2006
-@@ -90,7 +90,7 @@
- "68kclock":0,
- "z80clock":0,
+--- data/py/configfile.py Sun Oct 1 20:52:46 2006
++++ data/py/configfile.py Sun Oct 1 20:53:13 2006
+@@ -107,7 +107,7 @@
+ "68kclock": 0,
+ "z80clock": 0,
#Other thing section.
-- "libglpath":"/usr/lib/libGL.so",
-+ "libglpath":"%%X11BASE%%/lib/libGL.so",
- "sleepidle":"true",
- "bench":"false",
- },{ #XGngeo default.
+- "libglpath": "/usr/lib/libGL.so",
++ "libglpath": "%%X11BASE%%/lib/libGL.so",
+ "sleepidle": "true",
+ "bench": "false",
+ },{ #XGngeo's default.
diff --git a/emulators/xgngeo/files/patch-setup.py b/emulators/xgngeo/files/patch-setup.py
index 5b0ed7c1187b..c1157d4b2c53 100644
--- a/emulators/xgngeo/files/patch-setup.py
+++ b/emulators/xgngeo/files/patch-setup.py
@@ -1,19 +1,27 @@
---- setup.py Tue Aug 1 00:23:11 2006
-+++ setup.py Tue Aug 1 00:23:43 2006
-@@ -48,11 +48,11 @@
- #Plan text documentation.
- (os.path.join("share","xgngeo","doc"),[os.path.join("doc","xgngeo-doc.txt")]),
+--- setup.py Sun Oct 1 20:57:22 2006
++++ setup.py Sun Oct 1 20:57:44 2006
+@@ -55,19 +55,19 @@
+ (os.path.join("share", "applications"), [os.path.join("data", "misc", "xgngeo.desktop")]),
#Localization files.
-- (os.path.join("share","xgngeo","locale","es","LC_MESSAGES"),[os.path.join("data","locale","es","LC_MESSAGES","xgngeo.mo")]), #Spanish
-- (os.path.join("share","xgngeo","locale","de","LC_MESSAGES"),[os.path.join("data","locale","de","LC_MESSAGES","xgngeo.mo")]), #German
-- (os.path.join("share","xgngeo","locale","fr","LC_MESSAGES"),[os.path.join("data","locale","fr","LC_MESSAGES","xgngeo.mo")]), #French
-- (os.path.join("share","xgngeo","locale","pl","LC_MESSAGES"),[os.path.join("data","locale","pl","LC_MESSAGES","xgngeo.mo")]), #Polish
-- (os.path.join("share","xgngeo","locale","pt_BR","LC_MESSAGES"),[os.path.join("data","locale","pt_BR","LC_MESSAGES","xgngeo.mo")]) #Portuguese of Brazil
-+ (os.path.join("share","locale","es","LC_MESSAGES"),[os.path.join("data","locale","es","LC_MESSAGES","xgngeo.mo")]), #Spanish
-+ (os.path.join("share","locale","de","LC_MESSAGES"),[os.path.join("data","locale","de","LC_MESSAGES","xgngeo.mo")]), #German
-+ (os.path.join("share","locale","fr","LC_MESSAGES"),[os.path.join("data","locale","fr","LC_MESSAGES","xgngeo.mo")]), #French
-+ (os.path.join("share","locale","pl","LC_MESSAGES"),[os.path.join("data","locale","pl","LC_MESSAGES","xgngeo.mo")]), #Polish
-+ (os.path.join("share","locale","pt_BR","LC_MESSAGES"),[os.path.join("data","locale","pt_BR","LC_MESSAGES","xgngeo.mo")]) #Portuguese of Brazil
- ],
- scripts = [os.path.join("data","script","xgngeo_startup.py")] #Startup script.
+ #Spanish
+- (os.path.join("share", "xgngeo", "locale", "es", "LC_MESSAGES"),
++ (os.path.join("share", "locale", "es", "LC_MESSAGES"),
+ [os.path.join("data", "locale", "es", "LC_MESSAGES", "xgngeo.mo")]),
+ #German
+- (os.path.join("share", "xgngeo", "locale", "de", "LC_MESSAGES"),
++ (os.path.join("share", "locale", "de", "LC_MESSAGES"),
+ [os.path.join("data", "locale", "de", "LC_MESSAGES", "xgngeo.mo")]),
+ #French
+- (os.path.join("share", "xgngeo", "locale", "fr", "LC_MESSAGES"),
++ (os.path.join("share", "locale", "fr", "LC_MESSAGES"),
+ [os.path.join("data", "locale", "fr", "LC_MESSAGES", "xgngeo.mo")]),
+ #Polish
+- (os.path.join("share", "xgngeo", "locale", "pl", "LC_MESSAGES"),
++ (os.path.join("share", "locale", "pl", "LC_MESSAGES"),
+ [os.path.join("data", "locale", "pl", "LC_MESSAGES", "xgngeo.mo")]),
+ #Portuguese of Brazil
+- (os.path.join("share", "xgngeo", "locale", "pt_BR", "LC_MESSAGES"),
++ (os.path.join("share", "locale", "pt_BR", "LC_MESSAGES"),
+ [os.path.join("data", "locale", "pt_BR", "LC_MESSAGES", "xgngeo.mo")])
+ ]
)
diff --git a/emulators/xgngeo/pkg-plist b/emulators/xgngeo/pkg-plist
index 4a727377b5ce..33c2687bb3b1 100644
--- a/emulators/xgngeo/pkg-plist
+++ b/emulators/xgngeo/pkg-plist
@@ -1,4 +1,3 @@
-bin/xgngeo_startup.py
bin/xgngeo
%%PYTHON_SITELIBDIR%%/xgngeo/__init__.py
%%PYTHON_SITELIBDIR%%/xgngeo/command.py
@@ -45,6 +44,7 @@ bin/xgngeo
%%DATADIR%%/rominfos.xml
%%DATADIR%%/LICENSE.txt
%%DATADIR%%/doc/xgngeo-doc.txt
+share/applications/xgngeo.desktop
share/locale/es/LC_MESSAGES/xgngeo.mo
share/locale/de/LC_MESSAGES/xgngeo.mo
share/locale/fr/LC_MESSAGES/xgngeo.mo
@@ -54,4 +54,5 @@ share/locale/pt_BR/LC_MESSAGES/xgngeo.mo
@dirrmtry %%DATADIR%%/doc
@dirrmtry %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications
@dirrm %%PYTHON_SITELIBDIR%%/xgngeo