aboutsummaryrefslogtreecommitdiff
path: root/emulators/xhomer
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-24 14:03:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-06-24 14:03:43 +0000
commitb6a21a5b7d7a3ba3aa4260eb25c8bd2a55f4e15a (patch)
treed142d65816026903d8285be60ea0039b20d5b6ee /emulators/xhomer
parent7df40923eb885e84eb1b55ca94e2b9941d792599 (diff)
downloadports-b6a21a5b7d7a3ba3aa4260eb25c8bd2a55f4e15a.tar.gz
ports-b6a21a5b7d7a3ba3aa4260eb25c8bd2a55f4e15a.zip
- Switch to options helpers
- Cosmetic fixes
Notes
Notes: svn path=/head/; revision=417422
Diffstat (limited to 'emulators/xhomer')
-rw-r--r--emulators/xhomer/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/emulators/xhomer/Makefile b/emulators/xhomer/Makefile
index 3852f17d0aca..bc97ea9674af 100644
--- a/emulators/xhomer/Makefile
+++ b/emulators/xhomer/Makefile
@@ -14,21 +14,28 @@ COMMENT= Emulator for the DEC Pro 350 computer
USES= gmake tar:tgz
USE_XORG= xt sm ice xext x11
ALL_TARGET= clean xhomer
-INSTALL_TARGET=
+INSTALL_TARGET= # empty
CFLAGS+= -Wall -ffloat-store
+
SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_FILES= bin/xhomer %%EXAMPLESDIR%%/xhomer.cfg
+PLIST_FILES= bin/xhomer
PORTDOCS= README LICENSE SIMH
+PORTEXAMPLES= xhomer.cfg
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
${INSTALL_PROGRAM} ${WRKSRC}/xhomer ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/xhomer.cfg ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>