aboutsummaryrefslogtreecommitdiff
path: root/emulators/xsystem35
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-02-10 16:44:07 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-02-10 16:44:07 +0000
commitd2a024b1211f788bc8fa25b36d45254af7400df7 (patch)
treec547259b2906701f4240549cba7b18546f8d4bb1 /emulators/xsystem35
parentc6fb94f457ca6c5a85025dcf36df25b2d6725980 (diff)
downloadports-d2a024b1211f788bc8fa25b36d45254af7400df7.tar.gz
ports-d2a024b1211f788bc8fa25b36d45254af7400df7.zip
Add and switch to GTK2 by default
Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=378784
Diffstat (limited to 'emulators/xsystem35')
-rw-r--r--emulators/xsystem35/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/emulators/xsystem35/Makefile b/emulators/xsystem35/Makefile
index 05da016fca51..95c20363287b 100644
--- a/emulators/xsystem35/Makefile
+++ b/emulators/xsystem35/Makefile
@@ -19,19 +19,27 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
OPTIONS_DEFINE= ESOUND DOCS EXAMPLES
OPTIONS_DEFINE_i386= MMX
+OPTIONS_SINGLE= GUI
+OPTIONS_SINGLE_GUI= GTK1 GTK2
+OPTIONS_DEFAULT=GTK2
OPTIONS_DEFAULT_i386= ${MACHINE_CPU:tu:MMMX}
ESOUND_USE= GNOME=esound
ESOUND_CONFIGURE_ON=--enable-audio=oss,esd --with-default-output=esd
+GTK1_USE= GNOME=gtk12
+GTK1_CONFIGURE_OFF=--with-glib-prefix=${NONEXISTENT} \
+ --with-gtk-prefix=${NONEXISTENT}
+GTK2_USE= GNOME=gtk20
+GTK2_USES= pkgconfig
MMX_BUILD_DEPENDS=nasm:${PORTSDIR}/devel/nasm
MMX_CONFIGURE_ENABLE=mmx
EXTRACT_AFTER_ARGS=--exclude libltdl
USES= gettext gmake libtool shebangfix
SHEBANG_FILES= contrib/instgame
-USE_GNOME= gtk12
USE_XORG= x11 xext xxf86vm
GNU_CONFIGURE= yes
+CONFIGURE_ENV= X_LIBS="-lX11"
CONFIGURE_ARGS= \
--with-cachesize=20 \
--disable-static \