aboutsummaryrefslogtreecommitdiff
path: root/emulators/zsnes
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-10 16:36:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-10 16:36:11 +0000
commit34d2de4b95f90cf4eaaf676976842b0c06d5c38e (patch)
tree1c62d8e98b0ee20f37e6ee7e626b9902ec344f45 /emulators/zsnes
parent686548f382c84451195f3cf3f1b8d940caba5f13 (diff)
downloadports-34d2de4b95f90cf4eaaf676976842b0c06d5c38e.tar.gz
ports-34d2de4b95f90cf4eaaf676976842b0c06d5c38e.zip
- Add option for libao support
- Minor port cleanup PR: 137562 Submitted by: Naram Qashat <cyberbotx@cyberbotx.com> (maintainer)
Notes
Notes: svn path=/head/; revision=239268
Diffstat (limited to 'emulators/zsnes')
-rw-r--r--emulators/zsnes/Makefile39
1 files changed, 22 insertions, 17 deletions
diff --git a/emulators/zsnes/Makefile b/emulators/zsnes/Makefile
index d8ea3eeb75a5..366d5a58c657 100644
--- a/emulators/zsnes/Makefile
+++ b/emulators/zsnes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zsnes
PORTVERSION= 1.51
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF
@@ -25,10 +25,11 @@ ONLY_FOR_ARCHS_REASON= non-portable, for a portable emulator see emulators/snes9
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/./_/}/src
-OPTIONS= X11 "Enable X11 video driver" on \
- OPENGL "Enable OpenGL video driver" off \
- DEBUGGER "Enable ZSNES debugger" off \
- JMA "Enable JMA support" on
+OPTIONS= X11 "Enable X11 video driver" on \
+ OPENGL "Enable OpenGL video driver" off \
+ DEBUGGER "Enable ZSNES debugger" off \
+ JMA "Enable JMA support" on \
+ LIBAO "Enable libao support" off
USE_BZIP2= yes
USE_SDL= sdl
@@ -47,36 +48,40 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 602000
-IGNORE= needs zlib >= 1.2.3 ,it is available on FreeBSD >= 6.2
+IGNORE= needs zlib >= 1.2.3, it is available on FreeBSD >= 6.2
.endif
.if defined(WITH_DEBUGGER)
-CONFIGURE_ARGS+=--enable-debugger
+CONFIGURE_ARGS+= --enable-debugger
.else
-CONFIGURE_ARGS+=--disable-debugger
+CONFIGURE_ARGS+= --disable-debugger
.endif
.if defined(WITH_JMA)
-CONFIGURE_ARGS+=--enable-jma
+CONFIGURE_ARGS+= --enable-jma
.else
-CONFIGURE_ARGS+=--disable-jma
+CONFIGURE_ARGS+= --disable-jma
.endif
.if defined(WITHOUT_X11)
-CONFIGURE_ARGS+=--without-x
+CONFIGURE_ARGS+= --without-x
PKGNAMESUFFIX= -nox11
.else
-CONFIGURE_ARGS+=--with-x
-CFLAGS+= -I${LOCALBASE}/include
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-x
.endif
.if defined(WITH_OPENGL)
USE_GL= yes
-CONFIGURE_ARGS+=--enable-opengl
+CONFIGURE_ARGS+= --enable-opengl
+.else
+CONFIGURE_ARGS+= --disable-opengl
+.endif
+
+.if defined(WITH_LIBAO)
+LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
+CONFIGURE_ARGS+= --enable-libao
.else
-CONFIGURE_ARGS+=--disable-opengl
+CONFIGURE_ARGS+= --disable-libao
.endif
post-patch: