aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2013-11-19 23:08:44 +0000
committerMathieu Arnold <mat@FreeBSD.org>2013-11-19 23:08:44 +0000
commit02e619a5d80d666372fdf370624b2d6c016de0d5 (patch)
treeab8d23ab014eb4477219665648225ccea56d0295 /emulators
parentf153879e96a329b43f46107b542848d2be0769c1 (diff)
downloadports-02e619a5d80d666372fdf370624b2d6c016de0d5.tar.gz
ports-02e619a5d80d666372fdf370624b2d6c016de0d5.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dtcyber/Makefile2
-rw-r--r--emulators/mame/Makefile4
-rw-r--r--emulators/mess/Makefile4
-rw-r--r--emulators/simh/Makefile4
4 files changed, 7 insertions, 7 deletions
diff --git a/emulators/dtcyber/Makefile b/emulators/dtcyber/Makefile
index 91b1f4ba1fde..4f165f214e78 100644
--- a/emulators/dtcyber/Makefile
+++ b/emulators/dtcyber/Makefile
@@ -13,9 +13,9 @@ DISTNAME= dtcyber20b1
MAINTAINER= ports@FreeBSD.org
COMMENT= Desktop CYBER Emulator
+USES= dos2unix
USE_ZIP= yes
USE_XORG= x11
-USE_DOS2UNIX= yes
NO_WRKSUBDIR= yes
INSTALL_TARGET=
MAKEFILE= Makefile.x11
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 2a850dcaddd8..5628405570c5 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -32,12 +32,12 @@ BUILTIN_DEBUGGER_DESC= Builtin debugger support
NO_WRKSUBDIR= yes
USE_ZIP= yes
-USES= gmake pkgconfig shebangfix
+USES= gmake pkgconfig shebangfix dos2unix
SHEBANG_FILES= src/emu/cpu/m6502/m6502make.py \
src/emu/cpu/m6809/m6809make.py \
src/emu/cpu/mcs96/mcs96make.py \
src/emu/cpu/tms57002/tmsmake.py
-USE_DOS2UNIX= src/osd/sdl/input.c \
+DOS2UNIX_FILES= src/osd/sdl/input.c \
src/osd/sdl/testkeys.c
USE_XORG= xext xi xinerama xrender
USE_GL= gl
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 32defec5fcda..61483b2e6ede 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -32,12 +32,12 @@ BUILTIN_DEBUGGER_DESC= Builtin debugger support
NO_WRKSUBDIR= yes
USE_ZIP= yes
-USES= gmake pkgconfig shebangfix
+USES= gmake pkgconfig shebangfix dos2unix
SHEBANG_FILES= src/emu/cpu/m6502/m6502make.py \
src/emu/cpu/m6809/m6809make.py \
src/emu/cpu/mcs96/mcs96make.py \
src/emu/cpu/tms57002/tmsmake.py
-USE_DOS2UNIX= src/osd/sdl/input.c \
+DOS2UNIX_FILES= src/osd/sdl/input.c \
src/osd/sdl/testkeys.c
USE_XORG= xext xi xinerama xrender
USE_GL= gl
diff --git a/emulators/simh/Makefile b/emulators/simh/Makefile
index 03511553fed3..bfc02843fd03 100644
--- a/emulators/simh/Makefile
+++ b/emulators/simh/Makefile
@@ -12,9 +12,9 @@ COMMENT= Emulates classic DEC, HP, GRI, IBM, Altair, SDS, Honeywell, and others
NO_WRKSUBDIR= yes
+USES= gmake dos2unix
USE_ZIP= yes
-USE_DOS2UNIX= VAX/vax_sysdev.c
-USE_GMAKE= yes
+DOS2UNIX_FILES= VAX/vax_sysdev.c
MAKE_ENV= GCC="${CC}" CFLAGS_O="${CFLAGS}" USE_NETWORK=1
MAKEFILE= makefile