aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-07-21 23:39:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-07-22 00:21:10 +0000
commit12d271da6d06a911ec3986b5b3be6eb933a647bc (patch)
treeb1b5cf677e1c263bb7f21847717f33e70cdc7ccb /emulators
parentea072e2909cb0ad87a69cf42d5c6274091ee12b4 (diff)
downloadports-12d271da6d06a911ec3986b5b3be6eb933a647bc.tar.gz
ports-12d271da6d06a911ec3986b5b3be6eb933a647bc.zip
emulators/rpcs3: switch to system faudio
Diffstat (limited to 'emulators')
-rw-r--r--emulators/rpcs3/Makefile5
-rw-r--r--emulators/rpcs3/files/patch-3rdparty_FAudio_src_FAudio__platform__sdl2.c23
2 files changed, 2 insertions, 26 deletions
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index 211c0e0ad1c0..eae18c2f408d 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -56,9 +56,8 @@ EVDEV_BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
EVDEV_LIB_DEPENDS= libevdev.so:devel/libevdev
FAUDIO_DESC= FAudio audio support
-FAUDIO_USES= sdl
-FAUDIO_USE= SDL=sdl2
-FAUDIO_CMAKE_BOOL= USE_FAUDIO
+FAUDIO_LIB_DEPENDS= libFAudio.so:audio/faudio
+FAUDIO_CMAKE_BOOL= USE_FAUDIO USE_SYSTEM_FAUDIO
PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio
PULSEAUDIO_CMAKE_BOOL= USE_PULSE
diff --git a/emulators/rpcs3/files/patch-3rdparty_FAudio_src_FAudio__platform__sdl2.c b/emulators/rpcs3/files/patch-3rdparty_FAudio_src_FAudio__platform__sdl2.c
deleted file mode 100644
index 0371764cfcb9..000000000000
--- a/emulators/rpcs3/files/patch-3rdparty_FAudio_src_FAudio__platform__sdl2.c
+++ /dev/null
@@ -1,23 +0,0 @@
-https://github.com/FNA-XNA/FAudio/issues/183
-
---- 3rdparty/FAudio/src/FAudio_platform_sdl2.c.orig 2020-04-01 14:55:30 UTC
-+++ 3rdparty/FAudio/src/FAudio_platform_sdl2.c
-@@ -100,6 +100,18 @@ void FAudio_PlatformInit(
- want.samples = want.freq / 100;
- }
-
-+ /* SDL audio with arts/dsp backends expect ^2, so round up.
-+ * For 48KHz this should be 512.
-+ * https://graphics.stanford.edu/~seander/bithacks.html#RoundUpPowerOf2
-+ */
-+ want.samples--;
-+ want.samples |= want.samples >> 1;
-+ want.samples |= want.samples >> 2;
-+ want.samples |= want.samples >> 4;
-+ want.samples |= want.samples >> 8;
-+ want.samples |= want.samples >> 16;
-+ want.samples++;
-+
- /* Open the device (or at least try to) */
- iosretry:
- device = SDL_OpenAudioDevice(