aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-09 22:47:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-09 22:47:32 +0000
commit19aba2b8de86f4e2d0a9c429d587e5c36fc79c4e (patch)
tree74bd9a2307ad169a042f762e7dfad8c7041a8b4b /emulators
parent4e51e56d016703078bed6ee1e0867b6ceb6ceab9 (diff)
downloadports-19aba2b8de86f4e2d0a9c429d587e5c36fc79c4e.tar.gz
ports-19aba2b8de86f4e2d0a9c429d587e5c36fc79c4e.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/xgngeo/Makefile57
-rw-r--r--emulators/xgngeo/distinfo3
-rw-r--r--emulators/xgngeo/files/patch-data-py_configfile.py32
-rw-r--r--emulators/xgngeo/files/patch-xgngeo.py80
-rw-r--r--emulators/xgngeo/pkg-descr13
-rw-r--r--emulators/xgngeo/pkg-plist42
7 files changed, 228 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index a920cabc1487..3655bd3be72a 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -144,6 +144,7 @@
SUBDIR += wine
SUBDIR += x48
SUBDIR += xbraitenberg
+ SUBDIR += xgngeo
SUBDIR += xgs
SUBDIR += xmame
SUBDIR += xmess
diff --git a/emulators/xgngeo/Makefile b/emulators/xgngeo/Makefile
new file mode 100644
index 000000000000..2d37664e3f83
--- /dev/null
+++ b/emulators/xgngeo/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: xgngeo
+# Date created: 2006-03-02
+# Whom: Jose Alonso Cardenas Marquez <acardebas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xgngeo
+PORTVERSION= 15
+CATEGORIES= emulators games
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DIST_SUBDIR= gngeo
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Fronted (GUI) for gngeo
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ gngeo:${PORTSDIR}/emulators/gngeo
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_GETTEXT= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/${PORTNAME}.py \
+ ${WRKSRC}/data/py/configfile.py
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/${PORTNAME}.py \
+ ${WRKSRC}/data/py/configfile.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xgngeo.py ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/rominfos.dtd ${WRKSRC}/data/rominfos.xml ${DATADIR}
+
+.for DIRE in img py
+ ${MKDIR} ${DATADIR}/${DIRE}
+ @cd ${WRKSRC}/data/${DIRE} && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/${DIRE}/{}" \; && \
+ ${FIND} -E * -type f -iregex ".*\.(py|pyc|png|po|mo)" \
+ -exec ${INSTALL_DATA} "{}" "${DATADIR}/${DIRE}/{}" \;
+.endfor
+
+.for LANG in es fr pl pt_BR
+ @cd ${WRKSRC}/data/lang/${LANG}/LC_MESSAGES && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${PREFIX}/share/locale/${LANG}/LC_MESSAGES/{}" \;
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/xgngeo-doc.pdf ${WRKSRC}/doc/xgngeo-doc.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/xgngeo/distinfo b/emulators/xgngeo/distinfo
new file mode 100644
index 000000000000..597f8d0ce738
--- /dev/null
+++ b/emulators/xgngeo/distinfo
@@ -0,0 +1,3 @@
+MD5 (gngeo/xgngeo-15.tar.bz2) = e0c444324376d4c5dad5ecf701822e3c
+SHA256 (gngeo/xgngeo-15.tar.bz2) = db462e8aae76d3d9688168abbc1411b3123a9efba8090286490a336df1599efb
+SIZE (gngeo/xgngeo-15.tar.bz2) = 296082
diff --git a/emulators/xgngeo/files/patch-data-py_configfile.py b/emulators/xgngeo/files/patch-data-py_configfile.py
new file mode 100644
index 000000000000..ca36c82fd3f1
--- /dev/null
+++ b/emulators/xgngeo/files/patch-data-py_configfile.py
@@ -0,0 +1,32 @@
+--- data/py/configfile.py Thu Jul 14 13:48:58 2005
++++ data/py/configfile.py Fri Apr 14 01:25:46 2006
+@@ -33,7 +33,7 @@
+ as the `gngeorc'."""
+
+ def __init__(self):
+- self.xgngeoconfPath = "data/xgngeo.conf" #Path to XGngeo config file.
++ self.xgngeoconfPath = os.path.join(os.getenv("HOME"),".gngeo/xgngeo.conf") #Path to XGngeo config file.
+ self.gngeoDir = os.path.expanduser("~/.gngeo") #Gngeo local configuration directory.
+ self.gngeorcPath = os.path.join(self.gngeoDir,"gngeorc") #Path to Gngeo config file.
+
+@@ -42,9 +42,9 @@
+ and XGngeo configuration files."""
+ return { #Gngeo default.
+ #Path
+- "libglpath":"/usr/lib/libGL.so",
++ "libglpath":"%%X11BASE%%/lib/libGL.so",
+ "rompath": os.path.join(os.getenv("HOME"),"..."),
+- "romrc":"/usr/local/share/gngeo/romrc",
++ "romrc":"%%X11BASE%%/share/gngeo/romrc",
+ #Graphic
+ "blitter":"soft",
+ "effect":"none",
+@@ -74,7 +74,7 @@
+ "previewimages":"false",
+ "previewimagedir":"data/previewimages/",
+ "rominfos":"true",
+- "rominfoxml":"data/rominfos.xml",
++ "rominfoxml":"%%DATADIR%%/rominfos.xml",
+ "showavailableromsonly":"true"
+ }
+
diff --git a/emulators/xgngeo/files/patch-xgngeo.py b/emulators/xgngeo/files/patch-xgngeo.py
new file mode 100644
index 000000000000..2b8acaa4c570
--- /dev/null
+++ b/emulators/xgngeo/files/patch-xgngeo.py
@@ -0,0 +1,80 @@
+--- xgngeo.py Thu Jul 14 13:48:58 2005
++++ /home/acardenas/xgngeo.py Thu Mar 2 21:39:00 2006
+@@ -28,14 +28,14 @@
+ os.chdir(os.path.abspath(syspath[0]))
+
+ #Add `data/py/' to PATH, then import internal modules.
+-syspath.append("data/py/")
++syspath.append("%%DATADIR%%/py/")
+ import command, configfile, history, rominfos, romrcfile
+
+ VERSION = 15
+ gngeoDir = os.path.expanduser("~/.gngeo")
+
+ #Internationalization.
+-gettext.install("xgngeo","data/lang")
++gettext.install("xgngeo","%%X11BASE%%/share/locale")
+
+ class XGngeo:
+ def checkError(self):
+@@ -591,7 +591,7 @@
+ frame.add(box)
+
+ logo = gtk.Image()
+- logo.set_from_file("data/img/chprod.png")
++ logo.set_from_file("%%DATADIR%%/img/chprod.png")
+ box.pack_start(logo,False)
+
+ box2 = gtk.VBox(spacing=4)
+@@ -1087,7 +1087,7 @@
+
+ #Generate key's image
+ image = gtk.Image()
+- image.set_from_file("data/img/key_%s.png" % key_list[i])
++ image.set_from_file("%%DATADIR%%/img/key_%s.png" % key_list[i])
+
+ box2 = gtk.HBox() #A box...
+ box2.pack_start(p1keywidgets[i]) #with P1 key...
+@@ -1131,21 +1131,21 @@
+ if temp_param["country"]=="japan": self.configwidgets['country_japan'].set_active(1)
+ table.attach(self.configwidgets['country_japan'],0,1,0,1)
+ image = gtk.Image()
+- image.set_from_file("data/img/japan.png")
++ image.set_from_file("%%DATADIR%%/img/japan.png")
+ table.attach(image,0,1,1,2)
+
+ self.configwidgets['country_usa'] = gtk.RadioButton(self.configwidgets['country_japan'],_("USA"))
+ if temp_param["country"]=="usa": self.configwidgets['country_usa'].set_active(1)
+ table.attach(self.configwidgets['country_usa'],1,2,0,1)
+ image = gtk.Image()
+- image.set_from_file("data/img/usa.png")
++ image.set_from_file("%%DATADIR%%/img/usa.png")
+ table.attach(image,1,2,1,2)
+
+ radio = gtk.RadioButton(self.configwidgets['country_japan'],_("Europe"))
+ if temp_param["country"]=="europe": radio.set_active(1)
+ table.attach(radio,2,3,0,1)
+ image = gtk.Image()
+- image.set_from_file("data/img/europe.png")
++ image.set_from_file("%%DATADIR%%/img/europe.png")
+ table.attach(image,2,3,1,2)
+ frame2.add(table)
+ box.pack_start(frame2)
+@@ -1408,7 +1408,7 @@
+ self.context_id = self.statusbar.get_context_id("Info")
+
+ self.window = gtk.Window(gtk.WINDOW_TOPLEVEL)
+- gtk.window_set_default_icon_from_file("data/img/icon.png")
++ gtk.window_set_default_icon_from_file("%%DATADIR%%/img/icon.png")
+
+ def main(self):
+ #Window attributes.
+@@ -1536,7 +1536,7 @@
+ container = gtk.EventBox()
+ container.modify_bg(gtk.STATE_NORMAL,gtk.gdk.color_parse("white"))
+ logo = gtk.Image()
+- logo.set_from_file("data/img/xgngeo.png")
++ logo.set_from_file("%%DATADIR%%/img/xgngeo.png")
+ logo.set_padding(25,2)
+ container.add(logo)
+ box.pack_start(container)
diff --git a/emulators/xgngeo/pkg-descr b/emulators/xgngeo/pkg-descr
new file mode 100644
index 000000000000..421e2ebd19d8
--- /dev/null
+++ b/emulators/xgngeo/pkg-descr
@@ -0,0 +1,13 @@
+XGngeo is a frontend (GUI) for Gngeo which is a powerful command line Neo Geo
+emulator for the GNU/Linux, FreeBSD system (and may be some other Unices). Both
+are free softwares released under the GNU GPL license.
+
+XGngeo is written in Python and uses the PyGTK library to provide a complete,
+pratical, and user-friendly GTK+ interface over Gngeo!
+
+With XGngeo multiple configuration panels, designed in an intuitive way,
+emulator behaviour can be regulated both precisely and easily; while Rom
+selection is made simple thanks to a full featured list with preview image and
+various game information, etc.
+
+WWW: http://www.choplair.org/xgngeo.en.html
diff --git a/emulators/xgngeo/pkg-plist b/emulators/xgngeo/pkg-plist
new file mode 100644
index 000000000000..bcb075a38002
--- /dev/null
+++ b/emulators/xgngeo/pkg-plist
@@ -0,0 +1,42 @@
+bin/xgngeo.py
+%%PORTDOCS%%%%DOCSDIR%%/xgngeo-doc.pdf
+%%PORTDOCS%%%%DOCSDIR%%/xgngeo-doc.txt
+%%DATADIR%%/img/chprod.png
+%%DATADIR%%/img/europe.png
+%%DATADIR%%/img/icon.png
+%%DATADIR%%/img/japan.png
+%%DATADIR%%/img/key_A.png
+%%DATADIR%%/img/key_B.png
+%%DATADIR%%/img/key_C.png
+%%DATADIR%%/img/key_COIN.png
+%%DATADIR%%/img/key_D.png
+%%DATADIR%%/img/key_DOWN.png
+%%DATADIR%%/img/key_LEFT.png
+%%DATADIR%%/img/key_RIGHT.png
+%%DATADIR%%/img/key_START.png
+%%DATADIR%%/img/key_UP.png
+%%DATADIR%%/img/usa.png
+%%DATADIR%%/img/xgngeo.png
+share/locale/es/LC_MESSAGES/xgngeo.mo
+share/locale/es/LC_MESSAGES/xgngeo.po
+share/locale/fr/LC_MESSAGES/xgngeo.mo
+share/locale/fr/LC_MESSAGES/xgngeo.po
+share/locale/pl/LC_MESSAGES/xgngeo.mo
+share/locale/pl/LC_MESSAGES/xgngeo.po
+share/locale/pt_BR/LC_MESSAGES/xgngeo.po
+%%DATADIR%%/py/command.py
+%%DATADIR%%/py/configfile.py
+%%DATADIR%%/py/history.py
+%%DATADIR%%/py/rominfos.py
+%%DATADIR%%/py/romrcfile.py
+%%DATADIR%%/py/romrcfile.pyc
+%%DATADIR%%/py/command.pyc
+%%DATADIR%%/py/configfile.pyc
+%%DATADIR%%/py/history.pyc
+%%DATADIR%%/py/rominfos.pyc
+%%DATADIR%%/rominfos.dtd
+%%DATADIR%%/rominfos.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/py
+@dirrm %%DATADIR%%