aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-05-17 13:45:52 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-05-18 00:47:14 +0000
commit27d3f63cf1fea7262c8596cb852894e1a244b0fe (patch)
tree3537a6da0c61adb077191d637f7f2e9bcda62e57 /emulators
parent132db33e49ddaa8353987033a8204134af7a6077 (diff)
downloadports-27d3f63cf1fea7262c8596cb852894e1a244b0fe.tar.gz
ports-27d3f63cf1fea7262c8596cb852894e1a244b0fe.zip
emulators/yuzu: convert to USES=cmake:testing
Diffstat (limited to 'emulators')
-rw-r--r--emulators/yuzu/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index 0a34f6104b81..ad0d4df839b3 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -78,13 +78,12 @@ GH_TUPLE= yuzu-emu:mbedtls:v2.16.9-115-g8c88150ca:mbedtls/externals/mbedtls \
kinetiknz:cubeb:cubeb-0.2-1298-g8d53747:cubeb/externals/cubeb \
benhoyt:inih:r52:inih/externals/inih/inih
-USES= cmake compiler:c++17-lang localbase:ldflags sdl ssl
+USES= cmake:testing compiler:c++17-lang localbase:ldflags sdl ssl
USE_GCC= yes:build # libc++ lacks std::atomic_ref, std::ranges
USE_SDL= sdl2
CMAKE_OFF= ENABLE_GNUTLS ENABLE_MBEDTLS
LDFLAGS+= -static-libstdc++ # avoid libc++ conflict, requires files/patch-fmt
LDFLAGS+= -Wl,--as-needed # Qt5Network
-TEST_TARGET= test
OPTIONS_DEFINE= ALSA PULSEAUDIO JACK SNDIO VULKAN
OPTIONS_DEFAULT=PULSEAUDIO JACK SNDIO VULKAN