aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-10-10 14:03:00 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-10-10 14:03:00 +0000
commit3a55a118dde2f1cef80ad8ed446044449cb8417d (patch)
tree4ac25229c12e49e974a92ecd82e01b92eea15c00 /emulators
parent630b5a689e7c6ead73c118b24cff9156918e9155 (diff)
downloadports-3a55a118dde2f1cef80ad8ed446044449cb8417d.tar.gz
ports-3a55a118dde2f1cef80ad8ed446044449cb8417d.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/vmw/Makefile7
-rw-r--r--emulators/vmw/files/patch-vmshf.c17
2 files changed, 22 insertions, 2 deletions
diff --git a/emulators/vmw/Makefile b/emulators/vmw/Makefile
index 37f6e738cf05..456f44b77b99 100644
--- a/emulators/vmw/Makefile
+++ b/emulators/vmw/Makefile
@@ -2,6 +2,7 @@
PORTNAME= vmw
PORTVERSION= 060510
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://sites.google.com/site/chitchatvmback/storage/
@@ -33,7 +34,7 @@ PLIST_FILES+= sbin/${i}
.if !exists(/usr/lib32/libc.so)
IGNORE= please install lib32
.endif
-.if ${OSVERSION} < 1000000
+.if !empty(ICONV_LIB)
IGNORE= needs 32bit libiconv
.endif
CFLAGS+= -m32
@@ -42,9 +43,11 @@ LDFLAGS+= -m32 -B/usr/lib32 -L/usr/lib32
LD= ${CC}
.endif
-.if ${OSVERSION} > 1000000
+.if empty(ICONV_LIB)
FTPLIB=
MAKE_ENV+= FTPLIB="${FTPLIB}"
+.else
+CFLAGS+= -I${LOCALBASE}/include
.endif
do-install:
diff --git a/emulators/vmw/files/patch-vmshf.c b/emulators/vmw/files/patch-vmshf.c
new file mode 100644
index 000000000000..02c81403f8e4
--- /dev/null
+++ b/emulators/vmw/files/patch-vmshf.c
@@ -0,0 +1,17 @@
+--- vmshf.c.orig 2006-05-10 04:36:12 UTC
++++ vmshf.c
+@@ -306,14 +306,7 @@ static uint32_t LocalToUtf8(char *dst, c
+ unix systems with iconv.h
+ -- use iconv() for code conversion
+ */
+-#ifdef __FreeBSD__
+-#include <sys/types.h>
+-#include <sys/iconv.h>
+-typedef size_t iconv_t;
+-#else /* __FreeBSD__ */
+ #include <iconv.h>
+-#endif /* __FreeBSD__ */
+-
+ #include <langinfo.h>
+ #include <locale.h>
+ #include <strings.h>