aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2011-12-18 04:18:01 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2011-12-18 04:18:01 +0000
commit5e1484a800cf5aea260f6b69cef2ac166e9f1411 (patch)
tree97b5f2991c5a641a1f4b009b665a48e0bbcaa0e2 /emulators
parent3a04e009c1bb7e6a661fdea457b38c0b69a00cfa (diff)
downloadports-5e1484a800cf5aea260f6b69cef2ac166e9f1411.tar.gz
ports-5e1484a800cf5aea260f6b69cef2ac166e9f1411.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/wxmupen64plus/Makefile50
-rw-r--r--emulators/wxmupen64plus/distinfo2
-rw-r--r--emulators/wxmupen64plus/files/patch-wscript27
-rw-r--r--emulators/wxmupen64plus/pkg-descr3
-rw-r--r--emulators/wxmupen64plus/pkg-plist27
6 files changed, 110 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 612c6cfb2cdf..0d1ec87499d7 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -183,6 +183,7 @@
SUBDIR += wine
SUBDIR += wine-doors
SUBDIR += wine-gecko
+ SUBDIR += wxmupen64plus
SUBDIR += x48
SUBDIR += xbraitenberg
SUBDIR += xcpc
diff --git a/emulators/wxmupen64plus/Makefile b/emulators/wxmupen64plus/Makefile
new file mode 100644
index 000000000000..c60c3e762483
--- /dev/null
+++ b/emulators/wxmupen64plus/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: wxmupen64plus
+# Date created: 2011-12-17
+# Whom: Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxmupen64plus
+PORTVERSION= 0.2
+CATEGORIES= emulators
+MASTER_SITES= http://cdn.bitbucket.org/auria/wxmupen64plus/downloads/
+DIST_SUBDIR= ${PORTNAME:S/wx//}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= A Mupen64Plus 2.0 GUI frontend written using wxWidgets
+
+LIB_DEPENDS= mupen64plus.2:${PORTSDIR}/emulators/mupen64plus-core
+RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:${PORTSDIR}/emulators/mupen64plus-core \
+ ${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:${PORTSDIR}/emulators/mupen64plus-audio-sdl \
+ ${LOCALBASE}/lib/mupen64plus/mupen64plus-input-sdl.so:${PORTSDIR}/emulators/mupen64plus-input-sdl \
+ ${LOCALBASE}/lib/mupen64plus/mupen64plus-rsp-hle.so:${PORTSDIR}/emulators/mupen64plus-rsp-hle \
+ ${LOCALBASE}/lib/mupen64plus/mupen64plus-video-rice.so:${PORTSDIR}/emulators/mupen64plus-video-rice \
+ mupen64plus:${PORTSDIR}/emulators/mupen64plus-ui-console
+
+USE_ZIP= yes
+USE_SDL= yes
+USE_WX= 2.9
+WX_UNICODE= yes
+USE_PYTHON= yes
+
+WAF_SCRIPT= waf
+
+do-configure:
+ @cd ${WRKSRC} && \
+ ${PYTHON_CMD} ${WAF_SCRIPT} configure --mupenapi=${LOCALBASE}/include/${PORTNAME:S/wx//} \
+ --wxconfig=${WX_CONFIG} \
+ --sdlconfig=${SDL_CONFIG} \
+ --datadir=${DATADIR} \
+ --libdir=${LOCALBASE}/lib/${PORTNAME:S/wx//}
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${WAF_SCRIPT}
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/build/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/emulators/wxmupen64plus/distinfo b/emulators/wxmupen64plus/distinfo
new file mode 100644
index 000000000000..5afedad48b16
--- /dev/null
+++ b/emulators/wxmupen64plus/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mupen64plus/wxmupen64plus-0.2.zip) = c6cc2a3d63a3d8d81d2d4635efd1f180aac9442dec2abd3943fc5eee6ef3f4c4
+SIZE (mupen64plus/wxmupen64plus-0.2.zip) = 310793
diff --git a/emulators/wxmupen64plus/files/patch-wscript b/emulators/wxmupen64plus/files/patch-wscript
new file mode 100644
index 000000000000..ace8f57cb4c5
--- /dev/null
+++ b/emulators/wxmupen64plus/files/patch-wscript
@@ -0,0 +1,27 @@
+--- wscript 2011-10-17 09:27:26.000000000 -0500
++++ wscript 2011-12-17 22:26:58.000000000 -0500
+@@ -153,15 +153,21 @@
+ data_dir = bld.path.find_dir('data')
+ bld.install_files('wxMupen64Plus.app/Contents/Resources', data_dir.ant_glob('*'))
+ bin_install_path = "wxMupen64Plus.app/Contents/MacOS"
+-
++ elif os.uname()[0] == 'FreeBSD':
++ if 'LOCALBASE' in os.environ:
++ LOCALBASE = os.environ['LOCALBASE']
++ else:
++ LOCALBASE = '/usr/local/'
++
++ build_flags += ['-I'+ LOCALBASE +'/include/X11']
++ osal_src += ['mupen64plusplus/osal_dynamiclib_unix.c', 'mupen64plusplus/osal_files_unix.c']
++ link_flags += ['-lGL','-lX11']
+ else:
+ # For other unices
+ build_flags += ['-I/usr/include/X11']
+ osal_src += ['mupen64plusplus/osal_dynamiclib_unix.c', 'mupen64plusplus/osal_files_unix.c']
+ link_flags += ['-lGL', '-ldl', '-lX11']
+
+- link_flags += ['-ldl']
+-
+ # install target
+ data_dir = bld.path.find_dir('data')
+ if len(bld.env['datadir']) > 0:
diff --git a/emulators/wxmupen64plus/pkg-descr b/emulators/wxmupen64plus/pkg-descr
new file mode 100644
index 000000000000..cd6ff9b891e5
--- /dev/null
+++ b/emulators/wxmupen64plus/pkg-descr
@@ -0,0 +1,3 @@
+wxMupen64plus is A Mupen64Plus v2 frontend written with wxWidgets
+
+WWW: http://bitbucket.org/auria/wxmupen64plus
diff --git a/emulators/wxmupen64plus/pkg-plist b/emulators/wxmupen64plus/pkg-plist
new file mode 100644
index 000000000000..05c2ee71167c
--- /dev/null
+++ b/emulators/wxmupen64plus/pkg-plist
@@ -0,0 +1,27 @@
+@comment $FreeBSD$
+bin/wxmupen64plus
+%%DATADIR%%/audio.png
+%%DATADIR%%/cancel.bmp
+%%DATADIR%%/down.png
+%%DATADIR%%/emulation.png
+%%DATADIR%%/erase.bmp
+%%DATADIR%%/input.png
+%%DATADIR%%/left.png
+%%DATADIR%%/mupen64cart.icns
+%%DATADIR%%/mupen64cart.png
+%%DATADIR%%/mupenicon.png
+%%DATADIR%%/mupenicon_large.png
+%%DATADIR%%/other.png
+%%DATADIR%%/pause.png
+%%DATADIR%%/play.png
+%%DATADIR%%/plugins.png
+%%DATADIR%%/presskey.bmp
+%%DATADIR%%/right.png
+%%DATADIR%%/stop.png
+%%DATADIR%%/up.png
+%%DATADIR%%/V64Doc.ico
+%%DATADIR%%/video.png
+%%DATADIR%%/warning.png
+%%DATADIR%%/wxMupen64Plus.icns
+%%DATADIR%%/wxmupen64plus.ico
+@dirrm %%DATADIR%%