aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-03-14 11:45:56 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-03-14 11:45:56 +0000
commit61e85817bd97a0a589328fbf5b10661ef70119bf (patch)
tree1aa79b3e8796dafba87e3e6f948e50f31beeef0c /emulators
parenta89964f9a0ffaa336672be5157770de6d36130af (diff)
downloadports-61e85817bd97a0a589328fbf5b10661ef70119bf.tar.gz
ports-61e85817bd97a0a589328fbf5b10661ef70119bf.zip
Add emulators/sameboy
SameBoy is a user friendly, powerful and open source Game Boy, Game Boy Color and Super Game Boy emulator. SameBoy is extremely accurate and includes a wide range of powerful debugging features, making it ideal for both casual players and developers. In addition to accuracy and developer capabilities, SameBoy has all the features one would expect from an emulator from save states to scaling filters. WWW: https://sameboy.github.io/
Notes
Notes: svn path=/head/; revision=568381
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/sameboy/Makefile42
-rw-r--r--emulators/sameboy/distinfo3
-rw-r--r--emulators/sameboy/pkg-descr9
-rw-r--r--emulators/sameboy/pkg-plist45
5 files changed, 100 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 8c2d2e8f08f2..fc3fae92dbb3 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -127,6 +127,7 @@
SUBDIR += rpcs3
SUBDIR += rtc
SUBDIR += rubygem-fission
+ SUBDIR += sameboy
SUBDIR += sdltrs
SUBDIR += simh
SUBDIR += simh-hp2100
diff --git a/emulators/sameboy/Makefile b/emulators/sameboy/Makefile
new file mode 100644
index 000000000000..d3b978e09da7
--- /dev/null
+++ b/emulators/sameboy/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= sameboy
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.14.2
+CATEGORIES= emulators games
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Game Boy and Game Boy Color emulator written in C
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= rgbds>0:devel/rgbds
+
+USES= compiler:c11 desktop-file-utils gl gmake pkgconfig sdl \
+ shared-mime-info
+USE_GITHUB= yes
+GH_ACCOUNT= LIJI32
+GH_PROJECT= SameBoy
+USE_GL= gl
+USE_SDL= sdl2
+
+MAKE_ARGS= FREEDESKTOP=true
+ALL_TARGET= sdl
+# -flto
+LDFLAGS+= -fuse-ld=lld
+
+OPTIONS_DEFINE= LIBRETRO
+OPTIONS_DEFAULT= LIBRETRO
+OPTIONS_SUB= yes
+
+LIBRETRO_DESC= Build libretro core
+
+LIBRETRO_ALL_TARGET= libretro
+
+post-install-LIBRETRO-on:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/libretro
+ ${INSTALL_LIB} ${WRKSRC}/build/bin/sameboy_libretro.so \
+ ${STAGEDIR}${PREFIX}/lib/libretro
+
+.include <bsd.port.mk>
diff --git a/emulators/sameboy/distinfo b/emulators/sameboy/distinfo
new file mode 100644
index 000000000000..8df6ec75eaa2
--- /dev/null
+++ b/emulators/sameboy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615679711
+SHA256 (LIJI32-SameBoy-v0.14.2_GH0.tar.gz) = 94519ea37ef2a7db7089b178d52e53bf6b6f4967c7b56bb3dd7537a8c7c01b1c
+SIZE (LIJI32-SameBoy-v0.14.2_GH0.tar.gz) = 2826305
diff --git a/emulators/sameboy/pkg-descr b/emulators/sameboy/pkg-descr
new file mode 100644
index 000000000000..0f705c5fc7ee
--- /dev/null
+++ b/emulators/sameboy/pkg-descr
@@ -0,0 +1,9 @@
+SameBoy is a user friendly, powerful and open source Game Boy, Game
+Boy Color and Super Game Boy emulator. SameBoy is extremely accurate
+and includes a wide range of powerful debugging features, making
+it ideal for both casual players and developers. In addition to
+accuracy and developer capabilities, SameBoy has all the features
+one would expect from an emulator from save states to scaling
+filters.
+
+WWW: https://sameboy.github.io/
diff --git a/emulators/sameboy/pkg-plist b/emulators/sameboy/pkg-plist
new file mode 100644
index 000000000000..0fd0c1034af3
--- /dev/null
+++ b/emulators/sameboy/pkg-plist
@@ -0,0 +1,45 @@
+bin/sameboy
+%%LIBRETRO%%lib/libretro/sameboy_libretro.so
+share/applications/sameboy.desktop
+share/icons/hicolor/128x128/apps/sameboy.png
+share/icons/hicolor/128x128/mimetypes/x-gameboy-color-rom.png
+share/icons/hicolor/128x128/mimetypes/x-gameboy-rom.png
+share/icons/hicolor/16x16/apps/sameboy.png
+share/icons/hicolor/16x16/mimetypes/x-gameboy-color-rom.png
+share/icons/hicolor/16x16/mimetypes/x-gameboy-rom.png
+share/icons/hicolor/256x256/apps/sameboy.png
+share/icons/hicolor/256x256/mimetypes/x-gameboy-color-rom.png
+share/icons/hicolor/256x256/mimetypes/x-gameboy-rom.png
+share/icons/hicolor/32x32/apps/sameboy.png
+share/icons/hicolor/32x32/mimetypes/x-gameboy-color-rom.png
+share/icons/hicolor/32x32/mimetypes/x-gameboy-rom.png
+share/icons/hicolor/512x512/apps/sameboy.png
+share/icons/hicolor/512x512/mimetypes/x-gameboy-color-rom.png
+share/icons/hicolor/512x512/mimetypes/x-gameboy-rom.png
+share/icons/hicolor/64x64/apps/sameboy.png
+share/icons/hicolor/64x64/mimetypes/x-gameboy-color-rom.png
+share/icons/hicolor/64x64/mimetypes/x-gameboy-rom.png
+share/mime/packages/sameboy.xml
+@comment %%DATADIR%%/LICENSE
+%%DATADIR%%/Shaders/AAOmniScaleLegacy.fsh
+%%DATADIR%%/Shaders/AAScale2x.fsh
+%%DATADIR%%/Shaders/AAScale4x.fsh
+%%DATADIR%%/Shaders/Bilinear.fsh
+%%DATADIR%%/Shaders/CRT.fsh
+%%DATADIR%%/Shaders/HQ2x.fsh
+%%DATADIR%%/Shaders/LCD.fsh
+%%DATADIR%%/Shaders/MasterShader.fsh
+%%DATADIR%%/Shaders/MonoLCD.fsh
+%%DATADIR%%/Shaders/NearestNeighbor.fsh
+%%DATADIR%%/Shaders/OmniScale.fsh
+%%DATADIR%%/Shaders/OmniScaleLegacy.fsh
+%%DATADIR%%/Shaders/Scale2x.fsh
+%%DATADIR%%/Shaders/Scale4x.fsh
+%%DATADIR%%/Shaders/SmoothBilinear.fsh
+%%DATADIR%%/agb_boot.bin
+%%DATADIR%%/background.bmp
+%%DATADIR%%/cgb_boot.bin
+%%DATADIR%%/dmg_boot.bin
+%%DATADIR%%/registers.sym
+%%DATADIR%%/sgb2_boot.bin
+%%DATADIR%%/sgb_boot.bin