aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2011-12-02 14:04:47 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2011-12-02 14:04:47 +0000
commit71895d704519495aec2c3cae4b7579e3f5e74ea8 (patch)
tree7959bd5b5428e5a843c6158543689cf5069a23ad /emulators
parent7312f3a17652a1d1fd8aa7df0486418f05eb2f97 (diff)
downloadports-71895d704519495aec2c3cae4b7579e3f5e74ea8.tar.gz
ports-71895d704519495aec2c3cae4b7579e3f5e74ea8.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose/Makefile1
-rw-r--r--emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c16
2 files changed, 17 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index f06ec40757a3..e9be08d3b0c2 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -7,6 +7,7 @@
PORTNAME= virtualbox-ose
DISTVERSION= 4.0.12
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
diff --git a/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c b/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c
new file mode 100644
index 000000000000..671bb5552189
--- /dev/null
+++ b/emulators/virtualbox-ose/files/patch-src-VBox-Runtime-r3-freebsd-fileaio-freebsd.c
@@ -0,0 +1,16 @@
+Runtime/fileaio-freebsd: Fix error check for aio_error
+
+Obtained-from: https://www.virtualbox.org/changeset/38332
+
+--- src/VBox/Runtime/r3/freebsd/fileaio-freebsd.cpp.orig 2011-07-15 17:34:34.000000000 +0200
++++ src/VBox/Runtime/r3/freebsd/fileaio-freebsd.cpp 2011-11-21 09:33:26.155092865 +0100
+@@ -416,7 +416,8 @@
+ {
+ pReqInt = pahReqs[i];
+ rcBSD = aio_error(&pReqInt->AioCB);
+- if (rcBSD == EINVAL || rcBSD == EAGAIN)
++ if ( rcBSD == -1
++ && errno == EINVAL)
+ {
+ /* Was not submitted. */
+ RTFILEAIOREQ_SET_STATE(pReqInt, PREPARED);