aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-05 22:58:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-05 22:58:02 +0000
commit7277ec6a16005fbbf00e59a8beacc7634f4376fc (patch)
tree89becbb47fd3ca1d6f3fd97d6677e0b01732e970 /emulators
parent96966101c6558191cb15925803ded6baf1737eb7 (diff)
downloadports-7277ec6a16005fbbf00e59a8beacc7634f4376fc.tar.gz
ports-7277ec6a16005fbbf00e59a8beacc7634f4376fc.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile1
-rw-r--r--emulators/qemu-devel/files/patch-configure26
-rw-r--r--emulators/qemu/Makefile1
-rw-r--r--emulators/qemu/files/patch-configure26
4 files changed, 2 insertions, 52 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index e0fc0971b363..b576e1ecb91a 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -110,6 +110,7 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
# but it shouldn't matter much
post-patch:
@${REINPLACE_CMD} -e '/LIBS/s|-lprocstat|-lprocstat -lelf|' \
+ -e '/libusb/s/ --atleast-version=1\.0\.[0-9]*//' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
@${REINPLACE_CMD} -E \
diff --git a/emulators/qemu-devel/files/patch-configure b/emulators/qemu-devel/files/patch-configure
index 40a964f3df4e..c01324559867 100644
--- a/emulators/qemu-devel/files/patch-configure
+++ b/emulators/qemu-devel/files/patch-configure
@@ -130,32 +130,6 @@
fi
# Search for bswap_32 function
-@@ -3992,6 +4045,17 @@ fi
-
- # check for libusb
- if test "$libusb" != "no" ; then
-+ cat > $TMPC << EOF
-+#include <libusb.h>
-+
-+int main(void) { return libusb_get_port_path(NULL, NULL, NULL, 0); }
-+EOF
-+ if compile_prog "-Werror" "-lusb -pthread" ; then
-+ libusb="yes"
-+ libusb_cflags=""
-+ libusb_libs=-lusb
-+ libs_softmmu="$libs_softmmu $libusb_libs"
-+ else
- if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
- libusb="yes"
- libusb_cflags=$($pkg_config --cflags libusb-1.0)
-@@ -4004,6 +4068,7 @@ if test "$libusb" != "no" ; then
- fi
- libusb="no"
- fi
-+ fi
- fi
-
- # check for usbredirparser for usb network redirection support
@@ -4769,6 +4834,7 @@ echo "Audio drivers $audio_drv_list"
echo "Block whitelist (rw) $block_drv_rw_whitelist"
echo "Block whitelist (ro) $block_drv_ro_whitelist"
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 75bbb759ec5e..b9bd546f803c 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -111,6 +111,7 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
# but it shouldn't matter much
post-patch:
@${REINPLACE_CMD} -e '/LIBS/s|-lprocstat|-lprocstat -lelf|' \
+ -e '/libusb/s/ --atleast-version=1\.0\.[0-9]*//' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
@${REINPLACE_CMD} -E \
diff --git a/emulators/qemu/files/patch-configure b/emulators/qemu/files/patch-configure
index 40a964f3df4e..c01324559867 100644
--- a/emulators/qemu/files/patch-configure
+++ b/emulators/qemu/files/patch-configure
@@ -130,32 +130,6 @@
fi
# Search for bswap_32 function
-@@ -3992,6 +4045,17 @@ fi
-
- # check for libusb
- if test "$libusb" != "no" ; then
-+ cat > $TMPC << EOF
-+#include <libusb.h>
-+
-+int main(void) { return libusb_get_port_path(NULL, NULL, NULL, 0); }
-+EOF
-+ if compile_prog "-Werror" "-lusb -pthread" ; then
-+ libusb="yes"
-+ libusb_cflags=""
-+ libusb_libs=-lusb
-+ libs_softmmu="$libs_softmmu $libusb_libs"
-+ else
- if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
- libusb="yes"
- libusb_cflags=$($pkg_config --cflags libusb-1.0)
-@@ -4004,6 +4068,7 @@ if test "$libusb" != "no" ; then
- fi
- libusb="no"
- fi
-+ fi
- fi
-
- # check for usbredirparser for usb network redirection support
@@ -4769,6 +4834,7 @@ echo "Audio drivers $audio_drv_list"
echo "Block whitelist (rw) $block_drv_rw_whitelist"
echo "Block whitelist (ro) $block_drv_ro_whitelist"