aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2021-03-30 21:30:31 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2021-03-30 21:30:31 +0000
commit72a4b7ab575fe51fe7c895e4620d43c96df51d0d (patch)
tree2a9d76cb74b74cba7d0234d4b9280412f107453f /emulators
parent0b7ddc83164870866f6514cc5a9d2edb3d8f70df (diff)
downloadports-72a4b7ab575fe51fe7c895e4620d43c96df51d0d.tar.gz
ports-72a4b7ab575fe51fe7c895e4620d43c96df51d0d.zip
Reimplement patch to disable Asyncronous IO in virtualbox-ose 6 as
an option, leaving AIO enabled by default, so no functional change in default build. Requested/Suggested by: David G Lawrence <dg@dglawrence.com>
Notes
Notes: svn path=/head/; revision=569604
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 2a929438a8ac..785bde1f0a79 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -53,11 +53,12 @@ VBOX_PROGS= VBoxAutostart VBoxBalloonCtrl VBoxBugReport VBoxHeadless \
VBOX_UTILS= VBoxExtPackHelperApp VBoxNetAdpCtl VBoxNetDHCP VBoxNetNAT \
VBoxSVC VBoxXPCOMIPCD
-OPTIONS_DEFINE= ALSA DBUS DEBUG GUESTADDITIONS MANUAL NLS OPUS PULSEAUDIO \
+OPTIONS_DEFINE= AIO ALSA DBUS DEBUG GUESTADDITIONS MANUAL NLS OPUS PULSEAUDIO \
PYTHON QT5 R0LOGGING UDPTUNNEL VDE VNC WEBSERVICE VPX X11
-OPTIONS_DEFAULT= DBUS QT5 UDPTUNNEL VNC WEBSERVICE X11
+OPTIONS_DEFAULT= AIO DBUS QT5 UDPTUNNEL VNC WEBSERVICE X11
OPTIONS_SUB= yes
+AIO_DESC= Enable Asyncronous IO support (check pkg-message)
DEBUG_DESC= Debug symbols, additional logs and assertions
GUESTADDITIONS_DESC= Build with Guest Additions
MANUAL_DESC= Build with user manual
@@ -323,6 +324,10 @@ post-patch:
-e 's|^versions =.*|versions = ["${PYTHON_VER}${PYTHON_ABIVER}"]|' \
${WRKSRC}/src/libs/xpcom18a4/python/gen_python_deps.py
+post-patch-AIO-off:
+ @${REINPLACE_CMD} 's|r3/freebsd/fileaio-freebsd.cpp|r3/posix/fileaio-posix.cpp|' \
+ ${WRKSRC}/src/VBox/Runtime/Makefile.kmk
+
do-build:
cd ${WRKSRC} && ${SH} -c '. ${WRKSRC}/env.sh && \
${KMK_CONFIG} ${LOCALBASE}/bin/kmk ${KMK_FLAGS}'