aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorFelix Palmen <felix@palmen-it.de>2021-07-10 09:05:01 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-07-14 08:58:07 +0000
commit74fab2f5773d2eccc293b06de2fe9a477040aa3f (patch)
treeed3254d8393670abb45b391df787afebeb22f6b4 /emulators
parent291bf5665200779fb18d026c418de8a1b1633569 (diff)
downloadports-74fab2f5773d2eccc293b06de2fe9a477040aa3f.tar.gz
ports-74fab2f5773d2eccc293b06de2fe9a477040aa3f.zip
emulators/emu64: update to 5.0.19
Diffstat (limited to 'emulators')
-rw-r--r--emulators/emu64/Makefile6
-rw-r--r--emulators/emu64/distinfo6
-rw-r--r--emulators/emu64/files/patch-src_c64__class.cpp23
-rw-r--r--emulators/emu64/files/patch-src_src.pro18
-rw-r--r--emulators/emu64/files/patch-src_widget__file__browse.h2
-rw-r--r--emulators/emu64/pkg-message13
-rw-r--r--emulators/emu64/pkg-plist1
7 files changed, 29 insertions, 40 deletions
diff --git a/emulators/emu64/Makefile b/emulators/emu64/Makefile
index 787e5ee77d98..bfa696e1b4b0 100644
--- a/emulators/emu64/Makefile
+++ b/emulators/emu64/Makefile
@@ -1,8 +1,7 @@
# Created by: Felix Palmen <felix@palmen-it.de>
PORTNAME= emu64
-PORTVERSION= 5.0.18
-PORTREVISION= 3
+PORTVERSION= 5.0.19
CATEGORIES= emulators
MAINTAINER= felix@palmen-it.de
@@ -20,8 +19,7 @@ USES= compiler:c++11-lang desktop-file-utils dos2unix gl pkgconfig \
USE_GL= gl glu
USE_QT= core gui widgets buildtools_build linguisttools_build
-DOS2UNIX_FILES= src/c64_class.cpp \
- src/widget_file_browse.h
+DOS2UNIX_FILES= src/widget_file_browse.h
USE_SDL= sdl2 image2
USE_GITHUB= yes
diff --git a/emulators/emu64/distinfo b/emulators/emu64/distinfo
index 59f5292fe6cb..a81c699f485f 100644
--- a/emulators/emu64/distinfo
+++ b/emulators/emu64/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1583170010
-SHA256 (ThKattanek-emu64-5.0.18_GH0.tar.gz) = 3457f6cb37b99c597e0698ba4b5c2466bf6a0993cc9b8f343ab950a07a853717
-SIZE (ThKattanek-emu64-5.0.18_GH0.tar.gz) = 1630546
+TIMESTAMP = 1625814662
+SHA256 (ThKattanek-emu64-5.0.19_GH0.tar.gz) = 225d66d17f5e803137b373df3905063abcf7f77a5c914f7307913b18f6d51315
+SIZE (ThKattanek-emu64-5.0.19_GH0.tar.gz) = 1641017
diff --git a/emulators/emu64/files/patch-src_c64__class.cpp b/emulators/emu64/files/patch-src_c64__class.cpp
deleted file mode 100644
index 5b144477789a..000000000000
--- a/emulators/emu64/files/patch-src_c64__class.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/c64_class.cpp.orig 2020-04-11 10:05:13 UTC
-+++ src/c64_class.cpp
-@@ -27,9 +27,9 @@ int SDLThreadWarp(void *userdat);
- #define C64Takt 985248 // 50,124542Hz (Original C64 PAL)
-
- #ifdef _WIN32
-- #define AudioPufferSize (882) // 882 bei 44.100 Khz
-+ #define AudioPufferSize (1024) // 882 bei 44.100 Khz
- #else
-- #define AudioPufferSize (882) // 882 bei 44.100 Khz
-+ #define AudioPufferSize (1024) // 882 bei 44.100 Khz
- #endif
-
- #define RecPollingWaitStart 20
-@@ -1757,7 +1757,7 @@ void C64Class::SetFullscreenAspectRatio(bool enable)
- void C64Class::AnalyzeSDLEvent(SDL_Event *event)
- {
- static bool joy_center_flag = true;
-- static char joy_axis_tbl[5] = {1,1,0,0,-1};
-+ static signed char joy_axis_tbl[5] = {1,1,0,0,-1};
-
- SDL_Keymod keymod;
-
diff --git a/emulators/emu64/files/patch-src_src.pro b/emulators/emu64/files/patch-src_src.pro
index 586df78af226..f5fe38f8ff5b 100644
--- a/emulators/emu64/files/patch-src_src.pro
+++ b/emulators/emu64/files/patch-src_src.pro
@@ -1,11 +1,11 @@
---- src/src.pro.orig 2020-11-08 17:21:01 UTC
+--- src/src.pro.orig 2021-07-08 16:55:15 UTC
+++ src/src.pro
-@@ -73,7 +73,7 @@ DEFINES += ZIP_SUPPORT=true
- win32 {
- PKGCONFIG += quazip
- } else {
-- LIBS += -lquazip5
-+ PKGCONFIG += quazip1-qt5
- }
+@@ -84,7 +84,7 @@ equals(QT_MAJOR_VERSION, 5) {
+ win32 {
+ PKGCONFIG += quazip
+ } else {
+- LIBS += -lquazip5
++ PKGCONFIG += quazip1-qt5
+ }
- # Quelltexte
+ message("QT5 is active")
diff --git a/emulators/emu64/files/patch-src_widget__file__browse.h b/emulators/emu64/files/patch-src_widget__file__browse.h
index 1c6e9eb8f825..1dc2fcfcc95b 100644
--- a/emulators/emu64/files/patch-src_widget__file__browse.h
+++ b/emulators/emu64/files/patch-src_widget__file__browse.h
@@ -1,4 +1,4 @@
---- src/widget_file_browse.h.orig 2020-11-08 17:22:47 UTC
+--- src/widget_file_browse.h.orig 2021-07-09 07:30:04 UTC
+++ src/widget_file_browse.h
@@ -26,8 +26,8 @@
#include "quazip/quazip.h"
diff --git a/emulators/emu64/pkg-message b/emulators/emu64/pkg-message
new file mode 100644
index 000000000000..60cb4ab968c8
--- /dev/null
+++ b/emulators/emu64/pkg-message
@@ -0,0 +1,13 @@
+[
+{
+ type: upgrade
+ maximum_version: "5.0.19"
+ message: <<EOM
+Due to a breaking change, emu64 might crash when you open the user color
+palette window. This should happen only once.
+
+To prevent it from happening at all, you could also remove your
+~/.config/emu64/emu64.ini file containing your user's configuration.
+EOM
+}
+]
diff --git a/emulators/emu64/pkg-plist b/emulators/emu64/pkg-plist
index 069acfd731b5..ec4f0f764616 100644
--- a/emulators/emu64/pkg-plist
+++ b/emulators/emu64/pkg-plist
@@ -1,6 +1,7 @@
bin/emu64
share/applications/emu64.desktop
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/hotkeys.txt
%%PORTDOCS%%%%DOCSDIR%%/kommandozeilenparameter.txt
%%PORTDOCS%%%%DOCSDIR%%/änderungen.txt
%%DATADIR%%/floppy_sounds/anschlag.raw