aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2021-03-26 05:24:22 +0000
committerSanthosh Raju <fox@FreeBSD.org>2021-03-26 05:24:22 +0000
commita74251aedf6000024e22b6649bcc93d43d231133 (patch)
tree4afb470a54e921f3f36757941de7195f3fef68fe /emulators
parent62342bf5ee501ab1ac51389d0d5fa133c92b8a1f (diff)
downloadports-a74251aedf6000024e22b6649bcc93d43d231133.tar.gz
ports-a74251aedf6000024e22b6649bcc93d43d231133.zip
emulators/cannonball: Updates to 0.32
Changes since 0.31: Controller Improvements & Rumble Support This release focuses on Controller Support & Improvements. Please replace your old config.xml file when upgrading to this release. * [Controllers] Basic rumble support can now be enabled from the CONTROLS menu. The strength can be adjusted. The code that controls the rumble is identical to that of the upright arcade machine motor shaker. The option will only show in the menu if your controller is supported. * [Controllers] Auto-detection and assignment of controller buttons and axis should be much improved. I will update the manual to call out the default controls in due course. (Right trigger = accelerate, Left trigger = brake, Start = Start, Back = Menu, A = Gear Change, X = Change View, Y = Coin). These can be redefined as desired. * [Controllers] D-Pad can be used in menus. * [Menus] Gamepad/Joystick settings has its own menu. * [Menus] Ensure that 'A' button on controllers can be used to select items. Analog accelerate is now only used when run via original arcade cabs as it's not optimal. * [Rom Loader] Sped up CRC32 based loading by using a Hashmap. It was reportedly slow when used over a network. * [Rom Loader] It is possible to switch back to the old filename loading system via a setting in config.xml * [Config] It is now possible to change and configure the location of the 'res' directory.
Notes
Notes: svn path=/head/; revision=569241
Diffstat (limited to 'emulators')
-rw-r--r--emulators/cannonball/Makefile3
-rw-r--r--emulators/cannonball/distinfo6
-rw-r--r--emulators/cannonball/files/patch-cmake_linux.cmake20
3 files changed, 4 insertions, 25 deletions
diff --git a/emulators/cannonball/Makefile b/emulators/cannonball/Makefile
index 69ff3329de3f..29a0f023ba2c 100644
--- a/emulators/cannonball/Makefile
+++ b/emulators/cannonball/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= cannonball
-DISTVERSIONPREFIX= v
-DISTVERSION= 0.31
+DISTVERSION= 0.32
CATEGORIES= emulators games
MAINTAINER= fox@FreeBSD.org
diff --git a/emulators/cannonball/distinfo b/emulators/cannonball/distinfo
index 7dfbcadd0aad..d40e78998ca0 100644
--- a/emulators/cannonball/distinfo
+++ b/emulators/cannonball/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1615884344
-SHA256 (djyt-cannonball-v0.31_GH0.tar.gz) = 8743fcfabeeaf8820ab47196e1b29b1702c1f71b784b6336f79d5f8725bc561b
-SIZE (djyt-cannonball-v0.31_GH0.tar.gz) = 269125
+TIMESTAMP = 1616733810
+SHA256 (djyt-cannonball-0.32_GH0.tar.gz) = 50a4316159f5651a18edc7aa1a8961f944ec4bf8170e8afd6cb231cbc182a7c2
+SIZE (djyt-cannonball-0.32_GH0.tar.gz) = 292602
diff --git a/emulators/cannonball/files/patch-cmake_linux.cmake b/emulators/cannonball/files/patch-cmake_linux.cmake
deleted file mode 100644
index c2bc805f8646..000000000000
--- a/emulators/cannonball/files/patch-cmake_linux.cmake
+++ /dev/null
@@ -1,20 +0,0 @@
-Adds support for building in BSD.
-
-Will be removed once upstream makes a release with
-https://github.com/djyt/cannonball/commit/a9c71cbf229b9f808ae172a09d12a773fc869209
-
---- cmake/linux.cmake.orig 2021-03-16 11:22:26 UTC
-+++ cmake/linux.cmake
-@@ -0,0 +1,12 @@
-+# -----------------------------------------------------------------------------
-+# CannonBall BSD Setup
-+# -----------------------------------------------------------------------------
-+
-+# Use OpenGL for rendering.
-+find_package(OpenGL REQUIRED)
-+
-+# Platform Specific Libraries
-+set(platform_link_libs
-+ ${OPENGL_LIBRARIES}
-+)
-+