aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-06-09 16:19:05 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-06-09 16:19:05 +0000
commitb4d7f46da987d69753d7e3d9103ccdc3d2e4f2a3 (patch)
tree931305c9e0306e3b965f52db014726b96d2ffc17 /emulators
parent545a2d9ad571615bdd9bf914836f61fc7ecde5b7 (diff)
downloadports-b4d7f46da987d69753d7e3d9103ccdc3d2e4f2a3.tar.gz
ports-b4d7f46da987d69753d7e3d9103ccdc3d2e4f2a3.zip
- Update net/usbredir to 0.4.3 .
- Update emulators/qemu-devel to 1.1.0 - announce posting is here: http://lists.nongnu.org/archive/html/qemu-devel/2012-06/msg00072.html
Notes
Notes: svn path=/head/; revision=298875
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-devel/Makefile14
-rw-r--r--emulators/qemu-devel/distinfo4
-rw-r--r--emulators/qemu-devel/files/patch-Makefile31
-rw-r--r--emulators/qemu-devel/files/patch-bg6
-rw-r--r--emulators/qemu-devel/files/patch-configure8
-rw-r--r--emulators/qemu-devel/files/patch-qemu-timer.h13
-rw-r--r--emulators/qemu-devel/files/patch-z-bandaid-usb-current14
-rw-r--r--emulators/qemu-devel/files/pcap-patch10
-rw-r--r--emulators/qemu-devel/pkg-message11
-rw-r--r--emulators/qemu-devel/pkg-plist3
10 files changed, 46 insertions, 68 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index c3d2d16f93aa..a38699a885e0 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 1.0.1
-PORTREVISION= 3
+PORTVERSION= 1.1.0
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/:release \
LOCAL/nox:snapshot
@@ -19,6 +18,7 @@ MAINTAINER= nox@FreeBSD.org
COMMENT= QEMU CPU Emulator - development version
HAS_CONFIGURE= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
USE_PYTHON_BUILD= yes
@@ -32,7 +32,7 @@ CONFLICTS_INSTALL= qemu-[0-9]*
MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= SAMBA SDL OPENGL GNUTLS SASL JPEG PNG CURL CDROM_DMA PCAP \
- SEABIOS_GIT USBREDIR GNS3 ADD_AUDIO ALL_TARGETS
+ USBREDIR GNS3 ADD_AUDIO ALL_TARGETS
SAMBA_DESC= "samba dependency (for -smb)"
GNUTLS_DESC= "gnutls dependency (vnc encryption)"
SASL_DESC= "cyrus-sasl dependency (vnc encryption)"
@@ -46,8 +46,7 @@ USBREDIR_DESC= "usb device network redirection (experimental!)"
GNS3_DESC= "gns3 patches (udp, promiscuous multicast)"
ADD_AUDIO_DESC= "Emulate more audio hardware (experimental!)"
ALL_TARGETS_DESC= "Also build bsd-user targets (for testing)"
-OPTIONS_DEFAULT=SDL OPENGL GNUTLS SASL JPEG PNG CURL CDROM_DMA PCAP \
- SEABIOS_GIT
+OPTIONS_DEFAULT=SDL OPENGL GNUTLS SASL JPEG PNG CURL CDROM_DMA PCAP
.include <bsd.port.options.mk>
@@ -78,7 +77,7 @@ WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC} --enable-docs \
--disable-linux-user --disable-linux-aio \
- --disable-darwin-user --disable-kvm --disable-xen \
+ --disable-kvm --disable-xen \
--smbd=${LOCALBASE}/sbin/smbd \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"${PREFIX}\\\"
@@ -127,7 +126,8 @@ USE_GL= yes
.if empty(PORT_OPTIONS:MUSBREDIR)
CONFIGURE_ARGS+= --disable-usb-redir
.else
-LIB_DEPENDS+= usbredirparser:${PORTSDIR}/net/usbredir
+BUILD_DEPENDS+= usbredir>=0.4.3:${PORTSDIR}/net/usbredir
+RUN_DEPENDS+= usbredir>=0.4.3:${PORTSDIR}/net/usbredir
.endif
.if ${PORT_OPTIONS:MPCAP}
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index a4767fdf83a9..0898fbbb0e14 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qemu/1.0.1/qemu-1.0.1.tar.gz) = 198902e10782517f607c9ed9e629b5e7708ea39eb373ed3ec3f1c8a169d98378
-SIZE (qemu/1.0.1/qemu-1.0.1.tar.gz) = 10853005
+SHA256 (qemu/1.1.0/qemu-1.1.0.tar.bz2) = 927f498eff8dce2334de9338cae9e3a7c63bd472c85451235c45de5029140fc0
+SIZE (qemu/1.1.0/qemu-1.1.0.tar.bz2) = 9629317
diff --git a/emulators/qemu-devel/files/patch-Makefile b/emulators/qemu-devel/files/patch-Makefile
index 28c7fce9f05d..0ea9a8df7622 100644
--- a/emulators/qemu-devel/files/patch-Makefile
+++ b/emulators/qemu-devel/files/patch-Makefile
@@ -1,6 +1,6 @@
Index: qemu/Makefile
-@@ -29,7 +29,11 @@ $(call set-vpath, $(SRC_PATH):$(SRC_PATH
- LIBS+=-lz $(LIBS_TOOLS)
+@@ -40,7 +40,11 @@ LIBS+=-lz $(LIBS_TOOLS)
+ HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
@@ -8,29 +8,30 @@ Index: qemu/Makefile
+else
DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1 qemu-nbd.8 QMP/qmp-commands.txt
+endif
- else
- DOCS=
+ ifdef CONFIG_VIRTFS
+ DOCS+=fsdev/virtfs-proxy-helper.1
endif
-@@ -169,8 +173,10 @@ BLOBS=
+@@ -269,8 +273,10 @@ BLOBS=
endif
install-doc: $(DOCS)
+ifndef NOPORTDOCS
- $(INSTALL_DIR) "$(DESTDIR)$(docdir)"
- $(INSTALL_DATA) qemu-doc.html qemu-tech.html "$(DESTDIR)$(docdir)"
+ $(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) qemu-doc.html qemu-tech.html "$(DESTDIR)$(qemu_docdir)"
+endif
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
$(INSTALL_DATA) qemu.1 qemu-img.1 "$(DESTDIR)$(mandir)/man1"
-@@ -180,7 +186,10 @@ endif
+@@ -289,8 +295,11 @@ install-confdir:
+ $(INSTALL_DIR) "$(DESTDIR)$(qemu_confdir)"
- install-sysconfig:
- $(INSTALL_DIR) "$(DESTDIR)$(sysconfdir)/qemu"
-- $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(sysconfdir)/qemu"
-+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(sysconfdir)/qemu/target-x86_64.conf.sample"
-+ if [ ! -f "$(sysconfdir)/qemu/target-x86_64.conf" ]; then \
-+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(sysconfdir)/qemu"; \
+ install-sysconfig: install-datadir install-confdir
+- $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(qemu_confdir)"
++ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(DESTDIR)$(qemu_confdir)/target-x86_64.conf.sample"
++ if [ ! -f "$(qemu_confdir)/target-x86_64.conf" ]; then \
++ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/target-x86_64.conf "$(qemu_confdir)"; \
+ fi
+ $(INSTALL_DATA) $(SRC_PATH)/sysconfigs/target/cpus-x86_64.conf "$(DESTDIR)$(qemu_datadir)"
- install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig
+ install: all $(if $(BUILD_DOCS),install-doc) install-sysconfig install-datadir
$(INSTALL_DIR) "$(DESTDIR)$(bindir)"
diff --git a/emulators/qemu-devel/files/patch-bg b/emulators/qemu-devel/files/patch-bg
index d557dd5544a6..b96153595ce5 100644
--- a/emulators/qemu-devel/files/patch-bg
+++ b/emulators/qemu-devel/files/patch-bg
@@ -1,5 +1,5 @@
Index: qemu/net.h
-@@ -173,8 +173,8 @@ void net_host_device_remove(Monitor *mon
+@@ -174,8 +174,8 @@ void net_host_device_remove(Monitor *mon
int do_netdev_add(Monitor *mon, const QDict *qdict, QObject **ret_data);
int do_netdev_del(Monitor *mon, const QDict *qdict, QObject **ret_data);
@@ -7,8 +7,8 @@ Index: qemu/net.h
-#define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
+#define DEFAULT_NETWORK_SCRIPT PREFIX "/etc/qemu-ifup"
+#define DEFAULT_NETWORK_DOWN_SCRIPT PREFIX "/etc/qemu-ifdown"
-
- void qdev_set_nic_properties(DeviceState *dev, NICInfo *nd);
+ #define DEFAULT_BRIDGE_HELPER CONFIG_QEMU_HELPERDIR "/qemu-bridge-helper"
+ #define DEFAULT_BRIDGE_INTERFACE "br0"
Index: qemu/net/tap.h
@@ -29,8 +29,8 @@
diff --git a/emulators/qemu-devel/files/patch-configure b/emulators/qemu-devel/files/patch-configure
index b10a590664f3..48bc5cf97466 100644
--- a/emulators/qemu-devel/files/patch-configure
+++ b/emulators/qemu-devel/files/patch-configure
@@ -1,15 +1,15 @@
--- a/configure
+++ a/configure
-@@ -285,7 +285,7 @@ bigendian="no"
+@@ -154,7 +154,7 @@ bigendian="no"
mingw32="no"
EXESUF=""
prefix="/usr/local"
-mandir="\${prefix}/share/man"
+mandir="\${prefix}/man"
- datadir="\${prefix}/share/qemu"
- docdir="\${prefix}/share/doc/qemu"
+ datadir="\${prefix}/share"
+ qemu_docdir="\${prefix}/share/doc/qemu"
bindir="\${prefix}/bin"
-@@ -1964,15 +1964,18 @@ if compile_prog "" "" ; then
+@@ -2511,15 +2511,18 @@ if compile_prog "" "" ; then
fi
# Check if tools are available to build documentation.
diff --git a/emulators/qemu-devel/files/patch-qemu-timer.h b/emulators/qemu-devel/files/patch-qemu-timer.h
deleted file mode 100644
index 998a7aca5d50..000000000000
--- a/emulators/qemu-devel/files/patch-qemu-timer.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/qemu-timer.h
-+++ b/qemu-timer.h
-@@ -4,6 +4,10 @@
- #include "qemu-common.h"
- #include <time.h>
- #include <sys/time.h>
-+#ifdef __FreeBSD__ /* for __FreeBSD_version */
-+#include <sys/param.h>
-+#endif
-+#include <sys/time.h>
-
- #ifdef _WIN32
- #include <windows.h>
diff --git a/emulators/qemu-devel/files/patch-z-bandaid-usb-current b/emulators/qemu-devel/files/patch-z-bandaid-usb-current
deleted file mode 100644
index ad66da21f543..000000000000
--- a/emulators/qemu-devel/files/patch-z-bandaid-usb-current
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: qemu/usb-bsd.c
-@@ -35,7 +35,12 @@
-
- #include <sys/ioctl.h>
- #ifndef __DragonFly__
-+#include <sys/param.h>
-+#if __FreeBSD_version >= 800064
-+#include <legacy/dev/usb/usb.h>
-+#else
- #include <dev/usb/usb.h>
-+#endif
- #else
- #include <bus/usb/usb.h>
- #endif
diff --git a/emulators/qemu-devel/files/pcap-patch b/emulators/qemu-devel/files/pcap-patch
index 59a3fd9e4871..ed698e12dbc4 100644
--- a/emulators/qemu-devel/files/pcap-patch
+++ b/emulators/qemu-devel/files/pcap-patch
@@ -1,16 +1,16 @@
--- configure.orig 2010-01-29 14:36:00.000000000 -0500
+++ configure 2010-01-29 14:36:00.000000000 -0500
-@@ -185,6 +185,9 @@ opengl=""
- zlib="yes"
+@@ -194,6 +194,9 @@ zlib="yes"
guest_agent="yes"
libiscsi=""
+ coroutine=""
+pcap="no"
+pcap_create="no"
+bpf="no"
# parse CC options first
for opt do
-@@ -638,6 +641,8 @@ for opt do
+@@ -670,6 +673,8 @@ for opt do
;;
--enable-vnc-thread) vnc_thread="yes"
;;
@@ -19,7 +19,7 @@
--disable-slirp) slirp="no"
;;
--disable-uuid) uuid="no"
-@@ -1529,6 +1534,49 @@ EOF
+@@ -1619,6 +1624,49 @@ EOF
fi
##########################################
@@ -69,7 +69,7 @@
# VNC TLS detection
if test "$vnc" = "yes" -a "$vnc_tls" != "no" ; then
cat > $TMPC <<EOF
-@@ -2950,6 +2998,15 @@ fi
+@@ -3117,6 +3165,15 @@ fi
if test "$profiler" = "yes" ; then
echo "CONFIG_PROFILER=y" >> $config_host_mak
fi
diff --git a/emulators/qemu-devel/pkg-message b/emulators/qemu-devel/pkg-message
index d35860827b31..bdb3557f6bc7 100644
--- a/emulators/qemu-devel/pkg-message
+++ b/emulators/qemu-devel/pkg-message
@@ -79,21 +79,22 @@ FreeBSD host notes
sudo usbredirserver 045e:0772
2) Start qemu with usb2 support + a chardev talking to usbredirserver +
a usb-redir device using this chardev:
- qemu ... \
+ qemu -usb \
-readconfig docs/ich9-ehci-uhci.cfg \
-chardev socket,id=usbredirchardev,host=localhost,port=4000 \
- -device usb-redir,chardev=usbredirchardev,id=usbredirdev
+ -device usb-redir,chardev=usbredirchardev,id=usbredirdev ...
[you would replace docs/ich9-ehci-uhci.cfg with e.g.
/usr/local/share/doc/qemu/docs/ich9-ehci-uhci.cfg, but turns out
- ehci seems broken for me here with FreeBSD guests at least, I get:
+ ehci was broken for me here with FreeBSD guests and the previous
+ qemu version at least, I got:
FETCHENTRY: entry at 22C5484 is of type 2 which is not supported yet
processing error - resetting ehci HC
Assertion failed: (0), function ehci_advance_state, file /data/ports/emulators/qemu-devel/work/qemu-0.15.0/hw/usb-ehci.c, line 2045.
- Starting the same without ehci (-readconfig) works (may need
- -usb), tho usbredirserver crashes when qemu exits.]
+ The new qemu version works better, tho usbredirserver still crashes
+ when qemu exits.]
- Still usb: since the hub is no longer attached to the uchi controller and
the wakeup mechanism, resume interrupt is not implemented yet linux guests
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 87b492f11b55..f00f27564774 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -66,6 +66,9 @@ etc/qemu/target-x86_64.conf.sample
%%DATADIR%%/sgabios.bin
%%DATADIR%%/petalogix-s3adsp1800.dtb
%%DATADIR%%/bamboo.dtb
+%%DATADIR%%/cpus-x86_64.conf
+%%DATADIR%%/kvmvapic.bin
+%%DATADIR%%/qemu-icon.bmp
%%DATADIR%%/keymaps/ar
%%DATADIR%%/keymaps/common
%%DATADIR%%/keymaps/da