aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-25 15:43:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-25 15:43:14 +0000
commitb66cb02f6528b53dc52b664ec697174d846b6514 (patch)
treee4046c77d96e2d4b42e8c95e8aa4f234e963cceb /emulators
parent889edbf062bfc713433856f55ce9f4ae3644883a (diff)
downloadports-b66cb02f6528b53dc52b664ec697174d846b6514.tar.gz
ports-b66cb02f6528b53dc52b664ec697174d846b6514.zip
- Add WITH_QT knob to enable Qt GUI
PR: ports/67174 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=109988
Diffstat (limited to 'emulators')
-rw-r--r--emulators/pearpc/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/emulators/pearpc/Makefile b/emulators/pearpc/Makefile
index 053ae8b1c3c2..26aae716d7dc 100644
--- a/emulators/pearpc/Makefile
+++ b/emulators/pearpc/Makefile
@@ -21,14 +21,21 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}/lib"
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math
.else
CONFIGURE_ARGS+= --disable-fpo
.endif
+.if defined(WITH_QT)
+CONFIGURE_ARGS+= --enable-gui=qt
+USE_QT_VER= 3
+.else
+CONFIGURE_ARGS+= --enable-gui=nogui
+.endif
+
+.include <bsd.port.pre.mk>
+
# jitc_x86 is avaible only on x86
.if ${ARCH} == "i386"
.if !defined(WITH_JITC)