aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2021-03-17 16:44:10 +0000
committerRenato Botelho <garga@FreeBSD.org>2021-03-17 16:44:10 +0000
commitba6f0e996f97f48455e23e2ac24d1c0f328479fc (patch)
tree71e0753e46fce631cfc948a137b37d890c4ee31d /emulators
parent29acc5bcc6226b81cbab366311b7f929ef82e755 (diff)
downloadports-ba6f0e996f97f48455e23e2ac24d1c0f328479fc.tar.gz
ports-ba6f0e996f97f48455e23e2ac24d1c0f328479fc.zip
emulators/open-vm-tools: Flavorize and other tweaks
- Remove emulators/open-vm-tools-nox11 and create a nox11 flavor - Regenerate patches with make makepatch - Sort Makefile and make portclippy and portlint happy - Remove unused variables - Simplify Makefile Sponsored by: Rubicon Communications, LLC ("Netgate")
Notes
Notes: svn path=/head/; revision=568677
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/open-vm-tools-nox11/Makefile8
-rw-r--r--emulators/open-vm-tools/Makefile116
-rw-r--r--emulators/open-vm-tools/files/patch-modules_freebsd_vmmemctl_Makefile4
4 files changed, 57 insertions, 72 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index c04b2617accb..4108cfa2b5ff 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -99,7 +99,6 @@
SUBDIR += o2em
SUBDIR += ods2reader
SUBDIR += open-vm-tools
- SUBDIR += open-vm-tools-nox11
SUBDIR += openmsx
SUBDIR += p5-Acme-6502
SUBDIR += parallels-tools
diff --git a/emulators/open-vm-tools-nox11/Makefile b/emulators/open-vm-tools-nox11/Makefile
deleted file mode 100644
index 3a486c8d7aba..000000000000
--- a/emulators/open-vm-tools-nox11/Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
-# Created by: Martin Blapp <mb@FreeBSD.org>
-# $FreeBSD$
-
-MASTERDIR= ${.CURDIR}/../open-vm-tools
-PKGNAMESUFFIX= -nox11
-OPTIONS_EXCLUDE= X11 LIBNOTIFY
-
-.include "${MASTERDIR}/Makefile"
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 58130239f4be..c0efbd08edcf 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -1,81 +1,73 @@
# Created by: mbr@FreeBSD.org
# $FreeBSD$
-PORTNAME= open-vm-tools
-PORTVERSION= ${RELEASE_VER}
+PORTNAME= open-vm-tools
+PORTVERSION= 11.2.0
DISTVERSIONPREFIX= stable-
-PORTREVISION= 2
-PORTEPOCH= 2
-CATEGORIES= emulators
+PORTREVISION= 3
+PORTEPOCH= 2
+CATEGORIES= emulators
-MAINTAINER= garga@FreeBSD.org
-COMMENT?= Open VMware tools for FreeBSD VMware guests
+MAINTAINER= garga@FreeBSD.org
+COMMENT= Open VMware tools for FreeBSD VMware guests ${${FLAVOR}_COMMENT}
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
-ONLY_FOR_ARCHS= amd64 i386
+ONLY_FOR_ARCHS= amd64 i386
-LIB_DEPENDS= libmspack.so:archivers/libmspack \
- libdnet.so:net/libdnet
+LIB_DEPENDS= libdnet.so:net/libdnet \
+ libmspack.so:archivers/libmspack
-RELEASE_VER= 11.2.0
-BUILD_VER= 16938113
+FLAVORS= default nox11
+default_CONFLICTS_INSTALL= open-vm-tools-nox11
+nox11_PKGNAMESUFFIX= -nox11
+nox11_CONFLICTS_INSTALL= open-vm-tools
+nox11_COMMENT= (without X11)
-OPTIONS_DEFINE= DOCS LIBNOTIFY OPENSSL X11
-OPTIONS_DEFAULT= DOCS LIBNOTIFY OPENSSL X11
+USES= autoreconf fuse gettext-runtime gnome kmod libtool localbase \
+ pathfix pkgconfig
-OPTIONS_SUB=
-
-DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
-DOCS_CONFIGURE_ENABLE= docs
-
-LIBNOTIFY_DESC= Desktop notification support
-
-X11_CONFIGURE_WITH= x gtk2 gtkmm
-X11_USES= gnome xorg
-X11_USE= xorg=ice,sm,x11,xext,xi,xinerama,xorgproto,xrandr,xrender,xtst \
- gnome=gdkpixbuf2,gtk20,gtkmm24
-X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
-LIBNOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
-OPENSSL_CONFIGURE_WITH= ssl
-
-WRKSRC_SUBDIR= open-vm-tools
+USE_GITHUB= yes
+GH_ACCOUNT= vmware
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+USE_RC_SUBR= vmware-guestd vmware-kmod
-GNU_CONFIGURE= yes
-USES= autoreconf fuse gettext-runtime kmod libtool localbase pathfix pkgconfig gnome
-USE_GNOME= glib20
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--disable-vgauth \
+ --sysconfdir=${PREFIX}/etc \
+ --without-icu
+CONFIGURE_ENV+= SYSDIR=${SRC_BASE}/sys
-USE_GITHUB= yes
-GH_ACCOUNT= vmware
+INSTALL_TARGET= install-strip
-USE_LDCONFIG= yes
-CPPFLAGS+= -Wno-deprecated-declarations
+CPPFLAGS+= -Wno-deprecated-declarations
+SSP_UNSAFE= kernel module does not support ssp
-SSP_UNSAFE= kernel module does not support ssp
+CONFLICTS= vmware-guestd[0-9]* vmware-tools[0-9]*
-CONFIGURE_ARGS+= --without-icu \
- --disable-vgauth \
- --sysconfdir=${PREFIX}/etc
+WRKSRC_SUBDIR= open-vm-tools
-CONFLICTS+= vmware-guestd[0-9]* vmware-tools[0-9]*
-
-USE_RC_SUBR= vmware-guestd vmware-kmod
-
-INSTALL_TARGET= install-strip
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MX11}
-CONFLICTS+= open-vm-tools-nox11-[0-9]*
-.else
-CONFLICTS+= open-vm-tools-[0-9]*
+OPTIONS_DEFINE= DOCS LIBNOTIFY OPENSSL X11
+OPTIONS_DEFAULT=DOCS LIBNOTIFY OPENSSL X11
+.if ${FLAVOR:U} == nox11
+OPTIONS_EXCLUDE:= LIBNOTIFY X11
.endif
+OPTIONS_SUB=
-CONFIGURE_ENV+= SYSDIR=${SRC_BASE}/sys
+LIBNOTIFY_DESC= Desktop notification support
-.include <bsd.port.pre.mk>
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+DOCS_CONFIGURE_ENABLE= docs
+LIBNOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
+OPENSSL_CONFIGURE_WITH= ssl
+X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+X11_USES= xorg
+X11_USE= GNOME=gdkpixbuf2,gtk20,gtkmm24 \
+ XORG=ice,sm,x11,xext,xi,xinerama,xorgproto,xrandr,xrender,xtst
+X11_CONFIGURE_WITH= gtk2 gtkmm x
post-patch:
@${REINPLACE_CMD} -e "s@%%PREFIX%%@${PREFIX}@"\
@@ -87,11 +79,13 @@ post-build:
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers
${MKDIR} ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/input
- ${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmblock.ko ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmblock.ko
- ${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmmemctl.ko ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmmemctl.ko
+ ${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmblock.ko \
+ ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmblock.ko
+ ${INSTALL_DATA} ${WRKSRC}/modules/freebsd/vmmemctl.ko \
+ ${STAGEDIR}${PREFIX}/lib/vmware-tools/modules/drivers/vmmemctl.ko
${MKDIR} ${STAGEDIR}${PREFIX}/share/open-vm-tools/scripts/vmware/
${MKDIR} ${STAGEDIR}${PREFIX}/share/open-vm-tools/scripts/
${MKDIR} ${STAGEDIR}${PREFIX}/share/open-vm-tools/tests/
${MKDIR} ${STAGEDIR}${PREFIX}/etc/rc.conf.d
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/open-vm-tools/files/patch-modules_freebsd_vmmemctl_Makefile b/emulators/open-vm-tools/files/patch-modules_freebsd_vmmemctl_Makefile
index 526db30a5c97..632fff16326b 100644
--- a/emulators/open-vm-tools/files/patch-modules_freebsd_vmmemctl_Makefile
+++ b/emulators/open-vm-tools/files/patch-modules_freebsd_vmmemctl_Makefile
@@ -1,6 +1,6 @@
---- modules/freebsd/vmmemctl/Makefile.orig
+--- modules/freebsd/vmmemctl/Makefile.orig 2020-10-16 23:15:58 UTC
+++ modules/freebsd/vmmemctl/Makefile
-@@ -33,8 +33,6 @@
+@@ -33,8 +33,6 @@ SRCS += backdoorGcc32.c
.endif
KMOD = vmmemctl
PROG = ../$(KMOD).ko