aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-05-14 12:10:44 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-05-14 12:10:44 +0000
commitc4843ba5be0d639887536ce2936467a12597f46c (patch)
tree06ce912a3050b7b0b5af66838c10e27445e0a3d1 /emulators
parentc5d69a5700401ac5a9592388ee56658bc10cf771 (diff)
downloadports-c4843ba5be0d639887536ce2936467a12597f46c.tar.gz
ports-c4843ba5be0d639887536ce2936467a12597f46c.zip
Maintainer update of emulators/linux-geepee32
update of emulators/linux-geepee32 - (minor things) PR: ports/64613 Submitted by: No Name <arundel@gmx.net>
Notes
Notes: svn path=/head/; revision=109111
Diffstat (limited to 'emulators')
-rw-r--r--emulators/linux-geepee32/Makefile15
-rw-r--r--emulators/linux-geepee32/pkg-descr2
-rw-r--r--emulators/linux-geepee32/scripts/geepee32.sh5
-rw-r--r--emulators/linux-geepee32/scripts/wrapper.sh6
4 files changed, 18 insertions, 10 deletions
diff --git a/emulators/linux-geepee32/Makefile b/emulators/linux-geepee32/Makefile
index 6dad67264c89..f3c7f2842d25 100644
--- a/emulators/linux-geepee32/Makefile
+++ b/emulators/linux-geepee32/Makefile
@@ -6,14 +6,14 @@
PORTNAME= geepee32
PORTVERSION= 30
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators linux
MASTER_SITES= http://users.skynet.be/firefly/gp32/project/geepee32/
PKGNAMEPREFIX= linux-
DISTNAME= ${PORTNAME}_linux_sdl_${PORTVERSION}
MAINTAINER= arundel@gmx.net
-COMMENT= The only GP32 emulator for x86 archs
+COMMENT= The only GP32 emulator for i386
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
@@ -23,19 +23,26 @@ USE_XLIB= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
NO_BUILD= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS=
+STRIP=
TARGET_DIR= ${PREFIX}/${PORTNAME}
+post-patch:
+ ${REINPLACE_CMD}-e 's|%%GEEPEE32DIR%%|${PREFIX}/${PORTNAME}|' ${SCRIPTDIR}/wrapper.sh > \
+ ${WRKDIR}/wrapper.sh
+
do-install:
${INSTALL} -d -m 777 ${TARGET_DIR}
${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${TARGET_DIR}
- ${INSTALL_SCRIPT} ${SCRIPTDIR}/${PORTNAME}.sh ${TARGET_DIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${TARGET_DIR}/${PORTNAME}.sh
post-install:
@${TOUCH} ${TARGET_DIR}/iic.bin
@${LN} -s ${TARGET_DIR}/${PORTNAME}.sh ${PREFIX}/bin/${PORTNAME}
@${ECHO_MSG} ""
- @${ECHO_MSG} "Please don't mail us with requests for ROM dump."
+ @${ECHO_MSG} "Please don't mail us with requests for ROM dumps."
@${ECHO_MSG} ""
.include <bsd.port.mk>
diff --git a/emulators/linux-geepee32/pkg-descr b/emulators/linux-geepee32/pkg-descr
index 98253c46202c..e0f0d9f1583e 100644
--- a/emulators/linux-geepee32/pkg-descr
+++ b/emulators/linux-geepee32/pkg-descr
@@ -6,4 +6,4 @@ Firmware:
The emulator needs a GP32 firmware dump in order to work. I do not
have permission from Gamepark Inc. to distrubute this file :(
-WWW: http://users.skynet.be/firefly/gp32/geepee32/
+WWW: http://users.skynet.be/firefly/gp32/project/geepee32/
diff --git a/emulators/linux-geepee32/scripts/geepee32.sh b/emulators/linux-geepee32/scripts/geepee32.sh
index ae5bbf6caa4f..e69de29bb2d1 100644
--- a/emulators/linux-geepee32/scripts/geepee32.sh
+++ b/emulators/linux-geepee32/scripts/geepee32.sh
@@ -1,5 +0,0 @@
-#!/bin/sh
-# Needed to make symlinks/shortcuts work.
-# Wrap geepee32 binary
-./geepee32 $*
-exit $?
diff --git a/emulators/linux-geepee32/scripts/wrapper.sh b/emulators/linux-geepee32/scripts/wrapper.sh
new file mode 100644
index 000000000000..967a1cbd147c
--- /dev/null
+++ b/emulators/linux-geepee32/scripts/wrapper.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+# Needed to make symlinks/shortcuts work.
+# Wrap geepee32 binary
+cd %%GEEPEE32DIR%%
+./geepee32 $*
+exit $?