aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-22 09:48:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-05-22 09:48:12 +0000
commitdd7f46bbe0cba846c97856c20683bcc8608b7bb8 (patch)
treee9228e8dac5cb9a894f2bfa537d8a4bf65e7eb95 /emulators
parente506b9247c626f4f9099247e228ca653b6499209 (diff)
downloadports-dd7f46bbe0cba846c97856c20683bcc8608b7bb8.tar.gz
ports-dd7f46bbe0cba846c97856c20683bcc8608b7bb8.zip
Notes
Diffstat (limited to 'emulators')
-rw-r--r--emulators/hfsutils/Makefile60
-rw-r--r--emulators/hfsutils/pkg-descr26
-rw-r--r--emulators/hfsutils/pkg-plist4
3 files changed, 60 insertions, 30 deletions
diff --git a/emulators/hfsutils/Makefile b/emulators/hfsutils/Makefile
index e1e45d56dcb0..6df1a64bdf88 100644
--- a/emulators/hfsutils/Makefile
+++ b/emulators/hfsutils/Makefile
@@ -1,26 +1,21 @@
-# New ports collection makefile for: hfsutils
-# Date Created: 7 Sep 1997
-# Whom: Vanilla I. Shu <vanilla@MinJe.com.TW>
-#
+# Created by: Vanilla I. Shu <vanilla@MinJe.com.TW>
# $FreeBSD$
-#
PORTNAME= hfsutils
PORTVERSION= 3.2.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators tk
MASTER_SITES= ftp://ftp.mars.org/pub/hfs/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Yet Another HFS Utility
+COMMENT= Utilities for accessing Apple's HFS volumes
-CONFLICTS= hfs-[0-9]*
+LICENSE= GPLv2
-USE_TCL= 84
-USE_TK= 84
+CONFLICTS= hfs-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR}
+ALL_TARGET= all hfsck/hfsck
MAN1= hattrib.1 \
hcd.1 \
@@ -28,8 +23,6 @@ MAN1= hattrib.1 \
hdel.1 \
hdir.1 \
hformat.1 \
- hfs.1 \
- hfssh.1 \
hfsutils.1 \
hls.1 \
hmkdir.1 \
@@ -38,10 +31,47 @@ MAN1= hattrib.1 \
hrename.1 \
hrmdir.1 \
humount.1 \
- hvol.1 \
+ hvol.1
+
+OPTIONS_DEFINE= TCLTK DOCS
+TCLTK_DESC= Build tools that require Tcl/Tk support
+
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTCLTK}
+USE_TCL= 84+
+USE_TK= 84+
+
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} --with-tk=${TK_LIBDIR}
+CPPFLAGS+= -I${LOCALBASE}/include
+
+MAN1+= hfs.1 \
+ hfssh.1 \
xhfs.1
+PLIST_FILES+= bin/hfs \
+ bin/hfssh \
+ bin/xhfs
+.else
+CONFIGURE_ARGS= --without-tcl --without-tk
+.endif
+
+post-patch:
+# Unbreak against Tcl 8.6
+ @${ECHO_CMD} '#define USE_INTERP_RESULT 1' >> ${WRKSRC}/config.h.in
+
post-install:
- ${CHMOD} 755 ${PREFIX}/bin/hfs
+ ${INSTALL_PROGRAM} ${WRKSRC}/hfsck/hfsck ${PREFIX}/bin
+.if ${PORT_OPTIONS:MTCLTK}
+ @${CHMOD} 755 ${PREFIX}/bin/hfs
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+. for f in BLURB CHANGES README TODO doc/*.txt
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
.include <bsd.port.mk>
diff --git a/emulators/hfsutils/pkg-descr b/emulators/hfsutils/pkg-descr
index 9381504e7030..773ec5415632 100644
--- a/emulators/hfsutils/pkg-descr
+++ b/emulators/hfsutils/pkg-descr
@@ -1,14 +1,16 @@
- HFS is the "Hierarchical File System" used on modern Macintosh computers.
- With this package, you can read and write Macintosh-formatted media such as
- floppy disks, CD-ROMs, and SCSI hard disks on most UNIX platforms. You can
- also format raw media into an HFS volume.
-
- This package contains a number of different tools:
-
- * Several command-line programs (hmount, hls, hcopy, et al.)
- * A Tk-based front-end for browsing and copying files through a
- variety of transfer modes (MacBinary, BinHex, text, etc.)
- * A Tcl package and interface for scriptable access to volumes
- * A C library for low-level access to volumes
+HFS is the "Hierarchical File System" used on modern Macintosh computers.
+With this package, you can read and write Macintosh-formatted media such as
+floppy disks, CD-ROMs, and SCSI hard disks on most UNIX platforms. You can
+also format raw media into an HFS volume.
+
+This package contains a number of different tools:
+
+ - Several command-line programs (hmount, hls, hcopy, et al.)
+ - Tk-based front-end for browsing and copying files through a
+ variety of transfer modes (MacBinary, BinHex, text, etc.)
+ - Tcl package and interface for scriptable access to volumes
+ - C library for low-level access to volumes
+
+Support for Apple's new Extended Format (HFS+) is currently not available.
WWW: http://www.mars.org/home/rob/proj/hfs/
diff --git a/emulators/hfsutils/pkg-plist b/emulators/hfsutils/pkg-plist
index beb4101b4181..3fd0b2c7ae93 100644
--- a/emulators/hfsutils/pkg-plist
+++ b/emulators/hfsutils/pkg-plist
@@ -4,8 +4,7 @@ bin/hcopy
bin/hdel
bin/hdir
bin/hformat
-bin/hfs
-bin/hfssh
+bin/hfsck
bin/hls
bin/hmkdir
bin/hmount
@@ -14,4 +13,3 @@ bin/hrename
bin/hrmdir
bin/humount
bin/hvol
-bin/xhfs