aboutsummaryrefslogtreecommitdiff
path: root/finance/aqbanking
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-09-01 17:05:14 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2012-09-01 17:05:14 +0000
commitb2b7993a62b3b2f66daf98f8439ffbde6ccaa146 (patch)
tree1ce9e643d4ff5e1609fc209342a2b2dcfe715301 /finance/aqbanking
parentb2e9b698df519fa6633e1eab2f37e9849617180a (diff)
downloadports-b2b7993a62b3b2f66daf98f8439ffbde6ccaa146.tar.gz
ports-b2b7993a62b3b2f66daf98f8439ffbde6ccaa146.zip
devel/gwenhywfar:
- Repocopy devel/gwenhywfar to devel/gwenhywfar-{fox16,gtk2,qt4}. - devel/gwenhywfar is now a master port and new slave ports will allow the user to install the GUI libraries separately. This will make packaging easier for finance/gnucash and finance/kmymoney-kde4. finance/aqbanking: - finance/aqbanking has been updated to 5.0.25 and includes a shlib bump, so instead of making the user rebuild twice it is included here. - Shlib bump aqbanking.33 -> aqbanking.34. - Fix LICENSE. - Convert to new OPTIONS framework. finance/gnucash: - Adjust LIB_DEPENDS for AQBANKING option so they are installed in the correct order. - Drop unneeded LICENSE_FILE. - Drop ABI version numbers from all LIB_DEPENDS (if you really want to keep them, at least keep the LIB_DEPENDS in the order I changed them to since aqbanking should be built last. Also aqbanking.33 -> aqbanking.34). - Remove BROKEN message now that the dependency problem is solved. finance/kmymoney-kde4: - Convert to new OPTIONS framework. - Drop WITH_* from PLIST_SUB. - Drop ABI version numbers from all LIB_DEPENDS. - Add USE_PKGCONFIG=build. - Remove IGNORE message now that the dependency problem is solved. Also clean up the header for the touched Makefiles. PR: ports/170492 Submitted by: Jason E. Hale <bsdkaffee@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=303495
Diffstat (limited to 'finance/aqbanking')
-rw-r--r--finance/aqbanking/Makefile43
-rw-r--r--finance/aqbanking/distinfo4
-rw-r--r--finance/aqbanking/pkg-plist1
3 files changed, 23 insertions, 25 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
index 4cdd5308c5b2..351e70a04fc5 100644
--- a/finance/aqbanking/Makefile
+++ b/finance/aqbanking/Makefile
@@ -1,33 +1,30 @@
-# New ports collection makefile for: aqbanking
-# Date created: June 2005
-# Whom: Sam Lawrance <lawrance@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= aqbanking
-PORTVERSION= 5.0.23
-PORTREVISION= 1
+PORTVERSION= 5.0.25
CATEGORIES= finance
-MASTER_SITES= http://www.aquamaniac.de/sites/download/download.php?package=03&release=93&file=01&dummy=/
+MASTER_SITES= http://www.aquamaniac.de/sites/download/download.php?package=03&release=95&file=01&dummy=/
MAINTAINER= bsdkaffee@gmail.com
COMMENT= Online banking interface and financial data framework
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
-LIB_DEPENDS= gwenhywfar.63:${PORTSDIR}/devel/gwenhywfar \
- gmp.10:${PORTSDIR}/math/gmp
+LIB_DEPENDS= gwenhywfar:${PORTSDIR}/devel/gwenhywfar \
+ gmp:${PORTSDIR}/math/gmp
+
+OPTIONS_DEFINE= DOCS KTOBLZCHECK PAYPAL
+OPTIONS_DEFAULT= KTOBLZCHECK
+
+KTOBLZCHECK_DESC= Enable KtoBlzCheck support
+PAYPAL_DESC= Build PayPal backend (separate license)
USE_GMAKE= yes
USE_GETTEXT= yes
+USE_PKGCONFIG= build
USE_AUTOTOOLS= libtool
-USE_GNOME= gnomehack pkgconfig
-
-OPTIONS= APIDOC "Full API documentation (requires Doxygen)" off \
- KTOBLZCHECK "KtoBlzCheck support" off \
- PAYPAL "Build PayPal backend (separate license)" off
+USE_GNOME= gnomehack
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-release="yes"
@@ -39,23 +36,23 @@ PLIST_SUB= AQB_SHLIB_VER="${AQB_SHLIB_VER}" \
GWEN_SHLIB_VER="${GWEN_SHLIB_VER}"
USE_LDCONFIG= yes
-AQB_SHLIB_VER= 33
+AQB_SHLIB_VER= 34
GWEN_SHLIB_VER= 60
.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS) && defined(WITH_APIDOC)
+.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
dot:${PORTSDIR}/graphics/graphviz
CONFIGURE_ARGS+=--enable-full-doc
PORTDOCS= apidoc
.endif
-.if defined(WITH_KTOBLZCHECK) || exists(${LOCALBASE}/lib/libktoblzcheck.so)
+.if ${PORT_OPTIONS:MKTOBLZCHECK} || exists(${LOCALBASE}/lib/libktoblzcheck.so)
LIB_DEPENDS+= ktoblzcheck:${PORTSDIR}/finance/ktoblzcheck
.endif
-.if defined(WITH_PAYPAL)
+.if ${PORT_OPTIONS:MPAYPAL}
CONFIGURE_ARGS+=--with-backends="aqhbci aqnone aqofxconnect aqpaypal"
PLIST_SUB+= WITH_PAYPAL=""
.else
@@ -67,12 +64,12 @@ post-patch:
${WRKSRC}/Makefile.in
post-build:
-.if !defined(NOPORTDOCS) && defined(WITH_APIDOC)
+.if ${PORT_OPTIONS:MDOCS}
@cd ${WRKSRC} && ${GMAKE} srcdoc
.endif
post-install:
-.if !defined(NOPORTDOCS) && defined(WITH_APIDOC)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/apidoc
cd ${WRKSRC}/apidoc && \
${COPYTREE_SHARE} \* ${DOCSDIR}/apidoc
diff --git a/finance/aqbanking/distinfo b/finance/aqbanking/distinfo
index 132a3b8f8cdd..ca197f62156c 100644
--- a/finance/aqbanking/distinfo
+++ b/finance/aqbanking/distinfo
@@ -1,2 +1,2 @@
-SHA256 (aqbanking-5.0.23.tar.gz) = 04f2a9420513040b0e88c93b746d2e193985af909b58cc4ba99db56570059213
-SIZE (aqbanking-5.0.23.tar.gz) = 3635384
+SHA256 (aqbanking-5.0.25.tar.gz) = bb99f16704200e1ff456574b17895e04ef375479b21e075607454e6bc7c02151
+SIZE (aqbanking-5.0.25.tar.gz) = 3637565
diff --git a/finance/aqbanking/pkg-plist b/finance/aqbanking/pkg-plist
index 84aa379da685..2af8ba4d1e27 100644
--- a/finance/aqbanking/pkg-plist
+++ b/finance/aqbanking/pkg-plist
@@ -315,6 +315,7 @@ share/aqbanking/imexporters/csv/profiles/sparda.conf
share/aqbanking/imexporters/csv/profiles/spk-aachen.conf
share/aqbanking/imexporters/csv/profiles/spk-steiermark.conf
share/aqbanking/imexporters/csv/profiles/tonline-banking.conf
+share/aqbanking/imexporters/csv/profiles/transfers.conf
share/aqbanking/imexporters/csv/profiles/vrnetworld.conf
share/aqbanking/imexporters/ctxfile/profiles/default.conf
share/aqbanking/imexporters/dtaus/profiles/debitnote.conf