aboutsummaryrefslogtreecommitdiff
path: root/finance/beanie
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2008-11-14 15:23:37 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2008-11-14 15:23:37 +0000
commitc24add050672158a75df24cd5975095e6e5f86fe (patch)
tree994efa27125a79fedbbacc73246dfeff1748b026 /finance/beanie
parente1ed403478eabd0aa3ffea9fc70bc6bd0f7ca655 (diff)
downloadports-c24add050672158a75df24cd5975095e6e5f86fe.tar.gz
ports-c24add050672158a75df24cd5975095e6e5f86fe.zip
Notes
Diffstat (limited to 'finance/beanie')
-rw-r--r--finance/beanie/Makefile23
-rw-r--r--finance/beanie/distinfo3
-rw-r--r--finance/beanie/pkg-descr19
-rw-r--r--finance/beanie/pkg-plist64
4 files changed, 109 insertions, 0 deletions
diff --git a/finance/beanie/Makefile b/finance/beanie/Makefile
new file mode 100644
index 000000000000..5876fa40dcb3
--- /dev/null
+++ b/finance/beanie/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: beanie
+# Date created: 15 October 2008
+# Whom: Dermot Tynan <dtynan@kalopa.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beanie
+PORTVERSION= 0.8.2
+CATEGORIES= finance
+MASTER_SITES= SF
+
+MAINTAINER= dtynan@kalopa.com
+COMMENT= Beanie is a fully-fledged accounting and payroll system
+
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+BUILD_DEPENDS= dbow:${PORTSDIR}/databases/dbow
+
+post-patch:
+ @${CP} ${WRKSRC}/beanie.mk.sample $(WRKSRC)/beanie.mk
+ @${CP} ${WRKSRC}/tmac/lhead.sample.r ${WRKSRC}/tmac/lhead.r
+
+.include <bsd.port.mk>
diff --git a/finance/beanie/distinfo b/finance/beanie/distinfo
new file mode 100644
index 000000000000..76d2072c5479
--- /dev/null
+++ b/finance/beanie/distinfo
@@ -0,0 +1,3 @@
+MD5 (beanie-0.8.2.tar.gz) = 85ff96c1e2db66092112442abf5ddf82
+SHA256 (beanie-0.8.2.tar.gz) = 7b381eb3ae37b3b1b607453a3b974b8fc2b38f4fb989185c00c21c8dfb636fab
+SIZE (beanie-0.8.2.tar.gz) = 191320
diff --git a/finance/beanie/pkg-descr b/finance/beanie/pkg-descr
new file mode 100644
index 000000000000..7263c3123fd2
--- /dev/null
+++ b/finance/beanie/pkg-descr
@@ -0,0 +1,19 @@
+Beanie is a flexible, distributed accounting system for medium-sized
+companies. It includes back-end batch processing as well as a
+(skeleton) GTK GUI and provides automated purchases, sales, and
+nominal ledgers as well as automated invoicing (via email). It also
+supports VAT and payroll.
+
+The latest version has considerable updates over the earlier releases
+and isn't particularly backwards-compatible. The installation and
+compilation is streamlined and the multi-database schema has been
+reduced to a single database per company. The gnome GUI is still
+lacking, but the command-line interface now has support for automated
+bank reconciliation (from online banking QIF files), payroll,
+automated billing and reminders, invoice PDF generation, statement
+PDF generation, and a general journal.
+
+WWW: http://beanie.sf.net/
+
+- Dermot Tynan
+dtynan@kalopa.com
diff --git a/finance/beanie/pkg-plist b/finance/beanie/pkg-plist
new file mode 100644
index 000000000000..3f3e37e873ab
--- /dev/null
+++ b/finance/beanie/pkg-plist
@@ -0,0 +1,64 @@
+beanie/bin/acct.daily
+beanie/bin/acct.epilog
+beanie/bin/acct.monthly
+beanie/bin/acct.prolog
+beanie/bin/acct.weekly
+beanie/bin/acctview
+beanie/bin/arreport
+beanie/bin/bankdump
+beanie/bin/bankrecon
+beanie/bin/brcheck
+beanie/bin/brfix
+beanie/bin/charge
+beanie/bin/cheque
+beanie/bin/crnote
+beanie/bin/csvmake
+beanie/bin/customers
+beanie/bin/email
+beanie/bin/eoyupdate
+beanie/bin/export
+beanie/bin/fixvat
+beanie/bin/geninvoice
+beanie/bin/holidays
+beanie/bin/hours
+beanie/bin/import
+beanie/bin/jdelete
+beanie/bin/jdump
+beanie/bin/jfix
+beanie/bin/mkletter
+beanie/bin/mklists
+beanie/bin/newcompany
+beanie/bin/overnight
+beanie/bin/payment
+beanie/bin/payslip
+beanie/bin/postinvoice
+beanie/bin/prnomacct
+beanie/bin/products
+beanie/bin/qifread
+beanie/bin/remind
+beanie/bin/report
+beanie/bin/revrec
+beanie/bin/runcom
+beanie/bin/runhours
+beanie/bin/runorders
+beanie/bin/runpayroll
+beanie/bin/sendnews
+beanie/bin/sharecert
+beanie/bin/statement
+beanie/bin/vatreturn
+beanie/bin/vatrtd
+beanie/roff/ccpayment.tmac
+beanie/roff/crnote.tmac
+beanie/roff/faxcover.tmac
+beanie/roff/invoice.tmac
+beanie/roff/letter.tmac
+beanie/roff/lhead.tmac
+beanie/roff/minutes.tmac
+beanie/roff/payslip.tmac
+beanie/roff/porder.tmac
+beanie/roff/sharecert.tmac
+beanie/roff/statement.tmac
+@dirrm beanie/tmp
+@dirrm beanie/roff
+@dirrm beanie/bin
+@dirrm beanie