aboutsummaryrefslogtreecommitdiff
path: root/finance/electrum
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2018-03-13 10:09:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2018-03-13 10:09:09 +0000
commit153125ed76cb0ba0c6daf7f617762b7a514b261e (patch)
tree7b363380429ee3457f2eab1df6d5de5998d4f68b /finance/electrum
parent80739103c987b7b590cd58d8a2f237c13400e60c (diff)
downloadports-153125ed76cb0ba0c6daf7f617762b7a514b261e.tar.gz
ports-153125ed76cb0ba0c6daf7f617762b7a514b261e.zip
Update to 3.1.1
Notes
Notes: svn path=/head/; revision=464360
Diffstat (limited to 'finance/electrum')
-rw-r--r--finance/electrum/Makefile2
-rw-r--r--finance/electrum/distinfo6
-rw-r--r--finance/electrum/files/patch-setup.py13
3 files changed, 15 insertions, 6 deletions
diff --git a/finance/electrum/Makefile b/finance/electrum/Makefile
index a25aee145983..e41906a4eee1 100644
--- a/finance/electrum/Makefile
+++ b/finance/electrum/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= electrum
-PORTVERSION= 3.1.0
+PORTVERSION= 3.1.1
CATEGORIES= finance python
MASTER_SITES= https://download.electrum.org/${PORTVERSION}/ \
http://download.electrum.org/${PORTVERSION}/
diff --git a/finance/electrum/distinfo b/finance/electrum/distinfo
index 88f7a26fc008..43d379f9d07b 100644
--- a/finance/electrum/distinfo
+++ b/finance/electrum/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520325647
-SHA256 (Electrum-3.1.0.tar.gz) = e8f87fc2c36086e550c543e9fc0eac978c3bce85826c353c4f85248427f580c1
-SIZE (Electrum-3.1.0.tar.gz) = 2727509
+TIMESTAMP = 1520916612
+SHA256 (Electrum-3.1.1.tar.gz) = 3195679f898bd763c6db32f46bbdf59fa5a211fd3013507f5c7aab25d9b94337
+SIZE (Electrum-3.1.1.tar.gz) = 2722902
diff --git a/finance/electrum/files/patch-setup.py b/finance/electrum/files/patch-setup.py
index 14c388af005a..ba52667c4755 100644
--- a/finance/electrum/files/patch-setup.py
+++ b/finance/electrum/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2017-03-23 01:56:41 UTC
+--- setup.py.orig 2018-03-12 17:25:11 UTC
+++ setup.py
-@@ -21,12 +21,6 @@ if platform.system() in ['Linux', 'FreeB
+@@ -27,12 +27,6 @@ if platform.system() in ['Linux', 'FreeB
parser.add_argument('--root=', dest='root_path', metavar='dir', default='/')
opts, _ = parser.parse_known_args(sys.argv[1:])
usr_share = os.path.join(sys.prefix, "share")
@@ -13,3 +13,12 @@
data_files += [
(os.path.join(usr_share, 'applications/'), ['electrum.desktop']),
(os.path.join(usr_share, 'pixmaps/'), ['icons/electrum.png'])
+@@ -86,8 +80,3 @@ setup(
+ url="https://electrum.org",
+ long_description="""Lightweight Bitcoin Wallet"""
+ )
+-
+-# Optional modules (not required to run Electrum)
+-import pip
+-opt_modules = requirements_hw + ['pycryptodomex']
+-[ pip.main(['install', m]) for m in opt_modules ]