aboutsummaryrefslogtreecommitdiff
path: root/finance/grisbi
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2010-06-08 20:31:53 +0000
committerThierry Thomas <thierry@FreeBSD.org>2010-06-08 20:31:53 +0000
commit3b5c0fb9623e065a64bdf5cb3bc9706c8ed4d3d8 (patch)
tree536a1886fa3a54225bcea1735b7ee672afed3d36 /finance/grisbi
parent406ea0f7489a9287fdc68cfca1a8825ea3593e70 (diff)
downloadports-3b5c0fb9623e065a64bdf5cb3bc9706c8ed4d3d8.tar.gz
ports-3b5c0fb9623e065a64bdf5cb3bc9706c8ed4d3d8.zip
Upgrade to 0.6.
Notes
Notes: svn path=/head/; revision=256136
Diffstat (limited to 'finance/grisbi')
-rw-r--r--finance/grisbi/Makefile19
-rw-r--r--finance/grisbi/distinfo6
-rw-r--r--finance/grisbi/files/patch-configure20
-rw-r--r--finance/grisbi/files/patch-pixmaps::Makefile.in20
-rw-r--r--finance/grisbi/files/patch-pixmaps_flags_Makefile.in11
-rw-r--r--finance/grisbi/files/patch-src::Makefile.in40
-rw-r--r--finance/grisbi/pkg-plist340
7 files changed, 374 insertions, 82 deletions
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 135653785306..03eb18ac6b82 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -6,27 +6,22 @@
#
PORTNAME= grisbi
-PORTVERSION= 0.5.9
-PORTREVISION= 7
+PORTVERSION= 0.6.0
CATEGORIES= finance
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20${PORTVERSION}/${PORTVERSION}/
MAINTAINER= thierry@FreeBSD.org
COMMENT= A personnal accounting application
-LIB_DEPENDS= ofx.4:${PORTSDIR}/finance/libofx
-.if !defined(WITHOUT_LATEX)
-RUN_DEPENDS= ${UCS_CLASSDIR}/ucs.sty:${PORTSDIR}/print/latex-ucs
-.endif
+LIB_DEPENDS= ofx.4:${PORTSDIR}/finance/libofx \
+ ssl.7:${PORTSDIR}/security/openssl
USE_BZIP2= yes
USE_ICONV= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gtk20 glib20 libxml2
-
-TEXMFDIR?= share/texmf
-UCS_CLASSDIR= ${LOCALBASE}/${TEXMFDIR}/tex/latex/ucs
+INSTALLS_ICONS= yes
MAN1= grisbi.1
@@ -42,8 +37,10 @@ PLIST_SUB+= NLS=""
.endif
pre-configure:
+ ${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e "s|pixmaps help|pixmaps|" ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e "s|pixmaps help|pixmaps|" ${WRKSRC}/Makefile.in
.endif
.include <bsd.port.mk>
diff --git a/finance/grisbi/distinfo b/finance/grisbi/distinfo
index 7334dc3d04fd..063dbde8338c 100644
--- a/finance/grisbi/distinfo
+++ b/finance/grisbi/distinfo
@@ -1,3 +1,3 @@
-MD5 (grisbi-0.5.9.tar.bz2) = 040fd41c01b9075f84b7edb9b009bb67
-SHA256 (grisbi-0.5.9.tar.bz2) = 38aacb3007047fdb63816501921c58363737259f6bfe69a900aeb5dcd33498d7
-SIZE (grisbi-0.5.9.tar.bz2) = 1003327
+MD5 (grisbi-0.6.0.tar.bz2) = 19062be7f4f6ec29adda4ec09f0d626f
+SHA256 (grisbi-0.6.0.tar.bz2) = 3b9759e0839fc571ccedfb8514b47bef86db50223424137c2e70997f6d252527
+SIZE (grisbi-0.6.0.tar.bz2) = 1966296
diff --git a/finance/grisbi/files/patch-configure b/finance/grisbi/files/patch-configure
new file mode 100644
index 000000000000..dde0eb529c2a
--- /dev/null
+++ b/finance/grisbi/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2010-05-04 20:15:58.000000000 +0200
++++ configure 2010-06-07 22:44:31.000000000 +0200
+@@ -17527,7 +17527,7 @@
+ $as_echo "yes" >&6; }
+ :
+ fi
+-if test x$noxml2 == xtrue
++if test "x$noxml2" = "xtrue"
+ then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: libxml2 support not available, this Grisbi build will not be able to load Gnucash files." >&5
+ $as_echo "libxml2 support not available, this Grisbi build will not be able to load Gnucash files." >&6; }
+@@ -17610,7 +17610,7 @@
+ $as_echo "yes" >&6; }
+ :
+ fi
+-if test x$nossl == xtrue
++if test "x$nossl" = "xtrue"
+ then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: OpenSSL support not available, this Grisbi build will not be able to crypt/decrypt files." >&5
+ $as_echo "OpenSSL support not available, this Grisbi build will not be able to crypt/decrypt files." >&6; }
diff --git a/finance/grisbi/files/patch-pixmaps::Makefile.in b/finance/grisbi/files/patch-pixmaps::Makefile.in
index 92f863c2bcbb..5b0d3a1c1979 100644
--- a/finance/grisbi/files/patch-pixmaps::Makefile.in
+++ b/finance/grisbi/files/patch-pixmaps::Makefile.in
@@ -1,11 +1,11 @@
---- pixmaps/Makefile.in.orig Mon Dec 19 16:26:40 2005
-+++ pixmaps/Makefile.in Mon Dec 19 18:36:53 2005
-@@ -98,7 +98,7 @@
- VERSION = @VERSION@
- prefix = @prefix@
-
--grisbi_pixmapsdir = $(datadir)/pixmaps/grisbi
+--- pixmaps/Makefile.in.orig 2010-05-04 20:15:57.000000000 +0200
++++ pixmaps/Makefile.in 2010-06-07 18:47:32.000000000 +0200
+@@ -288,7 +288,7 @@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ SUBDIRS = flags
+-grisbi_pixmapsdir = $(datadir)/pixmaps/$(PACKAGE)
+grisbi_pixmapsdir = $(pkgdatadir)/pixmaps
-
- grisbi_pixmaps_DATA = addresses.png banks.png currencies.png dollar.gif exec.png euro.gif files.png financial-years.png fonts.png form.png import.png payment-methods.png reconciliation.png transaction-list.png warnings.png grisbi-logo.png grisbi.png
-
+ grisbi_pixmaps_DATA = \
+ ac_asset.png \
+ ac_bank.png \
diff --git a/finance/grisbi/files/patch-pixmaps_flags_Makefile.in b/finance/grisbi/files/patch-pixmaps_flags_Makefile.in
new file mode 100644
index 000000000000..57cf1d73756b
--- /dev/null
+++ b/finance/grisbi/files/patch-pixmaps_flags_Makefile.in
@@ -0,0 +1,11 @@
+--- pixmaps/flags/Makefile.in.orig 2010-05-04 20:15:57.000000000 +0200
++++ pixmaps/flags/Makefile.in 2010-06-07 23:50:38.000000000 +0200
+@@ -246,7 +246,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-grisbi_pixmaps_flagsdir = $(datadir)/pixmaps/$(PACKAGE)/flags
++grisbi_pixmaps_flagsdir = $(pkgdatadir)/pixmaps/flags
+ grisbi_pixmaps_flags_DATA = ADP.png AED.png AFN.png ALL.png AMD.png \
+ ANG.png ARS.png ATS.png AUD.png AWG.png AZM.png BAM.png BBD.png \
+ BDT.png BEF.png BGN.png BHD.png BHU.png BIF.png BMD.png BND.png \
diff --git a/finance/grisbi/files/patch-src::Makefile.in b/finance/grisbi/files/patch-src::Makefile.in
index 6b15c78742c1..6149291b4fbf 100644
--- a/finance/grisbi/files/patch-src::Makefile.in
+++ b/finance/grisbi/files/patch-src::Makefile.in
@@ -1,29 +1,11 @@
---- src/Makefile.in.orig Mon Dec 19 16:26:40 2005
-+++ src/Makefile.in Mon Dec 19 18:39:23 2005
-@@ -101,7 +101,7 @@
- prefix = @prefix@
-
- localedir = $(datadir)/locale
--INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/grisbi\"" -DLOGO_PATH="\"$(datadir)/pixmaps/grisbi/grisbi-logo.png\"" -DANIM_PATH="\"$(datadir)/pixmaps/grisbi/euro.gif\"" -DHELP_PATH="\"$(datadir)/doc/grisbi/help\"" -Wall
-+INCLUDES = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(pkgdatadir)/pixmaps\"" -DLOGO_PATH="\"$(pkgdatadir)/pixmaps/grisbi-logo.png\"" -DANIM_PATH="\"$(pkgdatadir)/pixmaps/euro.gif\"" -DHELP_PATH="\"$(datadir)/doc/grisbi/help\"" -Wall
- bin_PROGRAMS = grisbi
-
- sources = accueil.c affichage.c affichage_liste.c banque.c barre_outils.c calendar.c categories_onglet.c check.c comptes_gestion.c comptes_onglet.c comptes_traitements.c csv.c devises.c dialog.c echeancier_onglet.c echeancier_formulaire.c echeancier_liste.c echeancier_ventilation.c equilibrage.c erreur.c etat_io.c etats_affiche.c etats_calculs.c etats_config.c etats_gtktable.c etats_html.c etats_latex.c etats_csv.c etats_onglet.c etats_support.c exercice.c export.c fenetre_principale.c fichier_configuration.c fichiers_gestion.c fichiers_io.c gnucash.c gtk_combofix.c gtk_list_button.c help.c imputation_budgetaire.c main.c menu.c ofx.c operations_classement.c operations_comptes.c operations_formulaire.c operations_liste.c operations_onglet.c parametres.c patienter.c print_config.c qif.c import.c html.c tiers_onglet.c traitement_variables.c type_operations.c ventilation.c utils.c utils_files.c utils_file_selection.c utils_xml.c search_glist.c
-@@ -112,7 +112,7 @@
- grisbi_INCLUDES = accueil.h affichage.h affichage_liste.h banque.h barre_outils.h calendar.h categories_onglet.h check.h comptes_gestion.h comptes_onglet.h comptes_traitements.h constants.h devises.h dialog.h echeancier_onglet.h echeancier_formulaire.h echeancier_liste.h echeancier_ventilation.h equilibrage.h erreur.h etat_io.h etats_calculs.h etats_config.h etats_gtktable.h etats.h etats_latex.h etats_onglet.h etats_support.h exercice.h fenetre_principale.h fichier_configuration.h fichiers_gestion.h fichiers_io.h gnucash.h gtkcombofix.h gtk_list_button.h help.h imputation_budgetaire.h include.h main.h menu.h operations_classement.h operations_comptes.h operations_formulaire.h operations_liste.h operations_onglet.h parametres.h patienter.h print_config.h qif.h import.h html.h structures.h tiers_onglet.h traitement_variables.h type_operations.h ventilation.h utils.h utils_xml.h search_glist.h
-
-
--EXTRA_DIST = grisbi.desktop grisbi.keys grisbi.mime $(grisbi_INCLUDES)
-+EXTRA_DIST = grisbi.desktop $(grisbi_INCLUDES)
-
- mimedir = $(datadir)/mime-info
- mime_DATA = grisbi.keys grisbi.mime
-@@ -347,7 +347,7 @@
- install-exec-am: install-binPROGRAMS
- install-exec: install-exec-am
-
--install-data-am: install-mimeDATA
-+install-data-am:
- install-data: install-data-am
-
- install-am: all-am
+--- src/Makefile.in.orig 2010-05-04 20:15:57.000000000 +0200
++++ src/Makefile.in 2010-06-07 19:00:24.000000000 +0200
+@@ -483,7 +483,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+-AM_CPPFLAGS = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(datadir)/pixmaps/@PACKAGE@\"" -DPLUGINS_DIR="\"$(libdir)/@PACKAGE@\"" -DLOGO_PATH="\"$(datadir)/pixmaps/@PACKAGE@/grisbi-logo.png\"" -DDATA_PATH="\"$(datadir)/@PACKAGE@\"" -DHELP_PATH="\"$(datadir)/doc/@PACKAGE@\"" -Wall
++AM_CPPFLAGS = -I$(top_srcdir) -I$(includedir) -I../intl -DLOCALEDIR=\"$(localedir)\" -DPIXMAPS_DIR="\"$(pkgdatadir)/pixmaps\"" -DPLUGINS_DIR="\"$(libdir)/@PACKAGE@\"" -DLOGO_PATH="\"$(pkgdatadir)/pixmaps/grisbi-logo.png\"" -DDATA_PATH="\"$(pkgdatadir)\"" -DHELP_PATH="\"$(datadir)/doc/@PACKAGE@\"" -Wall
+
+ # TODO: This manual setting of -Wl is a hack, I cannot get it from
+ # configure right now because of no doc.
diff --git a/finance/grisbi/pkg-plist b/finance/grisbi/pkg-plist
index 2f6d23f5e0d5..2bb74697e0c8 100644
--- a/finance/grisbi/pkg-plist
+++ b/finance/grisbi/pkg-plist
@@ -1,29 +1,53 @@
bin/grisbi
-%%PORTDOCS%%%%DOCSDIR%%/help/C/contents_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/C/grisbi-manuel.html
-%%PORTDOCS%%%%DOCSDIR%%/help/C/next_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/C/previous_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/C/quickstart.html
-%%PORTDOCS%%%%DOCSDIR%%/help/C/translation.html
-%%PORTDOCS%%%%DOCSDIR%%/help/C/topic.dat
-%%PORTDOCS%%%%DOCSDIR%%/help/de/contents_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/de/grisbi-manuel.html
-%%PORTDOCS%%%%DOCSDIR%%/help/de/next_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/de/previous_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/de/quickstart.html
-%%PORTDOCS%%%%DOCSDIR%%/help/de/topic.dat
-%%PORTDOCS%%%%DOCSDIR%%/help/de/translation.html
-%%PORTDOCS%%%%DOCSDIR%%/help/fr/contents_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/fr/grisbi-manuel.html
-%%PORTDOCS%%%%DOCSDIR%%/help/fr/next_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/fr/previous_motif.gif
-%%PORTDOCS%%%%DOCSDIR%%/help/fr/quickstart.html
-%%PORTDOCS%%%%DOCSDIR%%/help/fr/topic.dat
-%%PORTDOCS%%%%DOCSDIR%%/help/fr/translation.html
+lib/grisbi/gnucash.a
+lib/grisbi/gnucash.la
+lib/grisbi/gnucash.so
+lib/grisbi/ofx.a
+lib/grisbi/ofx.la
+lib/grisbi/ofx.so
+lib/grisbi/openssl.a
+lib/grisbi/openssl.la
+lib/grisbi/openssl.so
+share/applications/grisbi.desktop
+%%PORTDOCS%%%%DOCSDIR%%/C/contents_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/C/grisbi-manuel.html
+%%PORTDOCS%%%%DOCSDIR%%/C/next_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/C/previous_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/C/quickstart.html
+%%PORTDOCS%%%%DOCSDIR%%/C/topic.dat
+%%PORTDOCS%%%%DOCSDIR%%/C/translation.html
+%%PORTDOCS%%%%DOCSDIR%%/de/contents_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/de/grisbi-manuel.html
+%%PORTDOCS%%%%DOCSDIR%%/de/next_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/de/previous_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/de/quickstart.html
+%%PORTDOCS%%%%DOCSDIR%%/de/topic.dat
+%%PORTDOCS%%%%DOCSDIR%%/de/translation.html
+%%PORTDOCS%%%%DOCSDIR%%/en/contents_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/en/grisbi-manuel.html
+%%PORTDOCS%%%%DOCSDIR%%/en/next_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/en/previous_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/en/quickstart.html
+%%PORTDOCS%%%%DOCSDIR%%/en/topic.dat
+%%PORTDOCS%%%%DOCSDIR%%/en/translation.html
+%%PORTDOCS%%%%DOCSDIR%%/fr/contents_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/fr/grisbi-manuel.html
+%%PORTDOCS%%%%DOCSDIR%%/fr/next_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/fr/previous_motif.gif
+%%PORTDOCS%%%%DOCSDIR%%/fr/quickstart.html
+%%PORTDOCS%%%%DOCSDIR%%/fr/topic.dat
+%%PORTDOCS%%%%DOCSDIR%%/fr/translation.html
%%NLS%%share/locale/cs/LC_MESSAGES/grisbi.mo
+%%NLS%%share/locale/da/LC_MESSAGES/grisbi.mo
%%NLS%%share/locale/de/LC_MESSAGES/grisbi.mo
+%%NLS%%share/locale/de/LC_MESSAGES/grisbi-tips.mo
+%%NLS%%share/locale/el/LC_MESSAGES/grisbi.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/grisbi.mo
%%NLS%%share/locale/es/LC_MESSAGES/grisbi.mo
+%%NLS%%share/locale/es/LC_MESSAGES/grisbi-tips.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/grisbi.mo
%%NLS%%share/locale/fr/LC_MESSAGES/grisbi.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/grisbi-tips.mo
%%NLS%%share/locale/he/LC_MESSAGES/grisbi.mo
%%NLS%%share/locale/it/LC_MESSAGES/grisbi.mo
%%NLS%%share/locale/nl/LC_MESSAGES/grisbi.mo
@@ -32,27 +56,285 @@ bin/grisbi
%%NLS%%share/locale/ro/LC_MESSAGES/grisbi.mo
%%NLS%%share/locale/ru/LC_MESSAGES/grisbi.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/grisbi.mo
+%%DATADIR%%/categories/C/00_general.cgsb
+%%DATADIR%%/categories/C/empty.cgsb
+%%DATADIR%%/categories/de_AT/keine.cgsb
+%%DATADIR%%/categories/de_AT/kontenplan.cgsb
+%%DATADIR%%/categories/de_AT/minimal.cgsb
+%%DATADIR%%/categories/de_AT/standard.cgsb
+%%DATADIR%%/categories/de_DE/keine.cgsb
+%%DATADIR%%/categories/de_DE/minimal.cgsb
+%%DATADIR%%/categories/de_DE/standard.cgsb
+%%DATADIR%%/categories/fr/00_general.cgsb
+%%DATADIR%%/categories/fr/empty.cgsb
+%%DATADIR%%/categories/fr/liberal.cgsb
+%%DATADIR%%/categories/fr_FR/plan-comptable.cgsb
+%%DATADIR%%/categories/ru/00_general.cgsb
+%%DATADIR%%/categories/ru/empty.cgsb
+%%DATADIR%%/pixmaps/ac_asset.png
+%%DATADIR%%/pixmaps/ac_bank.png
+%%DATADIR%%/pixmaps/ac_cash.png
+%%DATADIR%%/pixmaps/ac_home.png
+%%DATADIR%%/pixmaps/ac_liability.png
%%DATADIR%%/pixmaps/addresses.png
+%%DATADIR%%/pixmaps/amount.png
+%%DATADIR%%/pixmaps/archive.png
+%%DATADIR%%/pixmaps/archives.png
+%%DATADIR%%/pixmaps/balance_estimate.png
%%DATADIR%%/pixmaps/banks.png
+%%DATADIR%%/pixmaps/budgetary_lines.png
+%%DATADIR%%/pixmaps/bug.png
+%%DATADIR%%/pixmaps/categories.png
+%%DATADIR%%/pixmaps/comments.png
%%DATADIR%%/pixmaps/currencies.png
-%%DATADIR%%/pixmaps/dollar.gif
-%%DATADIR%%/pixmaps/euro.gif
+%%DATADIR%%/pixmaps/delete.png
%%DATADIR%%/pixmaps/exec.png
%%DATADIR%%/pixmaps/files.png
%%DATADIR%%/pixmaps/financial-years.png
+%%DATADIR%%/pixmaps/flags/ADP.png
+%%DATADIR%%/pixmaps/flags/AED.png
+%%DATADIR%%/pixmaps/flags/AFN.png
+%%DATADIR%%/pixmaps/flags/ALL.png
+%%DATADIR%%/pixmaps/flags/AMD.png
+%%DATADIR%%/pixmaps/flags/ANG.png
+%%DATADIR%%/pixmaps/flags/ARS.png
+%%DATADIR%%/pixmaps/flags/ATS.png
+%%DATADIR%%/pixmaps/flags/AUD.png
+%%DATADIR%%/pixmaps/flags/AWG.png
+%%DATADIR%%/pixmaps/flags/AZM.png
+%%DATADIR%%/pixmaps/flags/BAM.png
+%%DATADIR%%/pixmaps/flags/BBD.png
+%%DATADIR%%/pixmaps/flags/BDT.png
+%%DATADIR%%/pixmaps/flags/BEF.png
+%%DATADIR%%/pixmaps/flags/BGN.png
+%%DATADIR%%/pixmaps/flags/BHD.png
+%%DATADIR%%/pixmaps/flags/BHU.png
+%%DATADIR%%/pixmaps/flags/BIF.png
+%%DATADIR%%/pixmaps/flags/BMD.png
+%%DATADIR%%/pixmaps/flags/BND.png
+%%DATADIR%%/pixmaps/flags/BOB.png
+%%DATADIR%%/pixmaps/flags/BRL.png
+%%DATADIR%%/pixmaps/flags/BSD.png
+%%DATADIR%%/pixmaps/flags/BTN.png
+%%DATADIR%%/pixmaps/flags/BWP.png
+%%DATADIR%%/pixmaps/flags/BYB.png
+%%DATADIR%%/pixmaps/flags/BZD.png
+%%DATADIR%%/pixmaps/flags/CAD.png
+%%DATADIR%%/pixmaps/flags/CAM.png
+%%DATADIR%%/pixmaps/flags/CDF.png
+%%DATADIR%%/pixmaps/flags/CHA.png
+%%DATADIR%%/pixmaps/flags/CHF.png
+%%DATADIR%%/pixmaps/flags/CLP.png
+%%DATADIR%%/pixmaps/flags/CNY.png
+%%DATADIR%%/pixmaps/flags/COO.png
+%%DATADIR%%/pixmaps/flags/COP.png
+%%DATADIR%%/pixmaps/flags/CO_.png
+%%DATADIR%%/pixmaps/flags/CRC.png
+%%DATADIR%%/pixmaps/flags/CUP.png
+%%DATADIR%%/pixmaps/flags/CVE.png
+%%DATADIR%%/pixmaps/flags/CYP.png
+%%DATADIR%%/pixmaps/flags/CZK.png
+%%DATADIR%%/pixmaps/flags/DEM.png
+%%DATADIR%%/pixmaps/flags/DJF.png
+%%DATADIR%%/pixmaps/flags/DKK.png
+%%DATADIR%%/pixmaps/flags/DOP.png
+%%DATADIR%%/pixmaps/flags/DZD.png
+%%DATADIR%%/pixmaps/flags/ECS.png
+%%DATADIR%%/pixmaps/flags/EEK.png
+%%DATADIR%%/pixmaps/flags/EGP.png
+%%DATADIR%%/pixmaps/flags/ERN.png
+%%DATADIR%%/pixmaps/flags/ESP.png
+%%DATADIR%%/pixmaps/flags/ETB.png
+%%DATADIR%%/pixmaps/flags/EUR.png
+%%DATADIR%%/pixmaps/flags/FIM.png
+%%DATADIR%%/pixmaps/flags/FJD.png
+%%DATADIR%%/pixmaps/flags/FKP.png
+%%DATADIR%%/pixmaps/flags/FRF.png
+%%DATADIR%%/pixmaps/flags/GBP.png
+%%DATADIR%%/pixmaps/flags/GEL.png
+%%DATADIR%%/pixmaps/flags/GHC.png
+%%DATADIR%%/pixmaps/flags/GIP.png
+%%DATADIR%%/pixmaps/flags/GMD.png
+%%DATADIR%%/pixmaps/flags/GNF.png
+%%DATADIR%%/pixmaps/flags/GRD.png
+%%DATADIR%%/pixmaps/flags/GRE.png
+%%DATADIR%%/pixmaps/flags/GTQ.png
+%%DATADIR%%/pixmaps/flags/GWP.png
+%%DATADIR%%/pixmaps/flags/GYD.png
+%%DATADIR%%/pixmaps/flags/HKD.png
+%%DATADIR%%/pixmaps/flags/HNL.png
+%%DATADIR%%/pixmaps/flags/HRK.png
+%%DATADIR%%/pixmaps/flags/HTG.png
+%%DATADIR%%/pixmaps/flags/HUF.png
+%%DATADIR%%/pixmaps/flags/IDR.png
+%%DATADIR%%/pixmaps/flags/IEP.png
+%%DATADIR%%/pixmaps/flags/ILS.png
+%%DATADIR%%/pixmaps/flags/INR.png
+%%DATADIR%%/pixmaps/flags/IQD.png
+%%DATADIR%%/pixmaps/flags/IRR.png
+%%DATADIR%%/pixmaps/flags/ISK.png
+%%DATADIR%%/pixmaps/flags/ITL.png
+%%DATADIR%%/pixmaps/flags/JMD.png
+%%DATADIR%%/pixmaps/flags/JOD.png
+%%DATADIR%%/pixmaps/flags/JPY.png
+%%DATADIR%%/pixmaps/flags/KES.png
+%%DATADIR%%/pixmaps/flags/KGS.png
+%%DATADIR%%/pixmaps/flags/KHR.png
+%%DATADIR%%/pixmaps/flags/KIR.png
+%%DATADIR%%/pixmaps/flags/KMF.png
+%%DATADIR%%/pixmaps/flags/KPW.png
+%%DATADIR%%/pixmaps/flags/KRW.png
+%%DATADIR%%/pixmaps/flags/KWD.png
+%%DATADIR%%/pixmaps/flags/KYD.png
+%%DATADIR%%/pixmaps/flags/KZT.png
+%%DATADIR%%/pixmaps/flags/LAK.png
+%%DATADIR%%/pixmaps/flags/LBP.png
+%%DATADIR%%/pixmaps/flags/LIE.png
+%%DATADIR%%/pixmaps/flags/LKR.png
+%%DATADIR%%/pixmaps/flags/LRD.png
+%%DATADIR%%/pixmaps/flags/LSL.png
+%%DATADIR%%/pixmaps/flags/LTL.png
+%%DATADIR%%/pixmaps/flags/LUF.png
+%%DATADIR%%/pixmaps/flags/LVL.png
+%%DATADIR%%/pixmaps/flags/LYD.png
+%%DATADIR%%/pixmaps/flags/MAD.png
+%%DATADIR%%/pixmaps/flags/MDL.png
+%%DATADIR%%/pixmaps/flags/MGF.png
+%%DATADIR%%/pixmaps/flags/MKD.png
+%%DATADIR%%/pixmaps/flags/MMK.png
+%%DATADIR%%/pixmaps/flags/MNT.png
+%%DATADIR%%/pixmaps/flags/MOP.png
+%%DATADIR%%/pixmaps/flags/MRO.png
+%%DATADIR%%/pixmaps/flags/MTL.png
+%%DATADIR%%/pixmaps/flags/MUR.png
+%%DATADIR%%/pixmaps/flags/MVR.png
+%%DATADIR%%/pixmaps/flags/MWK.png
+%%DATADIR%%/pixmaps/flags/MXP.png
+%%DATADIR%%/pixmaps/flags/MYR.png
+%%DATADIR%%/pixmaps/flags/MZM.png
+%%DATADIR%%/pixmaps/flags/NAD.png
+%%DATADIR%%/pixmaps/flags/NAU.png
+%%DATADIR%%/pixmaps/flags/NGN.png
+%%DATADIR%%/pixmaps/flags/NIG.png
+%%DATADIR%%/pixmaps/flags/NIO.png
+%%DATADIR%%/pixmaps/flags/NLG.png
+%%DATADIR%%/pixmaps/flags/NOK.png
+%%DATADIR%%/pixmaps/flags/NPR.png
+%%DATADIR%%/pixmaps/flags/NZD.png
+%%DATADIR%%/pixmaps/flags/OMR.png
+%%DATADIR%%/pixmaps/flags/PAB.png
+%%DATADIR%%/pixmaps/flags/PEN.png
+%%DATADIR%%/pixmaps/flags/PGK.png
+%%DATADIR%%/pixmaps/flags/PHP.png
+%%DATADIR%%/pixmaps/flags/PKR.png
+%%DATADIR%%/pixmaps/flags/PLN.png
+%%DATADIR%%/pixmaps/flags/PTE.png
+%%DATADIR%%/pixmaps/flags/PYG.png
+%%DATADIR%%/pixmaps/flags/QAR.png
+%%DATADIR%%/pixmaps/flags/ROL.png
+%%DATADIR%%/pixmaps/flags/RUR.png
+%%DATADIR%%/pixmaps/flags/RWF.png
+%%DATADIR%%/pixmaps/flags/SAN.png
+%%DATADIR%%/pixmaps/flags/SAR.png
+%%DATADIR%%/pixmaps/flags/SBD.png
+%%DATADIR%%/pixmaps/flags/SCR.png
+%%DATADIR%%/pixmaps/flags/SDD.png
+%%DATADIR%%/pixmaps/flags/SEK.png
+%%DATADIR%%/pixmaps/flags/SEN.png
+%%DATADIR%%/pixmaps/flags/SGD.png
+%%DATADIR%%/pixmaps/flags/SHP.png
+%%DATADIR%%/pixmaps/flags/SIT.png
+%%DATADIR%%/pixmaps/flags/SKK.png
+%%DATADIR%%/pixmaps/flags/SLC.png
+%%DATADIR%%/pixmaps/flags/SLL.png
+%%DATADIR%%/pixmaps/flags/SOS.png
+%%DATADIR%%/pixmaps/flags/SRD.png
+%%DATADIR%%/pixmaps/flags/STD.png
+%%DATADIR%%/pixmaps/flags/SVC.png
+%%DATADIR%%/pixmaps/flags/SYP.png
+%%DATADIR%%/pixmaps/flags/SZL.png
+%%DATADIR%%/pixmaps/flags/THB.png
+%%DATADIR%%/pixmaps/flags/TJS.png
+%%DATADIR%%/pixmaps/flags/TMM.png
+%%DATADIR%%/pixmaps/flags/TND.png
+%%DATADIR%%/pixmaps/flags/TOP.png
+%%DATADIR%%/pixmaps/flags/TPE.png
+%%DATADIR%%/pixmaps/flags/TRL.png
+%%DATADIR%%/pixmaps/flags/TTD.png
+%%DATADIR%%/pixmaps/flags/TUV.png
+%%DATADIR%%/pixmaps/flags/TWD.png
+%%DATADIR%%/pixmaps/flags/TZS.png
+%%DATADIR%%/pixmaps/flags/UAH.png
+%%DATADIR%%/pixmaps/flags/UGX.png
+%%DATADIR%%/pixmaps/flags/USD.png
+%%DATADIR%%/pixmaps/flags/UYU.png
+%%DATADIR%%/pixmaps/flags/UZS.png
+%%DATADIR%%/pixmaps/flags/VAT.png
+%%DATADIR%%/pixmaps/flags/VEB.png
+%%DATADIR%%/pixmaps/flags/VND.png
+%%DATADIR%%/pixmaps/flags/VUV.png
+%%DATADIR%%/pixmaps/flags/WST.png
+%%DATADIR%%/pixmaps/flags/XPF.png
+%%DATADIR%%/pixmaps/flags/YER.png
+%%DATADIR%%/pixmaps/flags/YUM.png
+%%DATADIR%%/pixmaps/flags/YUV.png
+%%DATADIR%%/pixmaps/flags/ZAR.png
+%%DATADIR%%/pixmaps/flags/ZMK.png
+%%DATADIR%%/pixmaps/flags/ZWD.png
%%DATADIR%%/pixmaps/fonts.png
%%DATADIR%%/pixmaps/form.png
+%%DATADIR%%/pixmaps/generalities.png
%%DATADIR%%/pixmaps/grisbi-logo.png
%%DATADIR%%/pixmaps/grisbi.png
+%%DATADIR%%/pixmaps/hide_r.png
+%%DATADIR%%/pixmaps/impexp.png
%%DATADIR%%/pixmaps/import.png
-%%DATADIR%%/pixmaps/payment-methods.png
+%%DATADIR%%/pixmaps/importlg.png
+%%DATADIR%%/pixmaps/new-categ.png
+%%DATADIR%%/pixmaps/new-ib.png
+%%DATADIR%%/pixmaps/new-payee.png
+%%DATADIR%%/pixmaps/new-report.png
+%%DATADIR%%/pixmaps/new-scheduled.png
+%%DATADIR%%/pixmaps/new-sub-categ.png
+%%DATADIR%%/pixmaps/new-sub-ib.png
+%%DATADIR%%/pixmaps/new-transaction.png
+%%DATADIR%%/pixmaps/organization.png
+%%DATADIR%%/pixmaps/payees.png
+%%DATADIR%%/pixmaps/payeeslg.png
+%%DATADIR%%/pixmaps/payeesmg.png
+%%DATADIR%%/pixmaps/payment.png
+%%DATADIR%%/pixmaps/reconat.png
%%DATADIR%%/pixmaps/reconciliation.png
+%%DATADIR%%/pixmaps/reconciliationlg.png
+%%DATADIR%%/pixmaps/reports.png
+%%DATADIR%%/pixmaps/scheduler.png
+%%DATADIR%%/pixmaps/show_r.png
+%%DATADIR%%/pixmaps/text.png
+%%DATADIR%%/pixmaps/title.png
+%%DATADIR%%/pixmaps/toolbar.png
%%DATADIR%%/pixmaps/transaction-list.png
+%%DATADIR%%/pixmaps/transdisplay.png
+%%DATADIR%%/pixmaps/transfer.png
%%DATADIR%%/pixmaps/warnings.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/C
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/de
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help/fr
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/help
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%DATADIR%%/tips.txt
+share/icons/hicolor/48x48/apps/grisbi.png
+share/mime-info/grisbi.keys
+share/mime-info/grisbi.mime
+@dirrm %%DATADIR%%/pixmaps/flags
@dirrm %%DATADIR%%/pixmaps
+@dirrmtry share/mime-info
+@dirrm %%DATADIR%%/categories/ru
+@dirrm %%DATADIR%%/categories/fr_FR
+@dirrm %%DATADIR%%/categories/fr
+@dirrm %%DATADIR%%/categories/de_DE
+@dirrm %%DATADIR%%/categories/de_AT
+@dirrm %%DATADIR%%/categories/C
+@dirrm %%DATADIR%%/categories
@dirrm %%DATADIR%%
+@dirrmtry share/applications
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/fr
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/en
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/de
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/C
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm lib/grisbi