aboutsummaryrefslogtreecommitdiff
path: root/finance/kmymoney/files
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-04-17 19:22:05 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-04-17 19:22:05 +0000
commit8f72924f24d75b41fbebedef9de2985e30321ae1 (patch)
tree12b9e8532c27d23d4076bb591238423834eb312f /finance/kmymoney/files
parent071f9dbc7cd4273ef0ea6825dffc3585ad580b35 (diff)
downloadports-8f72924f24d75b41fbebedef9de2985e30321ae1.tar.gz
ports-8f72924f24d75b41fbebedef9de2985e30321ae1.zip
Notes
Diffstat (limited to 'finance/kmymoney/files')
-rw-r--r--finance/kmymoney/files/patch-CMakeLists.txt36
-rw-r--r--finance/kmymoney/files/patch-cmake_modules_FindLibOfx.cmake20
-rw-r--r--finance/kmymoney/files/patch-kmymoney_converter_mymoneystatementreader.cpp15
-rw-r--r--finance/kmymoney/files/patch-kmymoney_dialogs_transactioneditor.cpp13
4 files changed, 84 insertions, 0 deletions
diff --git a/finance/kmymoney/files/patch-CMakeLists.txt b/finance/kmymoney/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..aaff6df3dee3
--- /dev/null
+++ b/finance/kmymoney/files/patch-CMakeLists.txt
@@ -0,0 +1,36 @@
+Fix finding libofx
+Fix Weboob yes/no configure summary
+
+--- CMakeLists.txt.orig 2018-03-18 15:56:39 UTC
++++ CMakeLists.txt
+@@ -135,11 +135,7 @@ endif(ENABLE_WEBENGINE)
+ find_package(LibOfx)
+ if(LIBOFX_FOUND)
+ option(ENABLE_OFXIMPORTER "Enable OFX Importer" ON)
+- if(CMAKE_SYSTEM_NAME MATCHES "Windows")
+- set(PATH_TO_LIBOFX_HEADER "${LIBOFX_INCLUDE_DIR}/libofx/libofx.h") # Windows doesn't even see the header if it's not full path
+- else()
+- set(PATH_TO_LIBOFX_HEADER "libofx/libofx.h")
+- endif()
++ set(PATH_TO_LIBOFX_HEADER "${LIBOFX_INCLUDE_DIR}/libofx/libofx.h")
+
+ unset(LIBOFX_HAVE_CLIENTUID)
+ unset(LIBOFX_HAVE_CLIENTUID CACHE) #not doing this will prevent updating below check
+@@ -317,7 +313,7 @@ nice_yesno("KMM_ADDRESSBOOK_FOUND")
+ nice_yesno("LIBOFX_FOUND")
+ nice_yesno("LIBOFX_HAVE_CLIENTUID")
+ nice_yesno("KBANKING_FOUND")
+-nice_yesno("WEBOOB_FOUND")
++nice_yesno("ENABLE_WEBOOB")
+ nice_yesno("LIBICAL_FOUND")
+ nice_yesno("ENABLE_SQLCIPHER")
+ nice_yesno("USE_QT_DESIGNER")
+@@ -340,7 +336,7 @@ OFX plugin: ${nice_LIBOFX
+
+ KBanking plugin: ${nice_KBANKING_FOUND}
+
+-weboob plugin: ${nice_WEBOOB_FOUND}
++weboob plugin: ${nice_ENABLE_WEBOOB}
+
+ iCalendar export plugin: ${nice_LIBICAL_FOUND}
+
diff --git a/finance/kmymoney/files/patch-cmake_modules_FindLibOfx.cmake b/finance/kmymoney/files/patch-cmake_modules_FindLibOfx.cmake
new file mode 100644
index 000000000000..8da21c0a3704
--- /dev/null
+++ b/finance/kmymoney/files/patch-cmake_modules_FindLibOfx.cmake
@@ -0,0 +1,20 @@
+Use CMake to find libofx instead of just relying on pkgconf
+
+--- cmake/modules/FindLibOfx.cmake.orig 2018-02-06 18:22:38 UTC
++++ cmake/modules/FindLibOfx.cmake
+@@ -25,14 +25,13 @@ IF (NOT WIN32)
+ # use pkg-config to get the directories and then use these values
+ # in the FIND_PATH() and FIND_LIBRARY() calls
+ FIND_PACKAGE(PkgConfig)
+- PKG_CHECK_MODULES(LIBOFX libofx>=${LIBOFX_MIN_VERSION})
++ PKG_CHECK_MODULES(PC_OFX libofx>=${LIBOFX_MIN_VERSION})
+ # I am not sure what the next statement should do, since the
+ # var LIBOFX_DEFINITIONS is not used anywhere. Leave it here
+ # in case I overlooked something, but it could really go
+ # at some point in time (ipwizard, 2011-02-15)
+ # SET(LIBOFX_DEFINITIONS ${LIBOFX_CFLAGS_OTHER})
+
+-ELSE (NOT WIN32)
+ FIND_PATH(LIBOFX_INCLUDE_DIR libofx/libofx.h
+ PATHS
+ ${PC_OFX_INCLUDEDIR}
diff --git a/finance/kmymoney/files/patch-kmymoney_converter_mymoneystatementreader.cpp b/finance/kmymoney/files/patch-kmymoney_converter_mymoneystatementreader.cpp
new file mode 100644
index 000000000000..4806313e5347
--- /dev/null
+++ b/finance/kmymoney/files/patch-kmymoney_converter_mymoneystatementreader.cpp
@@ -0,0 +1,15 @@
+kmymoney/converter/mymoneystatementreader.cpp:1555:19: error: no member named 'abs' in namespace 'std'; did you mean 'labs'?
+ const int gap = std::abs(matchedSchedule.transaction().postDate().toJulianDay() - importedTransaction.postDate().toJulianDay());
+ ^~~~~~~~
+ labs
+
+--- kmymoney/converter/mymoneystatementreader.cpp.orig 2018-04-17 04:30:23 UTC
++++ kmymoney/converter/mymoneystatementreader.cpp
+@@ -23,6 +23,7 @@
+
+ #include "mymoneystatementreader.h"
+ #include <typeinfo>
++#include <cstdlib>
+
+ // ----------------------------------------------------------------------------
+ // QT Headers
diff --git a/finance/kmymoney/files/patch-kmymoney_dialogs_transactioneditor.cpp b/finance/kmymoney/files/patch-kmymoney_dialogs_transactioneditor.cpp
new file mode 100644
index 000000000000..3fb10f724f18
--- /dev/null
+++ b/finance/kmymoney/files/patch-kmymoney_dialogs_transactioneditor.cpp
@@ -0,0 +1,13 @@
+Fix crash when adding a new schedule to scheduled transactions
+
+--- kmymoney/dialogs/transactioneditor.cpp.orig 2018-04-17 02:57:53 UTC
++++ kmymoney/dialogs/transactioneditor.cpp
+@@ -178,7 +178,7 @@ void TransactionEditor::setup(QWidgetList& tabOrderWid
+
+ // remove all unused widgets and don't forget to remove them
+ // from the tab order list as well
+- d->m_editWidgets.removeOrphans();
++ // d->m_editWidgets.removeOrphans();
+ QWidgetList::iterator it_w;
+ const QWidgetList editWidgets(d->m_editWidgets.values());
+ for (it_w = tabOrderWidgets.begin(); it_w != tabOrderWidgets.end();) {