aboutsummaryrefslogtreecommitdiff
path: root/finance/kmymoney
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /finance/kmymoney
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'finance/kmymoney')
-rw-r--r--finance/kmymoney/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/finance/kmymoney/Makefile b/finance/kmymoney/Makefile
index 37e43d8258fd..e704248b0a26 100644
--- a/finance/kmymoney/Makefile
+++ b/finance/kmymoney/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libalkimia5.so:finance/alkimia \
libKChart.so:graphics/kdiagram
USES= cmake compiler:c++14-lang desktop-file-utils gettext kde:5 \
- pkgconfig shared-mime-info shebangfix tar:xz
-USE_QT5= buildtools_build core dbus gui network printsupport qmake_build \
+ pkgconfig qt:5 shared-mime-info shebangfix tar:xz
+USE_QT= buildtools_build core dbus gui network printsupport qmake_build \
sql testlib_build xml webkit widgets
USE_KDE= activities archive auth bookmarks codecs completion config \
configwidgets coreaddons doctools_build ecm_build i18n \
@@ -64,7 +64,7 @@ KBANKING_DESC= Online banking via KBanking (AqBanking)
KBANKING_LIB_DEPENDS= libgwenhywfar.so:devel/gwenhywfar \
libgwengui-qt5.so:devel/gwenhywfar-qt5 \
libaqbanking.so:finance/aqbanking
-KBANKING_USE= qt5=qml,quick
+KBANKING_USE= qt=qml,quick
KBANKING_CMAKE_BOOL= ENABLE_KBANKING
KDEWEBKIT_DESC= Web content rendering via KDEWebKit
@@ -75,7 +75,7 @@ OFX_LIB_DEPENDS= libofx.so:finance/libofx
OFX_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_LibOfx
QTWEBENGINE_DESC= Web content rendering via QtWebEngine
-QTWEBENGINE_USE= qt5=location,webchannel,webengine
+QTWEBENGINE_USE= qt=location,webchannel,webengine
QTWEBENGINE_CMAKE_BOOL= ENABLE_WEBENGINE
QUOTES_DESC= Online stock and currency price quotes
@@ -91,7 +91,7 @@ WEBOOB_DESC= Online banking via Web Outside Of Browsers
WEBOOB_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}weboob>0:www/py-weboob@${PY_FLAVOR}
WEBOOB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}weboob>0:www/py-weboob@${PY_FLAVOR}
WEBOOB_USES= python:2.7
-WEBOOB_USE= qt5=concurrent
+WEBOOB_USE= qt=concurrent
WEBOOB_CMAKE_BOOL= ENABLE_WEBOOB
.if defined(MAINTAINER_MODE)