aboutsummaryrefslogtreecommitdiff
path: root/finance/libofx/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-10-15 12:03:57 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-10-15 12:03:57 +0000
commit52eab7776d8b5c11f85d39f056efbd28d3839abe (patch)
tree269a0a77103d02ddc59570aad01983e1866afb72 /finance/libofx/Makefile
parent4a3989a17e9401657ff718183cc7f90e8a0dd22a (diff)
downloadports-52eab7776d8b5c11f85d39f056efbd28d3839abe.tar.gz
ports-52eab7776d8b5c11f85d39f056efbd28d3839abe.zip
- Update to finance/libofx to 0.9.11
- Remake/rename patches - Bump PORTREVISION on dependent ports as the shared library version has increased
Notes
Notes: svn path=/head/; revision=424012
Diffstat (limited to 'finance/libofx/Makefile')
-rw-r--r--finance/libofx/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index fd10e2c6ecbd..87fcaa47be9d 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -2,21 +2,22 @@
# $FreeBSD$
PORTNAME= libofx
-PORTVERSION= 0.9.10
-PORTREVISION= 1
+PORTVERSION= 0.9.11
CATEGORIES= finance
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= jhale@FreeBSD.org
COMMENT= OpenSource implementation of the OFX (Open Financial eXchange)
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl \
libxml++-2.6.so:textproc/libxml++26 \
libosp.so:textproc/opensp
-USES= gmake iconv pkgconfig pathfix libtool
+USES= gettext-runtime gmake iconv libtool localbase pathfix pkgconfig
+USE_GNOME= glib20 glibmm libsigc++20 libxml2
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP \
--with-opensp-libs=${LOCALBASE}/lib
@@ -25,9 +26,6 @@ USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PORTDOCS= *
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-
OPTIONS_DEFINE= DOCS
post-install: