aboutsummaryrefslogtreecommitdiff
path: root/finance/p5-Business-OnlinePayment-Cardstream
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-10-25 08:48:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-10-25 08:48:38 +0000
commitbd6eda483b78923861b391598f8440768aec3ce7 (patch)
treeff4b27195f7649b426d3fb4fde71905f6fbb101e /finance/p5-Business-OnlinePayment-Cardstream
parent965d272b03805ad29fd6229f54430c99331a7623 (diff)
downloadports-bd6eda483b78923861b391598f8440768aec3ce7.tar.gz
ports-bd6eda483b78923861b391598f8440768aec3ce7.zip
Add p5-Business-OnlinePayment-Cardstream 1.0, a Business::OnlinePayment
backend module for Cardstream.
Notes
Notes: svn path=/head/; revision=68797
Diffstat (limited to 'finance/p5-Business-OnlinePayment-Cardstream')
-rw-r--r--finance/p5-Business-OnlinePayment-Cardstream/Makefile27
-rw-r--r--finance/p5-Business-OnlinePayment-Cardstream/distinfo1
-rw-r--r--finance/p5-Business-OnlinePayment-Cardstream/pkg-comment1
-rw-r--r--finance/p5-Business-OnlinePayment-Cardstream/pkg-descr3
-rw-r--r--finance/p5-Business-OnlinePayment-Cardstream/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/finance/p5-Business-OnlinePayment-Cardstream/Makefile b/finance/p5-Business-OnlinePayment-Cardstream/Makefile
new file mode 100644
index 000000000000..377c500d6a94
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-Cardstream/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Business::OnlinePayment::Cardstream
+# Date created: 24 October 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OnlinePayment-Cardstream
+PORTVERSION= 1.0
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/misc/p5-Business-CreditCard \
+ ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/misc/p5-Business-OnlinePayment
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Business::OnlinePayment::Cardstream.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-OnlinePayment-Cardstream/distinfo b/finance/p5-Business-OnlinePayment-Cardstream/distinfo
new file mode 100644
index 000000000000..1499a421e657
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-Cardstream/distinfo
@@ -0,0 +1 @@
+MD5 (Business-OnlinePayment-Cardstream-1.0.tar.gz) = 7465ef747cd867a3efc3497cd4175023
diff --git a/finance/p5-Business-OnlinePayment-Cardstream/pkg-comment b/finance/p5-Business-OnlinePayment-Cardstream/pkg-comment
new file mode 100644
index 000000000000..f20d35b58860
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-Cardstream/pkg-comment
@@ -0,0 +1 @@
+A Business::OnlinePayment backend module for Cardstream
diff --git a/finance/p5-Business-OnlinePayment-Cardstream/pkg-descr b/finance/p5-Business-OnlinePayment-Cardstream/pkg-descr
new file mode 100644
index 000000000000..1b85d6ae3a47
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-Cardstream/pkg-descr
@@ -0,0 +1,3 @@
+This is Business::OnlinePayment::Cardstream, an Business::OnlinePayment
+backend module for Cardstream. For information on obtaining a merchant
+account please visit http://www.cardstream.com or e-mail sales@cardstream.com.
diff --git a/finance/p5-Business-OnlinePayment-Cardstream/pkg-plist b/finance/p5-Business-OnlinePayment-Cardstream/pkg-plist
new file mode 100644
index 000000000000..25b4a4e32b70
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-Cardstream/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Business/OnlinePayment/Cardstream.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/Cardstream/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/Cardstream/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/Cardstream
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/Cardstream