aboutsummaryrefslogtreecommitdiff
path: root/finance/p5-Business-OnlinePayment-PaymentsGateway
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-01-02 11:17:04 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-01-02 11:17:04 +0000
commit34520cca40669ea52d0928947eedc377dad9329e (patch)
treef8779abcb619bba1fb28435a893163c7ad2230db /finance/p5-Business-OnlinePayment-PaymentsGateway
parent9d7e6019b5db70c8186e2d925c790da5e94abab9 (diff)
downloadports-34520cca40669ea52d0928947eedc377dad9329e.tar.gz
ports-34520cca40669ea52d0928947eedc377dad9329e.zip
Add p5-Business-OnlinePayment-PaymentsGateway 0.01, a
Business::OnlinePayment backend module for PaymentsGateway.net ACH Direct.
Notes
Notes: svn path=/head/; revision=72191
Diffstat (limited to 'finance/p5-Business-OnlinePayment-PaymentsGateway')
-rw-r--r--finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile27
-rw-r--r--finance/p5-Business-OnlinePayment-PaymentsGateway/distinfo1
-rw-r--r--finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-comment1
-rw-r--r--finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-descr2
-rw-r--r--finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-plist5
5 files changed, 36 insertions, 0 deletions
diff --git a/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile b/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
new file mode 100644
index 000000000000..3f100f141717
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymentsGateway/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Business::OnlinePayment::PaymentsGateway
+# Date created: 27 December 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-OnlinePayment-PaymentsGateway
+PORTVERSION= 0.01
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Business
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Business/CreditCard.pm:${PORTSDIR}/misc/p5-Business-CreditCard \
+ ${SITE_PERL}/Business/OnlinePayment.pm:${PORTSDIR}/misc/p5-Business-OnlinePayment
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Business::OnlinePayment::PaymentsGateway.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-OnlinePayment-PaymentsGateway/distinfo b/finance/p5-Business-OnlinePayment-PaymentsGateway/distinfo
new file mode 100644
index 000000000000..5bb4c3d62691
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymentsGateway/distinfo
@@ -0,0 +1 @@
+MD5 (Business-OnlinePayment-PaymentsGateway-0.01.tar.gz) = 965679063595b64856d50ff43d7dc374
diff --git a/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-comment b/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-comment
new file mode 100644
index 000000000000..37ecd901e97b
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-comment
@@ -0,0 +1 @@
+A Business::OnlinePayment backend module for PaymentsGateway.net ACH Direct
diff --git a/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-descr b/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-descr
new file mode 100644
index 000000000000..0191e90972bf
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-descr
@@ -0,0 +1,2 @@
+A Business::OnlinePayment backend module for PaymentsGateway.net ACH Direct.
+It is only useful if you have a merchant account with PaymentsGateway.net.
diff --git a/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-plist b/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-plist
new file mode 100644
index 000000000000..18be71f6e0e8
--- /dev/null
+++ b/finance/p5-Business-OnlinePayment-PaymentsGateway/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Business/OnlinePayment/PaymentsGateway.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/PaymentsGateway/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/PaymentsGateway/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Business/OnlinePayment/PaymentsGateway
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/Business/OnlinePayment/PaymentsGateway