aboutsummaryrefslogtreecommitdiff
path: root/finance/quantlib
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2019-03-05 21:36:27 +0000
committerMikhail Teterin <mi@FreeBSD.org>2019-03-05 21:36:27 +0000
commiteb4180764f0847aaa88d25981f58c78c9b13f22c (patch)
tree8c91b5d3b9d12572e30f2175b9067f3b1d84246b /finance/quantlib
parent630fe1e7af38b5f93f4fb31f8e0da4e77d118f97 (diff)
downloadports-eb4180764f0847aaa88d25981f58c78c9b13f22c.tar.gz
ports-eb4180764f0847aaa88d25981f58c78c9b13f22c.zip
Upgrade from 1.13 to 1.15.
PR: 233864 Reported by: jbeich
Notes
Notes: svn path=/head/; revision=494745
Diffstat (limited to 'finance/quantlib')
-rw-r--r--finance/quantlib/Makefile7
-rw-r--r--finance/quantlib/distinfo6
-rw-r--r--finance/quantlib/files/patch-gmakeism14
-rw-r--r--finance/quantlib/files/patch-tests36
-rw-r--r--finance/quantlib/pkg-plist23
5 files changed, 26 insertions, 60 deletions
diff --git a/finance/quantlib/Makefile b/finance/quantlib/Makefile
index 5d0b497d325a..d1fe78d83ba2 100644
--- a/finance/quantlib/Makefile
+++ b/finance/quantlib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= quantlib
-PORTVERSION= 1.13
-PORTREVISION= 4
+PORTVERSION= 1.15
CATEGORIES= finance math devel
MASTER_SITES= https://dl.bintray.com/${PORTNAME}/releases/
DISTNAME= QuantLib-${PORTVERSION}
@@ -16,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-USES= compiler
+USES= compiler libtool
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= EMACS=no
@@ -60,4 +59,6 @@ OPENMP_LDFLAGS= -L${LOCALBASE}/lib
# one too:
OPENMP_LDFLAGS+= -L${LOCALBASE}/llvm${COMPILER_VERSION}/lib
+CXXFLAGS_i386= -DBOOST_MATH_NO_LONG_DOUBLE_MATH_FUNCTIONS
+
.include <bsd.port.mk>
diff --git a/finance/quantlib/distinfo b/finance/quantlib/distinfo
index be23fecf8f7f..4d45e2d49477 100644
--- a/finance/quantlib/distinfo
+++ b/finance/quantlib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531235784
-SHA256 (QuantLib-1.13.tar.gz) = bb52df179781f9c19ef8e976780c4798b0cdc4d21fa72a7a386016e24d1a86e6
-SIZE (QuantLib-1.13.tar.gz) = 9132949
+TIMESTAMP = 1551741337
+SHA256 (QuantLib-1.15.tar.gz) = 1f651b210d3046bffa9635864906423d40f9fff87faeaf417c9b76fd88f0ee64
+SIZE (QuantLib-1.15.tar.gz) = 9135648
diff --git a/finance/quantlib/files/patch-gmakeism b/finance/quantlib/files/patch-gmakeism
deleted file mode 100644
index 3a989a1cc090..000000000000
--- a/finance/quantlib/files/patch-gmakeism
+++ /dev/null
@@ -1,14 +0,0 @@
-Allow check-exapmles to work with our make, upstream's syntax is
-gmake-only...
-
---- Examples/Makefile.in 2018-05-23 14:35:06
-+++ Examples/Makefile.in 2018-07-10 23:06:07
-@@ -657,6 +657,6 @@
-
-
--%.check:
-- $(MAKE) -C $* check-examples
-+${SUBDIR_CHECKS}:
-+ $(MAKE) -C ${@:.check=} check-examples
-
- .PHONY: examples check-examples $(SUBDIRS)
diff --git a/finance/quantlib/files/patch-tests b/finance/quantlib/files/patch-tests
deleted file mode 100644
index 8eaa0a23e219..000000000000
--- a/finance/quantlib/files/patch-tests
+++ /dev/null
@@ -1,36 +0,0 @@
-See:
-
- https://github.com/lballabio/QuantLib/pull/507/
-
---- ql/termstructures/volatility/equityfx/fixedlocalvolsurface.cpp
-+++ ql/termstructures/volatility/equityfx/fixedlocalvolsurface.cpp
-@@ -132,7 +132,8 @@ namespace QuantLib {
-
- for (Size i=0; i < strikes_.size(); ++i)
- for (Size j=1; j<strikes_[i]->size(); j++) {
-- QL_REQUIRE(strikes_[i]->at(j)>=strikes_[i]->at(j-1),
-+ QL_REQUIRE(strikes_[i]->at(j)>=strikes_[i]->at(j-1)
-+ || close_enough(strikes_[i]->at(j),strikes_[i]->at(j-1)),
- "strikes must be sorted");
- }
- }
---- test-suite/hestonslvmodel.cpp
-+++ test-suite/hestonslvmodel.cpp
-@@ -2446,7 +2446,7 @@ void HestonSLVModelTest::testMoustacheGraph() {
- -0.0293,-0.0297,-0.0251,-0.0192,-0.0134,-0.0084,-0.0045,
- -0.0015, 0.0005, 0.0017, 0.0020
- };
-- const Real tol = 8e-3;
-+ const Real tol = 1e-2;
-
- for (Size i=0; i < 18; ++i) {
- const Real dist = 10.0+5.0*i;
---- test-suite/fdheston.cpp 2018-05-21 08:58:38.000000000 -0400
-+++ test-suite/fdheston.cpp 2018-07-20 18:51:34.213199000 -0400
-@@ -469,5 +469,5 @@
- new FdHestonVanillaEngine(boost::shared_ptr<HestonModel>(
- new HestonModel(hestonProcess)),
-- 500, 400, 3, 0,
-+ 4000, 400, 3, 0,
- FdmSchemeDesc::ExplicitEuler())));
-
diff --git a/finance/quantlib/pkg-plist b/finance/quantlib/pkg-plist
index 451cdab68c87..142626f14369 100644
--- a/finance/quantlib/pkg-plist
+++ b/finance/quantlib/pkg-plist
@@ -15,10 +15,10 @@ bin/quantlib-config
%%EXAMPLES%%bin/GlobalOptimizer
%%EXAMPLES%%bin/LatentModel
%%EXAMPLES%%bin/MarketModels
+%%EXAMPLES%%bin/MulticurveBootstrapping
%%EXAMPLES%%bin/MultidimIntegral
%%EXAMPLES%%bin/Replication
%%EXAMPLES%%bin/Repo
-%%EXAMPLES%%bin/SwapValuation
%%BENCHMARK%%bin/quantlib-benchmark
%%EXAMPLES%%man/man1/BasketLosses.1.gz
%%EXAMPLES%%man/man1/BermudanSwaption.1.gz
@@ -36,9 +36,9 @@ bin/quantlib-config
%%EXAMPLES%%man/man1/LatentModel.1.gz
%%EXAMPLES%%man/man1/MarketModels.1.gz
%%EXAMPLES%%man/man1/MultidimIntegral.1.gz
+%%EXAMPLES%%man/man1/MulticurveBootstrapping.1.gz
%%EXAMPLES%%man/man1/Replication.1.gz
%%EXAMPLES%%man/man1/Repo.1.gz
-%%EXAMPLES%%man/man1/SwapValuation.1.gz
%%BENCHMARK%%man/man1/quantlib-benchmark.1.gz
include/ql/cashflows/all.hpp
include/ql/cashflows/averagebmacoupon.hpp
@@ -100,6 +100,10 @@ include/ql/experimental/barrieroption/vannavolgabarrierengine.hpp
include/ql/experimental/barrieroption/vannavolgadoublebarrierengine.hpp
include/ql/experimental/barrieroption/vannavolgainterpolation.hpp
include/ql/experimental/barrieroption/wulinyongdoublebarrierengine.hpp
+include/ql/experimental/basismodels/all.hpp
+include/ql/experimental/basismodels/swaptioncfs.hpp
+include/ql/experimental/basismodels/tenoroptionletvts.hpp
+include/ql/experimental/basismodels/tenorswaptionvts.hpp
include/ql/experimental/callablebonds/all.hpp
include/ql/experimental/callablebonds/blackcallablebondengine.hpp
include/ql/experimental/callablebonds/callablebondconstantvol.hpp
@@ -264,6 +268,9 @@ include/ql/experimental/finitedifferences/modtriplebandlinearop.hpp
include/ql/experimental/finitedifferences/riskneutraldensitycalculator.hpp
include/ql/experimental/finitedifferences/squarerootprocessrndcalculator.hpp
include/ql/experimental/finitedifferences/vanillavppoption.hpp
+include/ql/experimental/futures/all.hpp
+include/ql/experimental/futures/overnightindexfuture.hpp
+include/ql/experimental/futures/overnightindexfutureratehelper.hpp
include/ql/experimental/fx/all.hpp
include/ql/experimental/fx/blackdeltacalculator.hpp
include/ql/experimental/fx/deltavolquote.hpp
@@ -299,7 +306,6 @@ include/ql/experimental/math/levyflightdistribution.hpp
include/ql/experimental/math/moorepenroseinverse.hpp
include/ql/experimental/math/multidimintegrator.hpp
include/ql/experimental/math/multidimquadrature.hpp
-include/ql/experimental/math/numericaldifferentiation.hpp
include/ql/experimental/math/particleswarmoptimization.hpp
include/ql/experimental/math/piecewisefunction.hpp
include/ql/experimental/math/piecewiseintegral.hpp
@@ -387,6 +393,7 @@ include/ql/indexes/ibor/euribor.hpp
include/ql/indexes/ibor/eurlibor.hpp
include/ql/indexes/ibor/fedfunds.hpp
include/ql/indexes/ibor/gbplibor.hpp
+include/ql/indexes/ibor/bibor.hpp
include/ql/indexes/ibor/jibar.hpp
include/ql/indexes/ibor/jpylibor.hpp
include/ql/indexes/ibor/libor.hpp
@@ -397,7 +404,9 @@ include/ql/indexes/ibor/pribor.hpp
include/ql/indexes/ibor/robor.hpp
include/ql/indexes/ibor/seklibor.hpp
include/ql/indexes/ibor/shibor.hpp
+include/ql/indexes/ibor/sofr.hpp
include/ql/indexes/ibor/sonia.hpp
+include/ql/indexes/ibor/thbfix.hpp
include/ql/indexes/ibor/tibor.hpp
include/ql/indexes/ibor/trlibor.hpp
include/ql/indexes/ibor/usdlibor.hpp
@@ -702,6 +711,8 @@ include/ql/methods/finitedifferences/operators/fdmlinearopiterator.hpp
include/ql/methods/finitedifferences/operators/fdmlinearoplayout.hpp
include/ql/methods/finitedifferences/operators/firstderivativeop.hpp
include/ql/methods/finitedifferences/operators/ninepointlinearop.hpp
+include/ql/methods/finitedifferences/operators/nthorderderivativeop.hpp
+include/ql/methods/finitedifferences/operators/numericaldifferentiation.hpp
include/ql/methods/finitedifferences/operators/secondderivativeop.hpp
include/ql/methods/finitedifferences/operators/secondordermixedderivativeop.hpp
include/ql/methods/finitedifferences/operators/triplebandlinearop.hpp
@@ -714,6 +725,7 @@ include/ql/methods/finitedifferences/schemes/hundsdorferscheme.hpp
include/ql/methods/finitedifferences/schemes/impliciteulerscheme.hpp
include/ql/methods/finitedifferences/schemes/methodoflinesscheme.hpp
include/ql/methods/finitedifferences/schemes/modifiedcraigsneydscheme.hpp
+include/ql/methods/finitedifferences/schemes/trbdf2scheme.hpp
include/ql/methods/finitedifferences/solvers/all.hpp
include/ql/methods/finitedifferences/solvers/fdm2dblackscholessolver.hpp
include/ql/methods/finitedifferences/solvers/fdm1dimsolver.hpp
@@ -1279,6 +1291,7 @@ include/ql/time/calendars/sweden.hpp
include/ql/time/calendars/switzerland.hpp
include/ql/time/calendars/taiwan.hpp
include/ql/time/calendars/target.hpp
+include/ql/time/calendars/thailand.hpp
include/ql/time/calendars/turkey.hpp
include/ql/time/calendars/ukraine.hpp
include/ql/time/calendars/unitedkingdom.hpp
@@ -1319,6 +1332,7 @@ include/ql/utilities/steppingiterator.hpp
include/ql/utilities/tracing.hpp
include/ql/utilities/vectors.hpp
include/ql/auto_link.hpp
+include/ql/auto_ptr.hpp
include/ql/cashflow.hpp
include/ql/compounding.hpp
include/ql/config.hpp
@@ -1329,6 +1343,7 @@ include/ql/errors.hpp
include/ql/exchangerate.hpp
include/ql/exercise.hpp
include/ql/event.hpp
+include/ql/functional.hpp
include/ql/grid.hpp
include/ql/handle.hpp
include/ql/index.hpp
@@ -1347,6 +1362,7 @@ include/ql/quantlib.hpp
include/ql/quote.hpp
include/ql/rebatedexercise.hpp
include/ql/settings.hpp
+include/ql/shared_ptr.hpp
include/ql/stochasticprocess.hpp
include/ql/termstructure.hpp
include/ql/timegrid.hpp
@@ -1358,7 +1374,6 @@ include/ql/volatilitymodel.hpp
lib/libQuantLib.so
lib/libQuantLib.so.0
lib/libQuantLib.so.0.0.0
-lib/libQuantLib.la
lib/libQuantLib.a
libdata/pkgconfig/quantlib.pc
man/man1/quantlib-config.1.gz