aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-01-12 20:50:23 +0000
committerRene Ladan <rene@FreeBSD.org>2021-01-12 20:50:23 +0000
commit0fa85ea40c711fe0a79c231f6270fe0ead5445ea (patch)
treee42b31e645653af9ab0b2b89546d1b6e6e65e961 /finance
parenta445d926254533140d3ef3c969050055825076eb (diff)
downloadports-0fa85ea40c711fe0a79c231f6270fe0ead5445ea.tar.gz
ports-0fa85ea40c711fe0a79c231f6270fe0ead5445ea.zip
finance/quickfix: migrate to Python 3
PR: 251677 [1] PR: 249685 [2] Submitted by: maintainer [1] Submitted by: swills [1]
Notes
Notes: svn path=/head/; revision=561379
Diffstat (limited to 'finance')
-rw-r--r--finance/quickfix/Makefile6
-rw-r--r--finance/quickfix/files/patch-m4_ax__python.m418
2 files changed, 6 insertions, 18 deletions
diff --git a/finance/quickfix/Makefile b/finance/quickfix/Makefile
index a8249e7aed8b..407a11bc5346 100644
--- a/finance/quickfix/Makefile
+++ b/finance/quickfix/Makefile
@@ -24,7 +24,7 @@ USE_LDCONFIG= yes
SHEBANG_FILES= examples/tradeclientgui/banzai/build.sh
HAS_CONFIGURE= yes
CONFIGURE_ENV= CXX=${CXX} CC=${CC} LIBS=-L${LOCALBASE}/lib/
-CONFIGURE_ARGS+= --without-python --without-python3
+CONFIGURE_ARGS+= --without-python2
OPTIONS_DEFINE= MYSQL PGSQL PYTHON RUBY JAVA
OPTIONS_DEFAULT= MYSQL
@@ -33,8 +33,8 @@ PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= postgresql
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
-PYTHON_USES= python:2.7
-PYTHON_CONFIGURE_WITH= python2
+PYTHON_USES= python:3.7
+PYTHON_CONFIGURE_WITH= python3
RUBY_USE= ruby=yes
RUBY_CONFIGURE_WITH= ruby
RUBY_LIB_DEPENDS+=libunwind.so:devel/libunwind
diff --git a/finance/quickfix/files/patch-m4_ax__python.m4 b/finance/quickfix/files/patch-m4_ax__python.m4
index 8e3dbc397632..89e73ecf51c7 100644
--- a/finance/quickfix/files/patch-m4_ax__python.m4
+++ b/finance/quickfix/files/patch-m4_ax__python.m4
@@ -16,28 +16,16 @@
has_python3=false
)
-@@ -44,20 +47,20 @@ AC_SUBST(PYTHON3_PREFIX)
-
- if test $has_python2 = true
- then
-- PYTHON2_INCLUDE_PATH=[`python2 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
-+ PYTHON2_INCLUDE_PATH=[`python2.7 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
- PYTHON2_CFLAGS="-I${PYTHON2_INCLUDE_PATH}"
- AC_SUBST(PYTHON2_CFLAGS)
-- PYTHON2_SITE_PACKAGES=[`python2 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
-+ PYTHON2_SITE_PACKAGES=[`python2.7 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
- AC_SUBST(PYTHON2_SITE_PACKAGES)
- AC_DEFINE(HAVE_PYTHON2, 1, Define if you have python2)
- fi
+@@ -54,10 +57,10 @@ fi
if test $has_python3 = true
then
- PYTHON3_INCLUDE_PATH=[`python3 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
-+ PYTHON3_INCLUDE_PATH=[`python3.6 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
++ PYTHON3_INCLUDE_PATH=[`python3.7 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
PYTHON3_CFLAGS="-I${PYTHON3_INCLUDE_PATH}"
AC_SUBST(PYTHON3_CFLAGS)
- PYTHON3_SITE_PACKAGES=[`python3 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
-+ PYTHON3_SITE_PACKAGES=[`python3.6 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
++ PYTHON3_SITE_PACKAGES=[`python3.7 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
AC_SUBST(PYTHON3_SITE_PACKAGES)
AC_DEFINE(HAVE_PYTHON3, 1, Define if you have python3)
fi