aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-04 15:07:34 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-01-04 15:07:34 +0000
commit5122d473a7773e0c1819cd36598a9d10f498b12e (patch)
treeea8f58316148845ad9c7653d6a6a21afcabca889 /finance
parent1dfca9d2c53b66c57dfcba1eb1acb92a08b9fc56 (diff)
downloadports-5122d473a7773e0c1819cd36598a9d10f498b12e.tar.gz
ports-5122d473a7773e0c1819cd36598a9d10f498b12e.zip
finance/quickfix: fix build on non-x86
Code uses x86 assembly, but makes it possible to use Boost atomic.
Notes
Notes: svn path=/head/; revision=560298
Diffstat (limited to 'finance')
-rw-r--r--finance/quickfix/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/finance/quickfix/Makefile b/finance/quickfix/Makefile
index f92ba6ae71dc..a8249e7aed8b 100644
--- a/finance/quickfix/Makefile
+++ b/finance/quickfix/Makefile
@@ -11,7 +11,6 @@ COMMENT= Free FIX Protocol Implementation
LICENSE= GPLv3+
-BROKEN_powerpc64= fails to configure: unable to find set_terminate in std or global namespace
BROKEN_i386= fails to build
BUILD_DEPENDS= bash:shells/bash
@@ -44,6 +43,14 @@ JAVA_CONFIGURE_WITH= java
INSTALL_TARGET=install-strip
+.include <bsd.port.options.mk>
+
+.if ${ARCH} != amd64 && ${ARCH} != i386
+CXXFLAGS+= -DENABLE_BOOST_ATOMIC_COUNT
+LIB_DEPENDS+= libboost_system.so:devel/boost-libs
+USES+= compiler:c++11-lang localbase
+.endif
+
post-extract:
@${REINPLACE_CMD} -e 's|^make|gmake|' \
${WRKSRC}/src/ruby/make_ruby.sh