aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-12-12 01:36:42 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-12-12 01:36:42 +0000
commit56b9b29a38f273106b66ea6fa6b26736ed4e6420 (patch)
treed0149821e9e32e26ca794fafa279c108e088d9a8 /finance
parent95ecffeb57ea072396289f391c96055b6e99b866 (diff)
downloadports-56b9b29a38f273106b66ea6fa6b26736ed4e6420.tar.gz
ports-56b9b29a38f273106b66ea6fa6b26736ed4e6420.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-Business-TW-TSIB-CStorePayment/Makefile26
-rw-r--r--finance/p5-Business-TW-TSIB-CStorePayment/distinfo3
-rw-r--r--finance/p5-Business-TW-TSIB-CStorePayment/pkg-descr4
-rw-r--r--finance/p5-Business-TW-TSIB-CStorePayment/pkg-plist9
5 files changed, 43 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index bdd169aa0a5f..d77e81a0ea2d 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -48,6 +48,7 @@
SUBDIR += p5-Business-OnlinePayment-eSec
SUBDIR += p5-Business-OnlinePayment-iAuthorizer
SUBDIR += p5-Business-PayPal-IPN
+ SUBDIR += p5-Business-TW-TSIB-CStorePayment
SUBDIR += p5-Business-WorldPay-Junior
SUBDIR += p5-Finance-Amortization
SUBDIR += p5-Finance-Currency-Convert
diff --git a/finance/p5-Business-TW-TSIB-CStorePayment/Makefile b/finance/p5-Business-TW-TSIB-CStorePayment/Makefile
new file mode 100644
index 000000000000..1b8c49705eb9
--- /dev/null
+++ b/finance/p5-Business-TW-TSIB-CStorePayment/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Business-TW-TSIB-CStorePayment
+# Date created: 2007/10/04
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Business-TW-TSIB-CStorePayment
+PORTVERSION= 0.02
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Module for Taishin Bank Convenient Store Payment Management
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Business::TW::TSIB::CStorePayment.3
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Business-TW-TSIB-CStorePayment/distinfo b/finance/p5-Business-TW-TSIB-CStorePayment/distinfo
new file mode 100644
index 000000000000..353aef3d23f0
--- /dev/null
+++ b/finance/p5-Business-TW-TSIB-CStorePayment/distinfo
@@ -0,0 +1,3 @@
+MD5 (Business-TW-TSIB-CStorePayment-0.02.tar.gz) = e415b51eed73aa2bb69b72693d76e4e9
+SHA256 (Business-TW-TSIB-CStorePayment-0.02.tar.gz) = bf89b10e0d250496a2052a095a0615fc73db42653b7faa24371123f06d82b6f5
+SIZE (Business-TW-TSIB-CStorePayment-0.02.tar.gz) = 19719
diff --git a/finance/p5-Business-TW-TSIB-CStorePayment/pkg-descr b/finance/p5-Business-TW-TSIB-CStorePayment/pkg-descr
new file mode 100644
index 000000000000..e3745077393d
--- /dev/null
+++ b/finance/p5-Business-TW-TSIB-CStorePayment/pkg-descr
@@ -0,0 +1,4 @@
+This module provides utility functions for the convenient store payment
+collection service by TSIB (Taishin International Bank, Taiwan).
+
+WWW: http://search.cpan.org/dist/Business-TW-TSIB-CStorePayment/
diff --git a/finance/p5-Business-TW-TSIB-CStorePayment/pkg-plist b/finance/p5-Business-TW-TSIB-CStorePayment/pkg-plist
new file mode 100644
index 000000000000..3d34e2dc4252
--- /dev/null
+++ b/finance/p5-Business-TW-TSIB-CStorePayment/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/TW/TSIB/CStorePayment/.packlist
+%%SITE_PERL%%/Business/TW/TSIB/CStorePayment.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/TW/TSIB/CStorePayment
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/TW/TSIB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/TW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business
+@dirrmtry %%SITE_PERL%%/Business/TW/TSIB
+@dirrmtry %%SITE_PERL%%/Business/TW
+@dirrmtry %%SITE_PERL%%/Business