aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-06 10:14:34 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-06 10:14:34 +0000
commit5d2b9f69d690d5e732cafd007156d3c9fefda57f (patch)
treefe7cd216e09a0c3e6028fcc0046dcfbda5883d68 /finance
parent0cb595fdf91604dc747a1bfaf47bdd1a6bcd7bfc (diff)
downloadports-5d2b9f69d690d5e732cafd007156d3c9fefda57f.tar.gz
ports-5d2b9f69d690d5e732cafd007156d3c9fefda57f.zip
Notes
Diffstat (limited to 'finance')
-rw-r--r--finance/gnofin/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/finance/gnofin/Makefile b/finance/gnofin/Makefile
index 968b8ebdf541..c30a337e2f81 100644
--- a/finance/gnofin/Makefile
+++ b/finance/gnofin/Makefile
@@ -14,6 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Light-weight GNOME based financial management program
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
@@ -24,14 +25,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnofin.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
- @find ${WRKSRC}/plugins -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|_la_LDFLAGS =|_la_LDFLAGS = -avoid-version|g'
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ -e 's|DATADIRNAME=lib|DATADIRNAME=share|g' \
+ -e 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|' \
+ -e 's|$$(top_builddir)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|$$(datadir)/gnome/|$$(datadir)/|g' \
+ -e ' s|$$(datadir)/locale|$$(prefix)/share/locale|g'
+ @{FIND} ${WRKSRC}/plugins -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e 's|_la_LDFLAGS =|_la_LDFLAGS = -avoid-version|g'
.include <bsd.port.mk>