aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-16 15:12:41 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-05-16 15:23:45 +0000
commit9a9fd92310e4ee75fae514a9690fdd12f16f8d7c (patch)
tree4e7abe839e1b20beee79d72f1d8909fc8cb492e9 /finance
parenta65230a557b6d22e1edc7acf4c1a67038633e530 (diff)
downloadports-9a9fd92310e4ee75fae514a9690fdd12f16f8d7c.tar.gz
ports-9a9fd92310e4ee75fae514a9690fdd12f16f8d7c.zip
finance/py-mplfinance: Add py-mplfinance 0.12.7a17
mplfinance provides matplotlib utilities for the visualization, and visual analysis, of financial data. WWW: https://github.com/matplotlib/mplfinance
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/py-mplfinance/Makefile23
-rw-r--r--finance/py-mplfinance/distinfo3
-rw-r--r--finance/py-mplfinance/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 019b5f241fa1..1e74de75b6fc 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -93,6 +93,7 @@
SUBDIR += py-backtrader
SUBDIR += py-bitcoin
SUBDIR += py-ebaysdk
+ SUBDIR += py-mplfinance
SUBDIR += py-ofxparse
SUBDIR += py-pycoin
SUBDIR += py-python-bitcoinlib
diff --git a/finance/py-mplfinance/Makefile b/finance/py-mplfinance/Makefile
new file mode 100644
index 000000000000..3e788fd061dd
--- /dev/null
+++ b/finance/py-mplfinance/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= mplfinance
+PORTVERSION= 0.12.7a17
+CATEGORIES= finance python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Utilities for the visualization, and visual analysis, of financial data
+
+LICENSE= PSFL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0,1:math/py-pandas@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-mplfinance/distinfo b/finance/py-mplfinance/distinfo
new file mode 100644
index 000000000000..0ee1896a34b6
--- /dev/null
+++ b/finance/py-mplfinance/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620928533
+SHA256 (mplfinance-0.12.7a17.tar.gz) = 0331fb99ca10fe59e8870c477603ef21365f8975f0d7288701a32c02d010db24
+SIZE (mplfinance-0.12.7a17.tar.gz) = 59401
diff --git a/finance/py-mplfinance/pkg-descr b/finance/py-mplfinance/pkg-descr
new file mode 100644
index 000000000000..0428fce495a7
--- /dev/null
+++ b/finance/py-mplfinance/pkg-descr
@@ -0,0 +1,4 @@
+mplfinance provides matplotlib utilities for the visualization, and visual
+analysis, of financial data.
+
+WWW: https://github.com/matplotlib/mplfinance