aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
commitaa7a6c429ea62d972467d6755fa7a6f52256b452 (patch)
tree3c451883d3bd4d2ffe401b2b6aee58825505d145 /finance
parentc3b3e6a10d663bc2672cdd4bf46943046d03ecba (diff)
downloadports-aa7a6c429ea62d972467d6755fa7a6f52256b452.tar.gz
ports-aa7a6c429ea62d972467d6755fa7a6f52256b452.zip
Drop python 2.7 support from a few ports
With hat: portmgr
Notes
Notes: svn path=/head/; revision=559531
Diffstat (limited to 'finance')
-rw-r--r--finance/py-backtrader/Makefile2
-rw-r--r--finance/py-bitcoin/Makefile2
-rw-r--r--finance/py-ebaysdk/Makefile2
-rw-r--r--finance/py-pycoin/Makefile2
-rw-r--r--finance/py-python-obelisk/Makefile2
-rw-r--r--finance/py-stripe/Makefile2
-rw-r--r--finance/py-ta-lib/Makefile2
-rw-r--r--finance/py-vatnumber/Makefile2
-rw-r--r--finance/py-ystockquote/Makefile2
9 files changed, 9 insertions, 9 deletions
diff --git a/finance/py-backtrader/Makefile b/finance/py-backtrader/Makefile
index 8581e867ab6d..fa25bbfe8db1 100644
--- a/finance/py-backtrader/Makefile
+++ b/finance/py-backtrader/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_GITHUB= yes # Does not distribute sdist via PyPI
USE_PYTHON= autoplist concurrent distutils
diff --git a/finance/py-bitcoin/Makefile b/finance/py-bitcoin/Makefile
index 9b79f886c073..b551f08cc409 100644
--- a/finance/py-bitcoin/Makefile
+++ b/finance/py-bitcoin/Makefile
@@ -13,7 +13,7 @@ COMMENT= Python Bitcoin Tools
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/finance/py-ebaysdk/Makefile b/finance/py-ebaysdk/Makefile
index 737f3660e3d5..d52e123c0238 100644
--- a/finance/py-ebaysdk/Makefile
+++ b/finance/py-ebaysdk/Makefile
@@ -14,7 +14,7 @@ LICENSE= CDDL
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/finance/py-pycoin/Makefile b/finance/py-pycoin/Makefile
index acc0be06f51b..7ed9d6ce24ba 100644
--- a/finance/py-pycoin/Makefile
+++ b/finance/py-pycoin/Makefile
@@ -13,7 +13,7 @@ COMMENT= Utilities for Bitcoin and altcoin addresses/transaction manipulation
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/finance/py-python-obelisk/Makefile b/finance/py-python-obelisk/Makefile
index e0bebbfeac0c..9edbc4e6fd4c 100644
--- a/finance/py-python-obelisk/Makefile
+++ b/finance/py-python-obelisk/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}twisted>0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyzmq>=14.5.0:net/py-pyzmq@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/finance/py-stripe/Makefile b/finance/py-stripe/Makefile
index 85cdebfc325d..2b9e5e1a04d5 100644
--- a/finance/py-stripe/Makefile
+++ b/finance/py-stripe/Makefile
@@ -19,7 +19,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.4:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-mock>=1.7:devel/py-pytest-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>=1.22:devel/py-pytest-xdist@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/finance/py-ta-lib/Makefile b/finance/py-ta-lib/Makefile
index 079c5bb7386c..0d32ee09e323 100644
--- a/finance/py-ta-lib/Makefile
+++ b/finance/py-ta-lib/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libta_lib.so:devel/ta-lib
RUN_DEPENDS= ${PYNUMPY}
-USES= python
+USES= python:3.6+
MAKE_ENV= TA_INCLUDE_PATH="${LOCALBASE}/include"
diff --git a/finance/py-vatnumber/Makefile b/finance/py-vatnumber/Makefile
index d61afb0bd3a2..85c48f93badb 100644
--- a/finance/py-vatnumber/Makefile
+++ b/finance/py-vatnumber/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stdnum>=1.1:devel/py-stdnum@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/finance/py-ystockquote/Makefile b/finance/py-ystockquote/Makefile
index f053def0b052..adfc3fc01d23 100644
--- a/finance/py-ystockquote/Makefile
+++ b/finance/py-ystockquote/Makefile
@@ -12,7 +12,7 @@ COMMENT= Python module to retrieve stock quote data from Yahoo Finance
LICENSE= LGPL21
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>