aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-09-02 03:43:59 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-09-02 03:43:59 +0000
commitc45af0804c1c73bbdd3f6f71ee9e18ad1160934a (patch)
treeba4a7c704b16a4dc1661bda9a8c2e289caa88105 /finance
parent82391a3eb5fdad07dd0ef5caf3f39665b9341d0d (diff)
downloadports-c45af0804c1c73bbdd3f6f71ee9e18ad1160934a.tar.gz
ports-c45af0804c1c73bbdd3f6f71ee9e18ad1160934a.zip
Ensure that there is only one variable definition per each object, as
the C (and C++) standards mandated for years and compilers started to enforce as of recently (Clang 11, GCC 10). Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=547315
Diffstat (limited to 'finance')
-rw-r--r--finance/beanie/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/finance/beanie/Makefile b/finance/beanie/Makefile
index afff393a1db6..126e20d3ec7e 100644
--- a/finance/beanie/Makefile
+++ b/finance/beanie/Makefile
@@ -22,5 +22,8 @@ MAKE_JOBS_UNSAFE= yes
post-patch:
@${CP} ${WRKSRC}/beanie.mk.sample ${WRKSRC}/beanie.mk
@${CP} ${WRKSRC}/tmac/lhead.sample.r ${WRKSRC}/tmac/lhead.r
+# Fix the build with -fno-common (for Clang 11 and GCC 10)
+ @${REINPLACE_CMD} -e 's,int[[:blank:]]*itemno,extern &,' \
+ ${WRKSRC}/import/salesorder.c
.include <bsd.port.mk>