aboutsummaryrefslogtreecommitdiff
path: root/french/med
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2012-07-07 15:15:57 +0000
committerThierry Thomas <thierry@FreeBSD.org>2012-07-07 15:15:57 +0000
commit5721174f8191ab30e3d69d64b7e8ac3275e16c79 (patch)
tree8efbb400cfb2c20ac0a27ad0714c391b17f2644b /french/med
parentfad6a6b2b812de0c4943215de953247ad6fe8ab1 (diff)
downloadports-5721174f8191ab30e3d69d64b7e8ac3275e16c79.tar.gz
ports-5721174f8191ab30e3d69d64b7e8ac3275e16c79.zip
Upgrade Code_Aster to 10.6.0-3.
Notes
Notes: svn path=/head/; revision=300604
Diffstat (limited to 'french/med')
-rw-r--r--french/med/Makefile19
-rw-r--r--french/med/files/patch-config_ltmain.sh11
-rw-r--r--french/med/files/patch-include::med_outils.h10
-rw-r--r--french/med/files/patch-include_2.3.6_med_outils.h11
-rw-r--r--french/med/files/patch-src::ci::MEDunvCr.c27
-rw-r--r--french/med/files/patch-src_2.3.6_ci_MEDunvCr.c15
-rw-r--r--french/med/files/patch-tests_f_2.3.1_Makefile.am12
-rw-r--r--french/med/files/patch-tests_f_2.3.1_Makefile.in12
-rw-r--r--french/med/files/patch-tests_f_2.3.2_Makefile.am12
-rw-r--r--french/med/files/patch-tests_f_2.3.2_Makefile.in12
-rw-r--r--french/med/files/patch-tests_f_Makefile.am12
-rw-r--r--french/med/files/patch-tests_f_Makefile.in12
-rw-r--r--french/med/pkg-plist25
13 files changed, 69 insertions, 121 deletions
diff --git a/french/med/Makefile b/french/med/Makefile
index d25836a3f26b..792de1a7d81c 100644
--- a/french/med/Makefile
+++ b/french/med/Makefile
@@ -6,19 +6,18 @@
#
PORTNAME= med
-DISTVERSION= 2.3.6
-PORTREVISION= 4
+DISTVERSION= 3.0.4
CATEGORIES= french science
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= thierry@FreeBSD.org
COMMENT= Modelisation et Echanges de Donnees
+LICENSE= GPLv3
+
BUILD_DEPENDS= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
LIB_DEPENDS= hdf5.7:${PORTSDIR}/science/hdf5-18
RUN_DEPENDS= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${SHORT_TK_VER}
-LICENSE= GPLv3
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
TK_VER?= 8.5
@@ -37,7 +36,7 @@ USE_GMAKE= yes
USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
-DOC2FIX= . gif html jpg png tests
+DOC2FIX= . dox gif html html.dox jpg png
TST2FIX= c f
PORTDOCS= *
@@ -55,10 +54,12 @@ pre-configure:
${REINPLACE_CMD} -e 's|docdir = $$(datadir)/doc|docdir = @docdir@|' \
${WRKSRC}/doc/${dd}/Makefile.${ext}
. endfor
-. for dd in ${TST2FIX}
+.endfor
+.for dd in ${TST2FIX}
+ ${FIND} ${WRKSRC}/tests -name "Makefile.*" | ${XARGS} \
${REINPLACE_CMD} -e 's|test${dd}dir = $$(bindir)/test|test${dd}dir = ${EXAMPLESDIR}/test|' \
- ${WRKSRC}/tests/${dd}/Makefile.${ext}
-. endfor
+ -e 's|unittestsdir = $$(bindir)/unit|unittestsdir = ${EXAMPLESDIR}/unit|' \
+ -e 's|usescasesdir = $$(bindir)/uses|usescasesdir = ${EXAMPLESDIR}/uses|'
.endfor
post-install:
diff --git a/french/med/files/patch-config_ltmain.sh b/french/med/files/patch-config_ltmain.sh
new file mode 100644
index 000000000000..02cae670602b
--- /dev/null
+++ b/french/med/files/patch-config_ltmain.sh
@@ -0,0 +1,11 @@
+--- ./config/ltmain.sh.orig 2011-11-03 15:35:55.000000000 +0100
++++ ./config/ltmain.sh 2011-12-26 21:19:08.000000000 +0100
+@@ -4160,7 +4160,7 @@
+ # include <io.h>
+ # endif
+ #endif
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <stdarg.h>
+ #include <assert.h>
+ #include <string.h>
diff --git a/french/med/files/patch-include::med_outils.h b/french/med/files/patch-include::med_outils.h
index bd8370cdb58d..d2d797e71fae 100644
--- a/french/med/files/patch-include::med_outils.h
+++ b/french/med/files/patch-include::med_outils.h
@@ -1,11 +1,11 @@
---- include/med_outils.h.orig Wed Nov 17 15:05:46 2004
-+++ include/med_outils.h Sat Jan 8 22:51:32 2005
-@@ -152,7 +152,7 @@
- #define MED_TAILLE_LIENS 7
+--- include/med_outils.h.orig 2011-07-28 15:11:41.000000000 +0200
++++ include/med_outils.h 2011-12-26 19:27:12.000000000 +0100
+@@ -241,7 +241,7 @@
/*Pour eviter le bug solaris*/
+ #ifndef __APPLE__
-#include <malloc.h>
+#include <stdlib.h>
+ #endif
/* Interface des routines du composant tools */
- #include <med_misc.h>
diff --git a/french/med/files/patch-include_2.3.6_med_outils.h b/french/med/files/patch-include_2.3.6_med_outils.h
new file mode 100644
index 000000000000..b5e5d4c5bdf1
--- /dev/null
+++ b/french/med/files/patch-include_2.3.6_med_outils.h
@@ -0,0 +1,11 @@
+--- include/2.3.6/med_outils.h.orig 2011-04-13 16:19:53.000000000 +0200
++++ include/2.3.6/med_outils.h 2011-12-26 21:14:25.000000000 +0100
+@@ -157,7 +157,7 @@
+
+ /*Pour eviter le bug solaris*/
+ #ifndef __APPLE__
+-#include <malloc.h>
++#include <stdlib.h>
+ #endif
+
+
diff --git a/french/med/files/patch-src::ci::MEDunvCr.c b/french/med/files/patch-src::ci::MEDunvCr.c
deleted file mode 100644
index 4312f999de4b..000000000000
--- a/french/med/files/patch-src::ci::MEDunvCr.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- ./src/ci/MEDunvCr.c.orig 2009-07-06 17:49:32.000000000 +0200
-+++ ./src/ci/MEDunvCr.c 2010-01-31 14:20:10.000000000 +0100
-@@ -50,6 +50,12 @@
-
- #endif
-
-+#ifdef __FreeBSD__
-+#include <sys/types.h>
-+#include <unistd.h>
-+#include <pwd.h>
-+#endif
-+
- med_err
- MEDunvCr(med_idt fid, char *maa)
- {
-@@ -100,7 +106,11 @@
- goto ERROR;
- }
- strcat(nomu,mypasswd->pw_name);*/
-+# ifdef __FreeBSD__
-+ if ( !getpwuid(geteuid()) ) {
-+# else
- if ( !cuserid(nomu) ) {
-+# endif
- MESSAGE("Impossible d'obtenir le nom de l'utilisateur effectif");
- goto ERROR;
- }
diff --git a/french/med/files/patch-src_2.3.6_ci_MEDunvCr.c b/french/med/files/patch-src_2.3.6_ci_MEDunvCr.c
new file mode 100644
index 000000000000..ca4b1f4b1d74
--- /dev/null
+++ b/french/med/files/patch-src_2.3.6_ci_MEDunvCr.c
@@ -0,0 +1,15 @@
+--- ./src/2.3.6/ci/MEDunvCr.c.orig 2011-10-20 19:12:46.000000000 +0200
++++ ./src/2.3.6/ci/MEDunvCr.c 2011-12-26 19:32:03.000000000 +0100
+@@ -55,6 +55,12 @@
+
+ #endif
+
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <unistd.h>
++#include <pwd.h>
++#endif
++
+ med_err
+ MEDunvCr(med_idt fid, char *maa)
+ {
diff --git a/french/med/files/patch-tests_f_2.3.1_Makefile.am b/french/med/files/patch-tests_f_2.3.1_Makefile.am
deleted file mode 100644
index e43c301f2aed..000000000000
--- a/french/med/files/patch-tests_f_2.3.1_Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- tests/f/2.3.1/Makefile.am.orig 2007-12-17 18:44:05.000000000 +0100
-+++ tests/f/2.3.1/Makefile.am 2008-03-22 22:38:41.000000000 +0100
-@@ -9,7 +9,8 @@
-
- if WITHF90
-
--myTESTS_LEC = ../test5.sh ../test7.sh ../test9.sh \
-+# FreeBSD: test9.sh disabled because test8.med seems invalid
-+myTESTS_LEC = ../test5.sh ../test7.sh \
- test11.sh ../test13.sh ../test15.sh ../test17.sh \
- ../test30.sh
-
diff --git a/french/med/files/patch-tests_f_2.3.1_Makefile.in b/french/med/files/patch-tests_f_2.3.1_Makefile.in
deleted file mode 100644
index d0e052a4bb3e..000000000000
--- a/french/med/files/patch-tests_f_2.3.1_Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- tests/f/2.3.1/Makefile.in.orig 2008-02-08 15:21:54.000000000 +0100
-+++ tests/f/2.3.1/Makefile.in 2008-03-23 00:30:47.000000000 +0100
-@@ -221,7 +221,8 @@
-
- AM_LDFLAGS = $(FTLDFLAGS)
- AM_LIBTOOLFLAGS = --tag=F77
--@WITHF90_TRUE@myTESTS_LEC = ../test5.sh ../test7.sh ../test9.sh \
-+# FreeBSD: test9.sh disabled because test8.med seems invalid
-+@WITHF90_TRUE@myTESTS_LEC = ../test5.sh ../test7.sh \
- @WITHF90_TRUE@ test11.sh ../test13.sh ../test15.sh ../test17.sh \
- @WITHF90_TRUE@ ../test30.sh
-
diff --git a/french/med/files/patch-tests_f_2.3.2_Makefile.am b/french/med/files/patch-tests_f_2.3.2_Makefile.am
deleted file mode 100644
index e93dae71efbb..000000000000
--- a/french/med/files/patch-tests_f_2.3.2_Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- tests/f/2.3.2/Makefile.am.orig 2007-12-18 12:34:30.000000000 +0100
-+++ tests/f/2.3.2/Makefile.am 2008-03-22 23:11:40.000000000 +0100
-@@ -9,7 +9,8 @@
-
- if WITHF90
-
--myTESTS_LEC = ../test5.sh ../test7.sh ../test9.sh \
-+# FreeBSD: test9.sh disabled because test8.med seems invalid
-+myTESTS_LEC = ../test5.sh ../test7.sh \
- test11.sh ../test13.sh ../test15.sh ../test17.sh \
- ../test30.sh
-
diff --git a/french/med/files/patch-tests_f_2.3.2_Makefile.in b/french/med/files/patch-tests_f_2.3.2_Makefile.in
deleted file mode 100644
index 42d55d91a41b..000000000000
--- a/french/med/files/patch-tests_f_2.3.2_Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- tests/f/2.3.2/Makefile.in.orig 2008-02-08 15:21:55.000000000 +0100
-+++ tests/f/2.3.2/Makefile.in 2008-03-23 00:32:04.000000000 +0100
-@@ -221,7 +221,8 @@
-
- AM_LDFLAGS = $(FTLDFLAGS)
- AM_LIBTOOLFLAGS = --tag=F77
--@WITHF90_TRUE@myTESTS_LEC = ../test5.sh ../test7.sh ../test9.sh \
-+# FreeBSD: test9.sh disabled because test8.med seems invalid
-+@WITHF90_TRUE@myTESTS_LEC = ../test5.sh ../test7.sh \
- @WITHF90_TRUE@ test11.sh ../test13.sh ../test15.sh ../test17.sh \
- @WITHF90_TRUE@ ../test30.sh
-
diff --git a/french/med/files/patch-tests_f_Makefile.am b/french/med/files/patch-tests_f_Makefile.am
deleted file mode 100644
index be649de47b5d..000000000000
--- a/french/med/files/patch-tests_f_Makefile.am
+++ /dev/null
@@ -1,12 +0,0 @@
---- tests/f/Makefile.am.orig 2007-12-17 18:44:03.000000000 +0100
-+++ tests/f/Makefile.am 2008-03-22 22:51:36.000000000 +0100
-@@ -19,7 +19,8 @@
-
- mycheckPROGRAMS = test5 test7 test9 test11 test13 test15 test17 test30
-
--myTESTS_LEC = test5.sh test7.sh test9.sh test11.sh test13.sh test15.sh test17.sh test30.sh
-+# FreeBSD: test9.sh disabled because test8.med seems invalid
-+myTESTS_LEC = test5.sh test7.sh test11.sh test13.sh test15.sh test17.sh test30.sh
-
- test5_SOURCES = test5.f90
- ##test5_LINK = $(LIBTOOL) --mode=link $(F90) $(AM_FFLAGS) \
diff --git a/french/med/files/patch-tests_f_Makefile.in b/french/med/files/patch-tests_f_Makefile.in
deleted file mode 100644
index ea718b0b25b7..000000000000
--- a/french/med/files/patch-tests_f_Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- tests/f/Makefile.in.orig 2008-02-08 15:21:56.000000000 +0100
-+++ tests/f/Makefile.in 2008-03-23 00:29:37.000000000 +0100
-@@ -387,7 +387,8 @@
- AM_LIBTOOLFLAGS = --tag=F77
- testfdir = $(bindir)/testf
- @WITHF90_TRUE@mycheckPROGRAMS = test5 test7 test9 test11 test13 test15 test17 test30
--@WITHF90_TRUE@myTESTS_LEC = test5.sh test7.sh test9.sh test11.sh test13.sh test15.sh test17.sh test30.sh
-+# FreeBSD: test9.sh disabled because test8.med seems invalid
-+@WITHF90_TRUE@myTESTS_LEC = test5.sh test7.sh test11.sh test13.sh test15.sh test17.sh test30.sh
- @WITHF90_TRUE@test5_SOURCES = test5.f90
- @WITHF90_TRUE@test7_SOURCES = test7.f90
- @WITHF90_TRUE@test9_SOURCES = test9.f90
diff --git a/french/med/pkg-plist b/french/med/pkg-plist
index 94aef3aa08cb..cab84f9f5caf 100644
--- a/french/med/pkg-plist
+++ b/french/med/pkg-plist
@@ -1,13 +1,25 @@
bin/mdump
+bin/mdump3
bin/medconforme
bin/medimport
bin/xmdump
+bin/xmdump3
+include/2.3.6/MEDerreur.hxx
+include/2.3.6/med.h
+include/2.3.6/med.hf
+include/2.3.6/med23v30.h
+include/2.3.6/med23v30_proto.h
+include/2.3.6/medC_win_dll.h
+include/2.3.6/med_exit_if.h
+include/2.3.6/med_proto.h
+include/2.3.6/med_utils.h
include/MEDerreur.hxx
include/MEDimport.h
include/MEDimport.hxx
include/med.h
include/med.hf
include/medC_win_dll.h
+include/med_err.h
include/med_exit_if.h
include/med_proto.h
include/med_utils.h
@@ -16,17 +28,14 @@ include/medimportcxx_win_dll.h
lib/libmed.a
lib/libmed.la
lib/libmed.so
-lib/libmed.so.2
-lib/libmed2.settings
+lib/libmed.so.4
+lib/libmed3.settings
lib/libmedC.a
lib/libmedC.la
lib/libmedC.so
-lib/libmedC.so.2
+lib/libmedC.so.4
lib/libmedimport.a
lib/libmedimport.la
lib/libmedimport.so
-lib/libmedimport.so.0
-lib/libmedimportcxx.a
-lib/libmedimportcxx.la
-lib/libmedimportcxx.so
-lib/libmedimportcxx.so.0
+lib/libmedimport.so.2
+@dirrm include/2.3.6