aboutsummaryrefslogtreecommitdiff
path: root/french/verbiste
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-29 18:40:51 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-29 18:40:51 +0000
commita6ecbdcfbdc93d32d7277c90cde11ec8483884d1 (patch)
tree88b271c0386c2fb893ebe970a2c87a332f4ff64d /french/verbiste
parent0d5f060d265d95298a5113bf9d82e496d9c3b6ca (diff)
downloadports-a6ecbdcfbdc93d32d7277c90cde11ec8483884d1.tar.gz
ports-a6ecbdcfbdc93d32d7277c90cde11ec8483884d1.zip
Add verbiste and gnome-verbiste.
Verbiste is a French conjugation system. It contains a C++ library, and two programs that can be run from the command line or from another program. The knowledge base is represented in XML and contains over 6800 verbs. GNOME Verbiste is a GNOME frontend to the Verbiste French conjugation system. It contains a GNOME program and a GNOME Panel applet. This applet shows a text field in the GNOME Panel where the user can enter a conjugated verb and obtain its complete conjugation. WWW: http://sarrazip.com/dev/verbiste.html PR: ports/89407 Submitted by: Dan Phillips <dan-ports@dp.id.au>
Notes
Notes: svn path=/head/; revision=149925
Diffstat (limited to 'french/verbiste')
-rw-r--r--french/verbiste/Makefile46
-rw-r--r--french/verbiste/distinfo3
-rw-r--r--french/verbiste/files/lib-patch-Makefile.in15
-rw-r--r--french/verbiste/files/lib-patch-src_verbiste_FrenchVerbDictionary.cpp20
-rw-r--r--french/verbiste/files/patch-configure16
-rw-r--r--french/verbiste/pkg-descr5
-rw-r--r--french/verbiste/pkg-plist32
7 files changed, 137 insertions, 0 deletions
diff --git a/french/verbiste/Makefile b/french/verbiste/Makefile
new file mode 100644
index 000000000000..00ff965a95c8
--- /dev/null
+++ b/french/verbiste/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: verbiste
+# Date created: 16 November 2005
+# Whom: Dan Phillips <dan-ports@dp.id.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= verbiste
+PORTVERSION= 0.1.13
+CATEGORIES= french textproc
+MASTER_SITES= http://www3.sympatico.ca/sarrazip/dev/
+
+MAINTAINER= dan-ports@dp.id.au
+COMMENT?= French verb conjugator/deconjugator
+
+USE_GETTEXT= yes
+USE_GNOME+= gnomehack ltverhack libxml2
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+.if !defined(PKGNAMEPREFIX)
+
+USE_GETOPT_LONG=yes
+USE_ICONV= yes
+INSTALLS_SHLIB= yes
+
+MAN1= french-conjugator.1 french-deconjugator.1
+MAN3= verbiste.3
+MANLANG= "" fr
+
+EXTRA_PATCHES= ${FILESDIR}/lib-patch-*
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in README *.java *.c
+ ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${EXAMPLESDIR}
+.endfor
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${EXAMPLESDIR}
+
+.endif
+
+.include <bsd.port.mk>
diff --git a/french/verbiste/distinfo b/french/verbiste/distinfo
new file mode 100644
index 000000000000..7c3f491a44fc
--- /dev/null
+++ b/french/verbiste/distinfo
@@ -0,0 +1,3 @@
+MD5 (verbiste-0.1.13.tar.gz) = 972ae6c8136761e51755f6c193ab0626
+SHA256 (verbiste-0.1.13.tar.gz) = efe004056b82aef286b3c835b44b19e821e1b7bf3644f51bae7c4f4d2fc22185
+SIZE (verbiste-0.1.13.tar.gz) = 549663
diff --git a/french/verbiste/files/lib-patch-Makefile.in b/french/verbiste/files/lib-patch-Makefile.in
new file mode 100644
index 000000000000..06e07971ead0
--- /dev/null
+++ b/french/verbiste/files/lib-patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig Tue Nov 29 16:23:13 2005
++++ Makefile.in Tue Nov 29 16:23:33 2005
+@@ -277,11 +277,9 @@
+ data/conjugation-fr.xml \
+ data/verbs-fr.xml
+
+-docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
++docdir = $(datadir)/doc/$(PACKAGE)
+ doc_DATA = \
+ AUTHORS \
+- COPYING \
+- INSTALL \
+ NEWS \
+ README \
+ TODO \
diff --git a/french/verbiste/files/lib-patch-src_verbiste_FrenchVerbDictionary.cpp b/french/verbiste/files/lib-patch-src_verbiste_FrenchVerbDictionary.cpp
new file mode 100644
index 000000000000..1b9d71d845c4
--- /dev/null
+++ b/french/verbiste/files/lib-patch-src_verbiste_FrenchVerbDictionary.cpp
@@ -0,0 +1,20 @@
+--- src/verbiste/FrenchVerbDictionary.cpp.orig Sun Mar 13 14:03:26 2005
++++ src/verbiste/FrenchVerbDictionary.cpp Sat Nov 5 21:32:23 2005
+@@ -655,7 +655,7 @@
+ char *inbuf = strcpy(new char[inbytesleft], latin1String.c_str());
+ char *outbuf = new char[outbytesleft];
+
+- char *in = inbuf;
++ const char *in = inbuf;
+ char *out = outbuf;
+ if (iconv(toUTF8, &in, &inbytesleft, &out, &outbytesleft) == (size_t) -1)
+ {
+@@ -681,7 +681,7 @@
+ char *inbuf = strcpy(new char[inbytesleft], utf8String.c_str());
+ char *outbuf = new char[outbytesleft];
+
+- char *in = inbuf;
++ const char *in = inbuf;
+ char *out = outbuf;
+ if (iconv(toLatin1, &in, &inbytesleft, &out, &outbytesleft) == (size_t) -1)
+ {
diff --git a/french/verbiste/files/patch-configure b/french/verbiste/files/patch-configure
new file mode 100644
index 000000000000..9381d1315f6c
--- /dev/null
+++ b/french/verbiste/files/patch-configure
@@ -0,0 +1,16 @@
+--- configure.orig Wed Nov 23 13:10:32 2005
++++ configure Wed Nov 23 13:10:55 2005
+@@ -23960,12 +23960,11 @@
+ #ifdef __cplusplus
+ "C"
+ #endif
+-const char *_nl_expand_alias ();
+ int
+ main ()
+ {
+ bindtextdomain ("", "");
+-return (int) gettext ("") + _nl_msg_cat_cntr + *_nl_expand_alias (0)
++return (int) gettext ("") + _nl_msg_cat_cntr
+ ;
+ return 0;
+ }
diff --git a/french/verbiste/pkg-descr b/french/verbiste/pkg-descr
new file mode 100644
index 000000000000..380e8fd5f61c
--- /dev/null
+++ b/french/verbiste/pkg-descr
@@ -0,0 +1,5 @@
+Verbiste is a French conjugation system. It contains a C++ library, and two
+programs that can be run from the command line or from another program. The
+knowledge base is represented in XML and contains over 6800 verbs.
+
+WWW: http://sarrazip.com/dev/verbiste.html
diff --git a/french/verbiste/pkg-plist b/french/verbiste/pkg-plist
new file mode 100644
index 000000000000..e3d7e10c5e94
--- /dev/null
+++ b/french/verbiste/pkg-plist
@@ -0,0 +1,32 @@
+bin/french-conjugator
+bin/french-deconjugator
+include/verbiste-0.1/verbiste/FrenchVerbDictionary.h
+include/verbiste-0.1/verbiste/HashMap.h
+include/verbiste-0.1/verbiste/Trie.cpp
+include/verbiste-0.1/verbiste/Trie.h
+include/verbiste-0.1/verbiste/c-api.h
+include/verbiste-0.1/verbiste/misc-types.h
+lib/libverbiste-0.1.a
+lib/libverbiste-0.1.so
+lib/libverbiste-0.1.so.0
+libdata/pkgconfig/verbiste-0.1.pc
+share/locale/fr/LC_MESSAGES/verbiste.mo
+share/verbiste-0.1/conjugation-fr.xml
+share/verbiste-0.1/verbs-fr.xml
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/HACKING
+%%DOCSDIR%%/LISEZMOI
+%%DOCSDIR%%/NEWS
+%%DOCSDIR%%/README
+%%DOCSDIR%%/TODO
+%%EXAMPLESDIR%%/FrenchDeconjugatorTester.java
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/conjugator.c
+%%EXAMPLESDIR%%/deconjugator.c
+%%EXAMPLESDIR%%/test-french-deconjugator.pl
+%%EXAMPLESDIR%%/trans-tenses.pl
+@dirrm include/verbiste-0.1/verbiste
+@dirrm include/verbiste-0.1
+@dirrm share/verbiste-0.1
+@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%